LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-04-2010, 11:06 AM   #31
tux_razor
LQ Newbie
 
Registered: Sep 2010
Posts: 2

Rep: Reputation: Disabled

Launchpad hybrid grpahics will show a substantial amount of users with varying distros with the same issues
on Asus and other optimus or hybrid graphics enabled laptops .

Please check the Ubuntu forum as their is a fix by enabling ide compatibility in the bios instead
of UHCI ,this works for the UL80 laptop after a reboot .

As per below ,this may work on the K52 i have heard .


this is how you get g210m to work on ubuntu 9.10 / 10.04.

1. download and install nvidia drivers. (i have only tested the ones in the repos)

2. make sure you got an Xorg.conf that is correct. ( if not, run nvidia-xconfig )

3. reboot into bios (press delete while booting)

4. change the SATA option in the bios from enhanced to compatibility. ( yea, this makes sense? NOT! )

5. boot into linux and smile!

Anyone more then me who want to hit the people who wrote the bios?
running the latest bios. ends with 10.
 
Old 09-04-2010, 11:11 AM   #32
tux_razor
LQ Newbie
 
Registered: Sep 2010
Posts: 2

Rep: Reputation: Disabled
The links which i couldnt post before .

launchpad.net/~hybrid-graphics-linux

http://ubuntu-ky.ubuntuforums.org/sh...1361466&page=2

If the slackware guys find a kernel module that will address this device in dmesg it would be great .

as this device is the mux /controller for the nvidia processor,which responds to
ACPI calls.

See dmesg ;

pci 0000:00:1f.6: found [8086:3b32] class 001180 header type 00
pci 0000:00:1f.6: reg 10: [mem 0xeb004000-0xeb004fff 64bit]
pci 0000:00:1f.6: calling quirk_resource_alignment+0x0/0x1cc
pci 0000:00:1f.6: calling pci_fixup_transparent_bridge+0x0/0x2f
pci 0000:00:1f.6: __pm_runtime_resume()!
pci 0000:00:1f.6: __pm_runtime_resume() returns -11!
pci_bus 0000:00: fixups for bus
pci 0000:00:01.0: scanning [bus 01-01] behind bridge, pass 0
pci_bus 0000:01: scanning bus
pci 0000:01:00.0: found [10de:0a35] class 000300 header type 00

# - 10de:0a35 is the nvidia adapter .

Please post to hybrid graphics launchpad if anyone has any module success with this ,and some parameters.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
(EE) NVIDIA(0): Failed to initialize the NVIDIA Kernel module latino Linux - Hardware 5 06-03-2008 03:55 AM
X fails to initialize the NVIDIA graphics device jimbogray Linux - Hardware 1 04-28-2008 08:07 PM
Debian startx Fatal Error : Failed to initialize core devices TextBrowserAddict Debian 2 08-21-2005 10:42 PM
"Failed to initialize the NVIDIA graphics device" WTH went wrong with driver install Ohmn Mandriva 3 06-29-2004 10:29 PM
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Stan the caddy Linux - Hardware 8 01-18-2004 04:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration