LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-27-2020, 12:52 PM   #316
lioh
Member
 
Registered: Aug 2019
Location: Switzerland
Distribution: Slackware
Posts: 141

Rep: Reputation: Disabled

Thanks for the hint. Concerning the screenlocker, it works now in general with PAM enabled but with the latest Release of enlightenment the lock on suspend function does not work anymore. It was working as expected in 0.23. Do you experience the same issue?
 
Old 05-27-2020, 04:31 PM   #317
Skaendo
Senior Member
 
Registered: Dec 2014
Location: West Texas, USA
Distribution: Slackware64-14.2
Posts: 1,318

Rep: Reputation: Disabled
Quote:
Originally Posted by lioh View Post
Do you have any ideas concerning the network applet? I am currently using nm-cli / nm-tui which is a bit a mess. As connman is not available and I don't know any other alternatives, I would be glad for a hint. Maybe there is a compile option for nm to enable indicator support?
I was using connman on e22 but I have not tried it on e24 as of yet. It's a bit of a process to get it up and working, and it requires 'iwd'.

I had not gotten 'econnman' to work on e22, but I was going to look into it again soon.
 
Old 05-27-2020, 06:16 PM   #318
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware
Posts: 750

Rep: Reputation: 491Reputation: 491Reputation: 491Reputation: 491Reputation: 491
Quote:
Originally Posted by lioh View Post
Thanks for the hint. Concerning the screenlocker, it works now in general with PAM enabled but with the latest Release of enlightenment the lock on suspend function does not work anymore. It was working as expected in 0.23. Do you experience the same issue?
I haven't tested suspend on lock myself.
 
Old 05-31-2020, 02:18 PM   #319
lioh
Member
 
Registered: Aug 2019
Location: Switzerland
Distribution: Slackware
Posts: 141

Rep: Reputation: Disabled
Enlightenment 0.24.1 has been released. Suspend works again as expected.

Quote:
Highlights:
* Optimized keymap response handling to not stall on startup
* Fixed wayland frame request timestamp to be the 0 base same as others
* Fix polkit auth handling when having to auth for non-user UID
* Randr fix to move pointer on-screen if off screen after reconfigure
* Fix non-systemd system suport for resume to not think it's suspended
* Add delay to allow any pending frames to display before suspend
 
1 members found this post helpful.
Old 06-01-2020, 07:00 AM   #320
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware
Posts: 750

Rep: Reputation: 491Reputation: 491Reputation: 491Reputation: 491Reputation: 491
Quote:
Originally Posted by lioh View Post
Enlightenment 0.24.1 has been released. Suspend works again as expected.
Thanks for the heads-up. I've updated my GitHub repository now
https://github.com/matsbtegner/slackENLIGHTENMENT
 
1 members found this post helpful.
Old 06-05-2020, 12:59 PM   #321
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys
Posts: 2,841

Rep: Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926
I have a lot of history with Enlightenment since it was actually my introduction to Linux circa 1997 when OS/2 could substitute Enlightenment for the Presentation Manager. I loved it! That was ages ago and I've tried a sampling (e17, e19) but gave up due to some minor but annoying graphics issues. 0.24.1 is looking really good to me and I really want to try it but I don';t have and will not use sbopkg. Is there a list of dependencies not met by default full install with May -Current so I can do this manually?
 
Old 06-05-2020, 01:17 PM   #322
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 7,113

Rep: Reputation: 4777Reputation: 4777Reputation: 4777Reputation: 4777Reputation: 4777Reputation: 4777Reputation: 4777Reputation: 4777Reputation: 4777Reputation: 4777Reputation: 4777
Quote:
Originally Posted by enorbet View Post
0.24.1 is looking really good to me and I really want to try it but I don';t have and will not use sbopkg. Is there a list of dependencies not met by default full install with May -Current so I can do this manually?
If you look in the enlighten-me.sh script, it shows that it uses sbopkg to install lua, luajit, bullet, and libwebp. Of those, it seems like only the last one, libwebp, is the only added to -current.

If the packages are already installed to your system, then it skips the sbopkg step.
 
Old 06-05-2020, 01:20 PM   #323
Skaendo
Senior Member
 
Registered: Dec 2014
Location: West Texas, USA
Distribution: Slackware64-14.2
Posts: 1,318

Rep: Reputation: Disabled
Quote:
Originally Posted by enorbet View Post
Is there a list of dependencies not met by default full install with May -Current so I can do this manually?
You can compare against what I use. I try to satisfy as may dependencies as I can so YMMV: https://gitlab.com/slackdesk/enlightenment-e24

Also note that some things that I have do NOT work, like epour (probably needs a old version of libtorrent-rasterbar) and econnman.
 
Old 06-05-2020, 08:16 PM   #324
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys
Posts: 2,841

Rep: Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926
Things went really smooth until it failed on VLC. That rascal has about 30 dependencies so... maybe on the weekend.
 
Old 06-06-2020, 11:17 AM   #325
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware
Posts: 750

Rep: Reputation: 491Reputation: 491Reputation: 491Reputation: 491Reputation: 491
Quote:
Originally Posted by enorbet View Post
Things went really smoothly until it failed on VLC. That rascal has about 30 dependencies so... maybe on the weekend.
I use AlienBob's restricted VLC package but VLC and Xine support in emotion have been removed in EFL 1.24.x
https://www.enlightenment.org/news/efl-1.24.0
Quote:
Removals
In this release cycle, we finally cleaned out some corners of our libraries that have been in need of it. We de-duplicated some media backend support and removed beta libraries which never came beyond this stage and libraries which are depending on deprecated or now unsupported components.

emotion & evas: remove gstreamer 0.10 support (gstreamer 1.x support is stable)
Xine and vlc support in emotion (gstreamer 1.x support is stable)

Last edited by mats_b_tegner; 06-06-2020 at 01:42 PM.
 
Old 06-07-2020, 12:16 AM   #326
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys
Posts: 2,841

Rep: Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926Reputation: 2926
Thank you, mats_b_tegner, but I followed what you and bassmadrigal posted just a few posts back. When I ran (as root, of course) "enlighten-me.sh" it failed citing the lack of VLC. What did I miss?
 
Old 06-07-2020, 01:27 PM   #327
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 7,113

Rep: Reputation: 4777Reputation: 4777Reputation: 4777Reputation: 4777Reputation: 4777Reputation: 4777Reputation: 4777Reputation: 4777Reputation: 4777Reputation: 4777Reputation: 4777
Quote:
Originally Posted by enorbet View Post
Thank you, mats_b_tegner, but I followed what you and bassmadrigal posted just a few posts back. When I ran (as root, of course) "enlighten-me.sh" it failed citing the lack of VLC. What did I miss?
vlc doesn't exist in the slackENLIGHTENMENT repo (at least via the search in github), so it's possible that enlightenment is actually looking for it through its deps, but then I'm not sure why you wouldn't be prompted to install it earlier.

What's the actual error? Is it a configure error or one of the scripts bailing since it can't find a vlc Slackware package installed?
 
Old 06-07-2020, 01:29 PM   #328
Patrick59
Member
 
Registered: Apr 2007
Location: North France
Distribution: Slackware since 7.0
Posts: 57

Rep: Reputation: 11
Quote:
Originally Posted by enorbet View Post
Thank you, mats_b_tegner, but I followed what you and bassmadrigal posted just a few posts back. When I ran (as root, of course) "enlighten-me.sh" it failed citing the lack of VLC. What did I miss?
I had the same problem.
I just had to install vlc to be able to install enlightenment.

hth,
 
Old 06-07-2020, 01:50 PM   #329
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware
Posts: 750

Rep: Reputation: 491Reputation: 491Reputation: 491Reputation: 491Reputation: 491
Hmm VLC is still listed under Dependencies on the Enlightenment Download page:
https://www.enlightenment.org/download
Quote:
Dependencies
vlc (for emotion_generic_players)
Edit:
Removed vlc from efl.info on my GitHub repository.

Last edited by mats_b_tegner; 06-07-2020 at 04:53 PM.
 
Old 06-07-2020, 03:14 PM   #330
Skaendo
Senior Member
 
Registered: Dec 2014
Location: West Texas, USA
Distribution: Slackware64-14.2
Posts: 1,318

Rep: Reputation: Disabled
Is this a case of a build time option?
Because I don't use VLC and I can build e24 just fine without it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Enlightenment E19 To Have Full Wayland Support jeremy Linux - News 0 03-19-2014 03:08 PM
LXer: Bodhi Linux 3.0.0 Alpha Release - Give E19 a try LXer Syndicated Linux News 0 03-03-2014 12:51 AM
LXer: Enlightenment E19 Going Into Feature Freeze Soon LXer Syndicated Linux News 0 02-01-2014 06:00 PM
LXer: Enlightenment E19 Can Act As A Wayland Compositor LXer Syndicated Linux News 0 08-25-2013 03:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration