LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-18-2003, 12:58 AM   #1
DarkXtar
Member
 
Registered: Apr 2003
Location: Exeter, Ca.
Distribution: Slackware
Posts: 37

Rep: Reputation: 15
Angry DVD-ROM not detected CD-RW mistaken as CD-ROM Device


Ok all i know is that i have a dvd-rom drive and a cd-rw drive but slackware thinks that my cd-rw is a cd-rom drive and that my dvd-drive doesnt exist i tried the append = ide-scsi in lilo.conf because thats what redhat had when i was using it i just want to burn one little cd under linux and i shouldnt have to do stuff for linux on windows so please someone help. i google searched i checked the slackware linux book at slackware.com nothing out there ever has the answers to my questions either slackware is crap or im some kind of retard. and how am i supposed to know all this stuff automatically? shouldnt everything be automatically configured from the start?
 
Old 04-18-2003, 06:40 AM   #2
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 46
The append statement in /etc/lilo.conf should read as follows

append="hdd=ide-scsi"

Please use the correct identifier for the CDRW drive as required. (hdb,hdc,hdd)
The lilo config has to be written to the hard disk after modification by running the program "lilo". The system then needs to be rebooted for it to actually take effect.

The standard drive designation, like /dev/hdd, will no longer function. You will need to use the generic scsi device, /dev/scd0, for the drive. The sym link /dev/cdrom may point to the DVD drive or the CDRW drive as you desire. To change it use the command similar to below.

ln -sf /dev/scd0 /dev/cdrom #for CDRW
or
ln -sf /dev/hdc /dev/cdrom #for DVD drive

It may be that Slack setup the system using the CD drive that was used during the installation. But I think the ide-scsi statement always has to be entered manually even in the setup program during lilo installation. The /dev/cdrom device is normally used by programs like the KDE apps.

For IDE drives, they might be using "cable select" jumper settings on the IDE bus and that can also cause some confussion. They need to be identified as master/slave.

If using a stock Slack kernel then the ide-scsi option also requires a module to be loaded that is configured to load from the /etc/rc.d/rc.modules script when the system is booted. Check to see if the module has been loaded. Use the "lsmod" command to view the loaded modules. This module will control devices reserved for generic scsi interface.

Once the system is configured for the recorder, then the cdrecord program should be able to see it as an available device. Use the command "cdrecord -scanbus" to view what cdrecord provides as the device identifier. Usually 0,0,0 for the only drive.

If this doesn't help to resolve the problem then post back some kernel messages where it identifies the IDE devices. Generally, after boot up these can be reviewed by using the "dmesg" command.
 
Old 04-18-2003, 01:05 PM   #3
DarkXtar
Member
 
Registered: Apr 2003
Location: Exeter, Ca.
Distribution: Slackware
Posts: 37

Original Poster
Rep: Reputation: 15
lilo.conf:
image = /boot/vmlinuz
root = /dev/hda2
label = Linux-2.4.20
append = "hdd=ide-scsi"

The results of lsmod:
agpgart 35776 3 (autoclean)
nvidia 1466976 10 (autoclean)
parport_pc 14724 1 (autoclean)
lp 6752 0 (autoclean)
parport 23264 1 (autoclean) [parport_pc lp]
usbmouse 2008 0 (unused)
keybdev 1952 0 (unused)
mousedev 4212 0 (unused)
hid 18596 0 (unused)
usbkbd 3416 0 (unused)
input 3200 0 [usbmouse keybdev mousedev hid usbkbd]
printer 7040 0
iptable_mangle 2072 0 (autoclean) (unused)
iptable_nat 14904 0 (autoclean) (unused)
ipt_REJECT 2712 1
ip_conntrack_ftp 3888 0 (unused)
ip_conntrack_irc 2992 0 (unused)
iptable_filter 1644 1
ipt_state 536 4
ip_conntrack 18016 4 [iptable_nat ip_conntrack_ftp ip_conntrack_irc ipt_state]
ip_tables 11768 7 [iptable_mangle iptable_nat ipt_REJECT iptable_filter ipt_state]
i810-tco 3088 0 (unused)
uhci 24560 0 (unused)
usbcore 58144 1 [usbmouse hid usbkbd printer uhci]
i810_audio 21160 0
ac97_codec 9512 0 [i810_audio]
soundcore 3332 2 [i810_audio]
ohci1394 16264 0 (unused)
ieee1394 30828 0 [ohci1394]
eepro100 19316 0 (unused)
mii 2240 0 [eepro100]
pcmcia_core 38112 0
ide-scsi 8048 0
apm 9608 1
ntfs 51040 1 (autoclean)

The results of modprobe:
modprobe: Can't locate module sr_mod
modprobe: Can't locate module scsi_mod

The results of insmod:
insmod: scsi_mod: no module by that name found
insmod: sr_mod: no module by that name found
 
Old 04-18-2003, 01:08 PM   #4
DarkXtar
Member
 
Registered: Apr 2003
Location: Exeter, Ca.
Distribution: Slackware
Posts: 37

Original Poster
Rep: Reputation: 15
SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
md: linear personality registered as nr 1
md: raid0 personality registered as nr 2
md: raid1 personality registered as nr 3
md: raid5 personality registered as nr 4
raid5: measuring checksumming speed
8regs : 2056.800 MB/sec
32regs : 1283.600 MB/sec
pIII_sse : 2335.200 MB/sec
pII_mmx : 2065.600 MB/sec
p5_mmx : 2010.800 MB/sec
raid5: using function: pIII_sse (2335.200 MB/sec)
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
LVM version 1.0.5+(22/07/2002)

I hope this is the part of dmesg that explains the scsi errors.
 
Old 04-18-2003, 01:09 PM   #5
DarkXtar
Member
 
Registered: Apr 2003
Location: Exeter, Ca.
Distribution: Slackware
Posts: 37

Original Poster
Rep: Reputation: 15
I edited lilo.conf. I made the symbolic links in /dev and it looks like /lib/modules/2.4.20/kernel/drivers/scsi doesn't have the correct modules for my cdburner. I don't know what to do next but it looks like I'm going to have to compile a new kernel, thats not good because even though I can build a kernel under 700KB and have it load only the neccessary modules it still runs noticably slower than the default kernel or windows so please somebody help me.
 
Old 04-18-2003, 01:18 PM   #6
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 46
The last post was regarding something trying to load a regular scsi module or something. Not about the IDE probe of the IDE controller. The ide-scsi support is a module and so the kernel load would not report anything about that until after the module is loaded.

Have you tried to run "cdrecord -scanbus" as yet? An IDE CDRW drive normally just uses the generic MMC3 driver from from cdrecord. A CD drive specific driver is not required.

You can also try the following command and see what the scsi is reporting.

cat /proc/scsi/scsi

If it is not found then the generic scsi support still has not been loaded.
 
Old 04-18-2003, 04:06 PM   #7
DarkXtar
Member
 
Registered: Apr 2003
Location: Exeter, Ca.
Distribution: Slackware
Posts: 37

Original Poster
Rep: Reputation: 15
root@linux:/root~# cdrecord -scanbus
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
root@linux:/root~#

root@linux:/root~# cat/proc/scsi/scsi
bash: cat/proc/scsi/scsi: No such file or directory
*ROOT*@unix:/jdtx~# cat /proc/scsi/scsi
Attached devices: none
root@linux:/root~#
 
Old 04-18-2003, 04:40 PM   #8
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 46
Is this a dual boot system? Recently we went through similar scenario with another user that was dual booting but using the MS Windows 2K/XP boot loader instead of lilo.
 
Old 04-18-2003, 05:55 PM   #9
DarkXtar
Member
 
Registered: Apr 2003
Location: Exeter, Ca.
Distribution: Slackware
Posts: 37

Original Poster
Rep: Reputation: 15
Yes I am using the winxp boot loader to chain load to lilo, so could I use a floppy instead? This is interesting. So the win2k/xp bootloader has some kind of effect on how the kernel recognizes certain devices?

Last edited by DarkXtar; 04-18-2003 at 09:31 PM.
 
Old 04-18-2003, 09:30 PM   #10
DarkXtar
Member
 
Registered: Apr 2003
Location: Exeter, Ca.
Distribution: Slackware
Posts: 37

Original Poster
Rep: Reputation: 15
i opened up my box to check and set my jumper settings to discover that my dvd and cd burner are using the same secondary ide bus connector which means my cd burners definitely not a scsi device although whats strange is when i was running redhat it recognized it as scsi which has thrown me off all this time I wonder if their jumpers being set to cable select threw off redhat and caused it to incorrectly identify it as a scsi. Well I can mount both drives now but still not sure on if i can burn cd's on it yet i'm still getting the error: root@linux:/root~# cdrecord -scanbus
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

Sorry about all the confusion, I'm even more confused now.

Last edited by DarkXtar; 04-18-2003 at 09:31 PM.
 
Old 04-19-2003, 12:04 AM   #11
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 46
In Linux, burning CD's has always been restricted to the original spec for SCSI based recorders. When IDE recordable drives were developed, the solution was to simply make the IDE units emulate SCSI devices. That way they did not need to reinvent the wheel. So, your CD recorder is IDE based and using SCSI emulation in Linux. So in a way it is really both.

Now, in regard to your issue on the booting and passing kernel arguments. Whenever, a change is made in the lilo.conf, the lilo program needs to be run to update the boot record. You have done this I believe and the updated boot record was written to the partiton where lilo was installed. However, it is not being read when it is booted. When you decided to use the WinXP boot loader I think you went through a process to transfer the lilo boot loader to the WInXP system for it to load it from a file. It is that last process that also needs to be transferred here again using the new boot table from the partition that lilo updated.

I am not very well informed on the exact details because I have never used the MS boot loader. Another user posted in a prior thread that the process used the dd command I think to transfer the first 512 bytes of the partiton table to a file for WinXP to load. Sounds stupid I know, but it did come from Microsoft. That Slack user also went through the same ordeal that you have trying to get the kernel arguments passed to the kernel because MS does not read the partition table at all. If you continue to use the MS boot loader, then you will need to remember that after the lilo config is written, that the MS boot loader needs to be updated as well.

I think if you update the MS boot record for the Slack partiton and reboot then you will find that your CD recordable drive will be seen properly.

Last edited by Excalibur; 04-19-2003 at 12:07 AM.
 
Old 04-19-2003, 09:06 AM   #12
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Another quick suggestion:

Just use lilo to chain load XP boot loader, it works just fine on my system and many others, requires less work when editing the conf file, and overall is easier to troubleshoot because you don't have 17 bootloaders to determine the error causing one.



Cool
 
Old 04-19-2003, 01:04 PM   #13
DarkXtar
Member
 
Registered: Apr 2003
Location: Exeter, Ca.
Distribution: Slackware
Posts: 37

Original Poster
Rep: Reputation: 15
Well it looks like alls well;

root@linux:root~# cdrecord -scanbus
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.7'
scsibus0:
0,0,0 0) 'LITE-ON ' 'LTR-16102B ' 'OQSB' Removable CD-ROM
0,1,0 1) *
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *
root@linux:root~#

Thanks for the patience and all the help!
 
Old 04-19-2003, 06:09 PM   #14
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 46
Good luck and glad to hear it is working now.
 
Old 05-01-2003, 03:39 AM   #15
canon
Member
 
Registered: Feb 2003
Location: Seattle & N.Ireland
Distribution: Suse 9.current
Posts: 40

Rep: Reputation: 15
i've been following along the process laid out here by Excalibur (thank you for your help on this btw) and here's what's going on with me.
stats: Mandrake9.1 booting lilo to kde3.1

i've modified the append="..." line in /etc/lilo.conf as such:

Image="/boot/vmlinuz
label="linux"
root="/dev/hda7"
initrd=/boot/initrd.img
append="quiet devfs=mount acpi=off hdd=ide-scsi"

the command
#modprobe sr_mod
and
# modprobe scsi_mod
both return a new prompt (no errors, no feedback)

the commands
# insmod scsi_mod
and
# insmod sr_mod
both return:
Using /lib/modules/2.4.21-0.13mdk/kernel/drivers/scsi/sr_mod.o.gz
insmod: a module named sr_mod already exists

so i think those modules are loading correctly.

the output from dmesg however has the following 2 lines:
Kernel command line: BOOT_IMAGE=linux ro root=307 devfs=mount hdc=ide-scsi acpi=off quiet
ide_setup: hdc=ide-scsi

these lines show that somewhere else is calling for hdc rather than hdd! but there is no drive at hdc - there was a while ago, but i never set it up as a burner.

an ls output of /dev shows only the directory scsi (which is empty), no scd0 device, and it still shows hdd as a legitimate device.

is this mis-call what is causing the system to continue not finding the cdr drive at hdd to be not found? what file is causing the call on hdc instead of hdd even after i have changed the /etc/lilo.conf file?
thank you for your help!
if you would rather me do so, i can repost this in a non-slack forum rather than continuing this thread.

Last edited by canon; 05-01-2003 at 03:53 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FC4 shows dvd-rw as cd-rom and cd-rom as cd-rw hjshah Linux - Hardware 1 10-03-2005 05:40 AM
dvd rom drive not detected snip128 Linux - Hardware 5 11-05-2004 11:53 PM
permission denied! floppy cd-rom dvd-rom HELP! OMEGA-DOOM Linux - Software 17 10-15-2004 05:40 PM
DVD-ROM/CD-ROM unable to recognize debain boot CD gottfried Linux - Newbie 2 01-20-2004 12:39 PM
how to add cd-rom, dvd-rom, floppy, hard disk icons on gnome desktop? spyghost Linux - Software 6 09-21-2003 05:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration