LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-26-2005, 02:51 PM   #1
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Rep: Reputation: 45
DVD burning issues


Ok, i've been avoiding these errors because i had 2 dvd burners.. one doesn't like burning DVDs, but burns CDs at '>4x', while the other burns DVDs at 4x max, and refuses to burn CDs... (messy...)

But now i'm temporarely stuck with my laptop's DVD writer, and i think its about time to find the problem.

EDIT I'm on kernel 2.6.11.7, udev 054, k3b 0.11.23, cdrdao 1.1.9, cdrtools 2.01, dvd+rw-tools 5.21.4.10.8. My dvd drive is /dev/hdc (/dev/cdrom).

CDs:
If i burn at 4x or less, it works, but if any faster speed, it fixates then crashes.

DVDs:
data dvd is terrebly slow (3x), while video dvd refuses to work..

An example error
k3b:
mkiso returned an unknown error (code 255)
Unknown error 255
Fatal error at startup: Input/output error

Debug output:
Code:
Devices
-----------------------
SONY DVD+RW DW-P50A 1.8f (/dev/hdc, ) at /mnt/cdrom [CD-R; CD-RW; CD-ROM; DVD-ROM; DVD+R; DVD+RW] [DVD-ROM; DVD+RW; DVD+R; CD-ROM; CD-R; CD-RW] [SAO; TAO; RAW; RAW/R96R]

System
-----------------------
K3b Version: 0.11.23
KDE Version: 3.4.0
QT Version:  3.3.4
Kernel:      2.6.11.7

growisofs
-----------------------
Executing 'builtin_dd if=/dev/fd/0 of=/dev/hdc obs=32k seek=0'
:-( write failed: Input/output error

growisofs comand:
-----------------------
/usr/bin/growisofs -Z /dev/hdc=/dev/fd/0 -use-the-force-luke=notray -use-the-force-luke=tty -dvd-compat -speed=2 

mkisofs
-----------------------
/usr/bin/mkisofs: Warning: -follow-links does not always work correctly; be careful.
/usr/bin/mkisofs: Either VIDEO_TS.IFO or VIDEO_TS.VOB is not of correct size/usr/bin/mkisofs: Unable to parse DVD-Video structures.
/usr/bin/mkisofs: Unable to make a DVD-Video image.

mkisofs comand:
-----------------------
/usr/bin/mkisofs -gui -graft-points -volid PinkPanther1 -volset  -appid  -publisher  -preparer  -sysid  -volset-size 1 -volset-seqno 1 -sort /tmp/kde-root/k3bQGZlhc.tmp -rational-rock -hide-list /tmp/kde-root/k3bS68dVa.tmp -full-iso9660-filenames -follow-links -iso-level 2 -path-list /tmp/kde-root/k3bHAUcfa.tmp -dvd-video /tmp/kde-root/k3bVideoDvd0 /root/.kde/share/apps/k3b/temp/dummydir0/
On a side note, incase this will help solve the problem, the second dvd burner is a USB2 one, so i have scsi emu enabled in the kernel. It's assigned to /dev/sr0 (/dev/dvd)
CD: refuses to burn CDs at all.. gives an error before even trying
DVD: doesn't burn dual layer anymore. Single layer is ok, but terrebly slow.

At one point i had one of these enabled in lilo.conf
#append="hdc=ide-scsi hdd=ide-scsi"
#append="hdc=ide-cd"
But not anymore (i was recommended not to)

I'm stuck.. i don't know where to start.. heh

Some more info...
Code:
root@xushitop:/dev# dmesg | grep hdc
    ide1: BM-DMA at 0x4c48-0x4c4f, BIOS settings: hdc:DMA, hdd:pio
hdc: SONY DVD+RW DW-P50A, ATAPI CD/DVD-ROM drive
hdc: ATAPI 24X DVD-ROM CD-R/RW drive, 8192kB Cache, UDMA(33)
EDIT: Hmm, i'm not sure if this might be an issue or not, but when running k3bsetup, under 'External Programs', it only shows cdrdao, and cdrecord. Should it also show dvd+rw-tools?

Also, in the debug output, it has a line
Executing 'builtin_dd if=/dev/fd/0 ...............
Does this have any relation to my floppy drive?! Coz this laptop doesn't have one..

Last edited by xushi; 04-26-2005 at 03:14 PM.
 
Old 04-26-2005, 05:32 PM   #2
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,154

Rep: Reputation: 698Reputation: 698Reputation: 698Reputation: 698Reputation: 698Reputation: 698
I would suggest enable append="hdc=ide-cd" in lilo.conf, I burns dvd and cd with
this setting with no problem.

On my system the floppy is /dev/floppy/0 and /dev/fd/0 is a symlink pointing to
/dev/pts/1

K3b should show in 'external programs' growisofs, dvd+rw-tools and other like sox,
normalize...if you have them
 
Old 04-27-2005, 04:31 AM   #3
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Original Poster
Rep: Reputation: 45
Quote:
Originally posted by keefaz
I would suggest enable append="hdc=ide-cd" in lilo.conf, I burns dvd and cd with
this setting with no problem.
I'm getting slightly better results with that enabled.

Internal DVD:
data dvd: avarage: It burns, i guess i should be grateful
video dvd: bad: Still same error.
cd: good: Atleast CD burning works properly now

Haven't checked the external burner yet, i'm more interested in the internal one now.

Quote:
K3b should show in 'external programs' growisofs, dvd+rw-tools and other like sox, normalize...if you have them
I do have them all, but I'm not sure why its not showing any of them on mine. Can i somehow manually set it up? Maby this might be the (a?) cause.

Thanks
 
Old 04-27-2005, 05:14 AM   #4
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,154

Rep: Reputation: 698Reputation: 698Reputation: 698Reputation: 698Reputation: 698Reputation: 698
For k3b, go to external programs menus and try the 3rd tab, click search or something similar
also make sure that it lists good search program paths (/usr/bin...)
 
Old 04-27-2005, 05:34 AM   #5
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Original Poster
Rep: Reputation: 45
Quote:
Originally posted by keefaz
For k3b, go to external programs menus and try the 3rd tab, click search or something similar
also make sure that it lists good search program paths (/usr/bin...)
Ah, sorry for the confusion. I was refering to k3bsetup's external programs part. If i go to k3b's external program tab, i see
cdrdao, cdrecord, dvd+rw-format, growisofs, mkisofs, normalize, and many more. But, the issues are still here.

EDIT:
Could it be that i might be missing any important configs in the kernel ?

EDIT 2:
Ok, i think this might not have to do with my DVD burner.. I just tried "Only create ISO image", to check, and it still gives me the same error

Edit 3:
Bah, screw this. i'll restart with another dvd later. Maby the transcoding screwed up the vob files for this one.

Last edited by xushi; 04-27-2005 at 06:14 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Burning DVD using multiple DVD writers desmo Linux - Software 5 04-12-2006 05:15 PM
CD Burning Issues justin_p Slackware 5 07-06-2005 10:54 AM
Burning ISO image (DVD+R, external DVD writer) swan2925 Linux - Software 6 06-02-2005 09:49 AM
burning DVD kaega2 Linux - Software 1 10-20-2004 09:50 PM
DVD::Rip and Burning to DVD lapthorn Linux - Software 4 10-19-2004 01:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration