-   Slackware (
-   -   dvb_core installed but still no /dev/dvb (

jimdaworm 08-08-2004 03:08 AM

dvb_core installed but still no /dev/dvb
According to the dvb documentation that comes with the 2.6.7 kernel the dvb_core module is supposed to make the /dev/dvb stuff... but I have that module loaded but no device, what can I do??


bash-2.05b$ lsmod
Module Size Used by
ppp_deflate 4864 0
zlib_deflate 21144 1 ppp_deflate
bsd_comp 5312 0
ppp_async 9664 1
ppp_generic 21652 7 ppp_deflate,bsd_comp,ppp_async
slhc 6720 1 ppp_generic
stv0299 12872 0
snd_pcm_oss 49064 0
snd_mixer_oss 17344 1 snd_pcm_oss
ipt_state 1536 1
ip_conntrack 29448 1 ipt_state
iptable_filter 2240 1
ip_tables 15808 2 ipt_state,iptable_filter
uhci_hcd 29264 0
nvidia_agp 5852 1
agpgart 27624 2 nvidia_agp
ohci_hcd 18756 0
ehci_hcd 25988 0
snd_intel8x0 30024 0
snd_ac97_codec 66372 1 snd_intel8x0
snd_pcm 84744 2 snd_pcm_oss,snd_intel8x0
snd_timer 21060 1 snd_pcm
snd_page_alloc 8968 2 snd_intel8x0,snd_pcm
snd_mpu401_uart 6144 1 snd_intel8x0
snd_rawmidi 20324 1 snd_mpu401_uart
snd_seq_device 6536 1 snd_rawmidi
snd 45988 9 snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi, snd_seq_device
skystar2 25156 0
dvb_core 79208 2 stv0299,skystar2
crc32 3840 1 dvb_core
nvidia 4818676 12
ide_scsi 14084 0
sr_mod 13924 0
apm 15656 2
rtc 10296 0


drivers/media/dvb/b2c2/skystar2.c: FlexCopII(rev.130) chip found
drivers/media/dvb/b2c2/skystar2.c: the chip has 6 hardware filters
DVB: registering new adapter (Technisat SkyStar2 driver).
probe_tuner: try to attach to Technisat SkyStar2 driver
drivers/media/dvb/frontends/stv0299.c: setup for tuner Samsung TBMU24112IMB
DVB: registering frontend 0:0 (STV0299/TSA5059/SL1935 based).

bash-2.05b$ cat modprobe.conf
# The BTTV module does not load the tuner module automatically,
# so do that in here
#post-install bttv insmod tuner
#post-remove bttv rmmod tuner

#TV Card
#alias char-major-89 i2c-dev
#alias char-major-81 bttv
#options bttv card=78 tuner=32 radio=1

#Satellite TV card

alias skystar skystar2
alias frontend stv0299

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.5 ---
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0
# --- END: Generated by ALSACONF, do not edit. ---

alias char-major-195* nvidia
Any ideas of what I might need to do for devfs to find it??:study:

Mephisto 08-08-2004 08:02 AM

Well since no one else answered I'll take a stab at it. Since you are using a2.6.x kernel with Slackware 10, udev will be in use. My understanding of udev is that since there is not a rule for node creation of the dvb, it won't get added.

You will need to add a line to your /etc/udev/rules.d/udev.rules to create the node.

my guess is that it should be:

KERNEL="dvb"                  NAME="media/%k",  SYMLINK="%k"
This tells udev to map the kernel device whose name matches "dvb" and to create a node for it called "media/dvb" (%k stands fo device name) and to symlink the device to dvb, which is where you are expecting it.

Look in the udev.rules comments for more info as well as man udev.

Mephisto 08-08-2004 08:16 AM

According to udev man page, if no rule is found the default kernel device name should be used, so this the advice above may not help. Is there a dvb_core somewhere in one of the subdirectories maybe?

EDIT: Did a google for "dvb udev" and most of the links seem to say dvb is not supported in udev yet. This one gives a possible answer that might work. There was also one mailing list entry that mentions a patch but I don't know enough about the subject to know if it is applicable. Hopefully that should get you headed in the right direction.

jimdaworm 08-08-2004 03:36 PM

Hey Mephisto, thats for all the info. I think for now what I might just end up doing is running a script in my startup that creates the devices...

I tried the script and editing the udev config file... but nothing worked:confused: All this diffculty is bringing back the good old days about a year ago when I started with linux!

jimdaworm 08-09-2004 05:03 AM

Hey I downloaded the drivers from just to see if they were the same. In the INSTALL file it says

- If you don't use devfs, execute DVB/driver/makedev.napi to create
the device nodes; if you use devfsd, copy drivers/devfsd.conf to
/etc/devfs/conf.d/dvb (exeact location might depend on you distribution).
Maby thats what I am missing... do you know exactly where I should put this devfsd.conf?? (The slack dir structure is different)

jimdaworm 08-13-2004 08:17 AM

I downloaded the cvs of the drivers and these seem to make the missing devices

All times are GMT -5. The time now is 05:51 PM.