Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 04-05-2012, 03:43 AM   #1
Registered: Jul 2006
Location: Gießen, Germany
Distribution: Slackware64-14.2
Posts: 785

Rep: Reputation: 48
dual display problem with xorg.conf

I am running Slackware64-13.37. I have a large monitor connected to a laptop and in practice this is a dual display. The problem is that I have to adjust the screen resolution for the large monitor each time when I start kde from its system settings. This is because I have not adjusted the Xorg.conf properly. Could someone give me hint where my mistake is? The Xorg.conf is attached.

Many thanks in advance.
Attached Files
File Type: txt xorg.conf.txt (2.9 KB, 38 views)
Old 04-05-2012, 04:23 AM   #2
Senior Member
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
You should have only one Screen section and one Device section, but keep the two Monitor sections. Change their Identifiers to whatever 'xrandr' reports for the monitor names (ie. LVDS1, VGA1).

Then, in those Monitor sections, put in the PreferredMode for each monitor. Something along the lines of this:

Section "Monitor"
	Identifier   "LVDS1"
        Option "PreferredMode" "1366x768"

Section "Monitor"
	Identifier   "VGA1"
        Option "PreferredMode" "1680x1050"
You should get rid of the Modes line in the Display SubSection, too.
Old 04-05-2012, 05:14 AM   #3
Alien Bob
Slackware Contributor
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 6,614

Rep: Reputation: 3904Reputation: 3904Reputation: 3904Reputation: 3904Reputation: 3904Reputation: 3904Reputation: 3904Reputation: 3904Reputation: 3904Reputation: 3904Reputation: 3904
Have you considered deleting your xorg.conf altogether? Slackware 13.37 is perfectly capable of auto-configuring X when xorg.conf is absent. I have a laptop with an external monitor connected to it, and use krandrtray in KDE if I need to change anything in the layout.
I have one large desktop split across the two screens.

I have not tried the KDE 4.5.5 of Slackware 13.37 in a long time, but I remember that I had to configure the "native mode" of the two screens, i.e. the monitor's optimal display resolution, every time when I booted up. So the advice by adamk75 (about adding the PreferredMode to xorg.conf) would be good to try out.

The KDE 4.8.2 which I am using nowadays (on slackware-current) works much better in this regard.

Old 04-05-2012, 07:04 AM   #4
Registered: Jul 2006
Location: Gießen, Germany
Distribution: Slackware64-14.2
Posts: 785

Original Poster
Rep: Reputation: 48
Thumbs up

Thank you very much for your advice, it worked perfectly. Now I do not have to adjust the resolution every time I log in.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
No display - xorg.conf corrupted getsha Ubuntu 2 03-14-2009 01:30 PM
Xorg.conf dual screen setup problem IraGainesUK Linux - Hardware 10 12-12-2008 09:01 AM
Problem w/ Dual Head 6600gt xorg.conf YellowPlague Ubuntu 9 09-21-2006 10:19 PM
is another file for display instead of xorg.conf hitlar Fedora 3 09-08-2006 09:31 PM
Dual Display (xorg.conf Settings) slash587 Linux - Software 3 02-20-2006 11:25 PM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:58 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration