-   Slackware (
-   -   Dual booting Slackware and Windows 8 (

Slawd 04-03-2013 09:13 PM

Dual booting Slackware and Windows 8
I did a clean install of Windows 8 on a system I built. Then I was able to enable legacy BIOS support and install Slackware from a USB drive as outlined here:

I have a 1TB HDD for storage and a Samsung 120 GB SSD for the operating systems. Here is the partition scheme I set up:

sda 1TB
sdb1 System Reserved (Windows 8) boot
sdb2 Windows 8
sdb3 Linux swap
sdb4 / boot

The installation completes without a problem, but I did something wrong when installing LILO. When the computer boots up it goes straight to Windows every time, without giving me a choice. Moreover, I am unable to boot Slackware at all. I've tried changing the boot order in the BIOS, but the only option it gives is the HDD or the SSD; it doesn't allow me to specify the partition.

I've tried installing LILO to the MBR (all of the partitions are of type MBR), I tried installing it to sdb1 (install failed), sdb2, and sdb4. I also tried the automatic configuration. I have a feeling it has to do with the System Reserved partition, since that's the first thing the system sees. From what I understand, the only way to combine that partition with the Windows one would be to reinstall Windows after formatting the drive into one NTFS partition. However, then my product key would not work because it will think I'm installing it on another computer.

Also, shouldn't I be able to get into Slackware somehow? When I boot from the USB drive and (where it asks to pass a parameter to the kernal) I've tried:


#mount /dev/sdb4 /mnt

#huge.s root=/dev/sdb4 rdinit= ro
to no avail. The first one says the directory does not exist, and the second one begins to install Slackware like the first time I booted from the USB.

I chose Slackware because I wanted to learn as much as possible, so I'm up for trying anything.

Any advice/help would be appreciated.


ITPhoenix 04-17-2013 06:37 AM

First, your link is broken; it just takes us to an answer question page.

You should install Debian with a disk instead. Better to learn on that, and it dual-boots with the GRUB bootloader flawlessly.

When you burn the OS disk, you should check the MD5 on the downloaded file, and set the burner to verify data.

I also check MD5 against the hash file on the disk (after it's burned), as a final measure.

Didier Spaier 04-17-2013 07:12 AM

"sdb3 / boot" is not good. You need a root (/) partition of type Linux to install Slackware.

[EDIT] But maybe you actually meant that sdb3 is bootable Linux partition. Then, forget above remark.

To make sure, please boot from the USB drive, just hit [enter] (as if you would want to install again), type following commands and post back the results:

ls -l

Also, the safe way is to install lilo on /sdb4 (assuming it's your linux root partition). Tell that to the installer when asked. You only will have to make sure it's bootable (you can do that with cfdisk).

What is the filesystem format on /dev/sdb3?
Is the USB drive an USB key or an USB HDD?
Is the USB drive your installation medium or an USB boot thumb drive you made when asked during installation?

@ITPhoenix: using Debian instead of Slackware is not the point here. Slackware should be easily installable using LILO in OP's configuration, unless we miss some important information.

ITPhoenix 04-18-2013 12:13 AM

@Didier Spaier, true. There must be a solution. I think he did something wrong, but since beginner, USB/Slackware/Dual boot, is not the way to start in Linux. Just my opinion. I mentioned Deb because after trying several distros, Deb worked perfectly and it didn't have pulseaudio, which was killing my speech recognition program.

The next Deb release has pulseaudio by default, but it is easily removed without complicated procedures, or any ill-effects.

Didier Spaier 04-18-2013 12:24 AM


Originally Posted by ITPhoenix (Post 4933761)
Deb worked perfectly and it didn't have pulseaudio, which was killing my speech recognition program

<Off topic>Dare to tell which is this speech recognition program? I still keep Windows 7 on my laptop, mainly to be able to run Dragon Naturally Speaking...</Off topic>

ITPhoenix 04-18-2013 11:52 PM


Originally Posted by Didier Spaier (Post 4933766)
<Off topic>Dare to tell which is this speech recognition program? I still keep Windows 7 on my laptop, mainly to be able to run Dragon Naturally Speaking...</Off topic>

CMU Pocketsphinx. Runs perfect on Deb and extremely fast because it is written entirely in C. Problem is you would have to write, or obtain, some interface software for it to be usable. Out of the box you get command line output in a terminal. I was working with it for a robotics application. I tested 4 instances running simultaneously just to test the speed. They all returned the sentence I spoke perfectly except one, which omitted one word, all at the same speed as one program running!

The other one is Sphinx4, which is written in Java. It has some GUIs and test programs already written. That is easier to interface with a program also written in Java. They all need some kind of "post processor" for an interactive application. Simple command and control is easier.

If you want to learn about speech recognition and programming, that is the way to go.

bonowax 04-19-2013 04:30 AM

Hello Slawd, and welcome to LQ;

I have a somewhat similar setup up and running, the main difference being that I used a DVD as install media.

You should be able to boot your USB drive, as you would in a normal install and, when at the prompt, instead of launching 'setup', mount /dev/sdb4.
From your post, I presume you're using a single partition for slack. That being the case, after mounting it, you can 'chroot /mnt', review/correct lilo.conf and reinstall lilo.

When I needed, I did my lilo.conf modifications by hand, but I see no reason why you couldn't invoke pkgtool and rerun the install script that runs lilo, for assisted install.

In such setup you can use either lilo or the windows boot loader, although the former is much simpler.
lilo, usually resides in the MBR of your primary drive - the same the kernel attributes the /dev/sda node.

Happy Slackin'

Dman58 04-19-2013 04:22 PM

Hey Slawd,

That is actually a popular topic and there is some info about in THIS POST.

It is pretty lengthy but I'm sure the explanation your looking for is there.

Slawd 04-20-2013 12:33 PM

Thanks everyone. My original post showed up 2 weeks after I submitted it for some reason. I was able to figure it out on my own a while back.

First I made sdb4 the only bootable partition. Then I was able to get into Slackware and access the lilo config file. The only thing I had to change there was to tell it where Windows should boot from. After that everything worked perfectly.

Thanks for the help.

All times are GMT -5. The time now is 05:47 AM.