-   Slackware (
-   -   Dropbox on slackware 12.1 (

CartersAdvocate 09-22-2008 11:45 AM

Dropbox on slackware 12.1 *solved*
Is there a way to get dropbox to work on Slackware? I know it normally runs on Gnome using nautilus, but I didn't know if there is a way to get it working on KDE/Slackware.

MS3FGX 09-22-2008 03:35 PM

Dropbox is built around Nautilus, so there is no avoiding it. The best you could do would be to install the GNOME libraries and Nautilus from one of the third party GNOME-on-Slackware projects, and then simply run Nautilus from within KDE.

Running "nautilus --no-desktop" should allow you to run Nautilus without it trying to take over your KDE desktop.

CartersAdvocate 09-22-2008 06:55 PM

That worked...I just installed the libraries from and ran nautilus --no-desktop and it seems to be working on KDE. Thanks!

v3gard 04-22-2009 04:36 PM

I figured out a way to install Dropbox on Slackware without having to install Nautilus first. I made a howto that I posted on my website.

andreqls 07-18-2010 09:28 PM

nautilus-free solution
This solution is actually by v3gard, but the website he mentioned previously is now dead ("move along...") so I thought it would be convenient to post the solution here where it may be easily found. Again, just to make it clear, I take no credit for the solution, I can merely attest that it works.

First, you must download the Fedora-version of dropbox at (download the right one for your architecture, wether it's x86 or x86_64).
In the directory where you downloaded the package, issue the command (replacing the 0.6.3-1 and x86_64 with the appropriate version and architecture for you):


rpm2tgz nautilus-dropbox-0.6.3-1.fedora.x86_64.rpm
This will create a .tgz package. Then, as root, use this command to extract the contents of the package:


explodepkg nautilus-dropbox-0.6.3-1.fedora.x86_64.tgz
Now there should be a folder named 'usr' in the current directory. Move to the 'bin' subdirectory of 'usr':


cd usr/bin
Inside this directory, which should contain only a file called "dropbox", create a new file titled "nautilus" with the following contents (you may replace dolphin in the script below with your preferred file browser, like thunar or konqueror):


dolphin $@
exit 0
Now move back to the usr directory and create your Slackware package for Dropbox, installing it immediately afterwards (note that you must create the package in a different directory from the one you are working in; I chose '/tmp' because it tends to be the default directory for storing Slackware packages):


makepkg /tmp/dropbox-0.6.3-1.tgz
installpkg /tmp/dropbox-0.6.3-1.tgz
Finally, log out of the root account and as a normal user issue the following command to install the Dropbox client:


dropbox start -i
There! You now have your dropbox available in Slackware. Cheers to v3gard for this.

dugan 07-19-2010 01:08 AM

I would just use the official procedure:

Alien Bob 07-19-2010 01:37 AM

Or get a package here (should work on Slackware 12.1 too):


andreqls 07-21-2010 05:39 PM

Wow, not one but two legends of Slack - dugan & alienbob - replied. That's very cool ^^

I still think the solution is interesting and worthwhile, since you can keep up with the Dropbox releases (hopefully) by simply making and upgrading to a new package... Alien's package, for instance, is one release outdated ;P

Anyway... as always, there are many solutions to the same problem. I'm just glad I remembered this one after v3gard took it down and had the opportunity to post it here. Best regards to all.

Alien Bob 07-22-2010 03:12 AM


Originally Posted by andreqls (Post 4041196)
Alien's package, for instance, is one release outdated

Thanks for alerting me, I will update the Slackware 13.1 package.


mEllis 09-02-2010 09:13 AM

Dropbox in Slackware
Hello, thanks to Alien Bob for the Dropbox package. I installed it fine on my Slackware 13.1 box. I can get Dropbox running just fine, but I'm wondering if I should expect to see the contextual menus for Dropbox (e.g., sharing options) when I right-click on a folder or file in konqueror? Right now, I'm not seeing them, and I don't have the Dropbox status icons on the folders like I do on my machine running that other popular OS. It would be nice to share folders and files from my Linux machine. And if anyone knows of a way to share from the command line, that would be great. Thanks.


pg99 09-03-2010 02:04 PM

I just installed kdropbox, now called kfilebox, from

It was v simple. Downloaded source, compiled as per README instructions. On first run it downloaded the daemon, prompted for email/password and connected to my dropbox account.

Now I have a dropbox tray icon in KDE and all my files in ~/Dropbox (default folder, but I could've changed it on first run).

I'm running -current with KDE 4.4.5. Source was kdropbox-0.4.1.tar.gz


volvoz 05-22-2014 01:23 AM

I followed the advise of pg99

It downloaded deamon, but after gave a mistake
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
What does it mean?

I am still seating without dropbox on Slackware.

ponce 05-22-2014 02:14 AM

hi volvoz, welcome to LQ.

next time you need help, please don't hijack a thread started in 2008: things are changed in the meantime (for instance, the program you used isn't updated since two years).

to try helping you we need more informations:
- which slackware version are you running (please note also if 32 or 64 bit)?
- which desktop environment are you running?

have you tried using the SlackBuild (howto) or the prebuilt package from Alien Bob?

volvoz 05-22-2014 02:25 AM

You are right, next time I will find newer topic.

I am using Slackware 14.1(x64) with KDE.
I started from SlackBuild (tried dropbox and kfilebox) and dropbox-client from the second link.
But I didn't manage to start dropbox.

ponce 05-22-2014 03:03 AM


Originally Posted by volvoz (Post 5175060)
You are right, next time I will find newer topic.

you can also open a new one :)

I just tried this:

- installed the prebuilt client from Alien Bob;

- installed the daemon with

dropbox start -i
(I found the command reading the output launching from a terminal first "dropbox", then "dropbox start")

- followed instructions on screen.

after an initial sync everything is running fine (also when logging in again).

All times are GMT -5. The time now is 07:48 AM.