-   Slackware (
-   -   Draftsight on slackware64 13.37 (

lpallard 11-18-2012 04:49 PM

Draftsight on slackware64 13.37
Hi all,

I am trying to figure out how to install and run Draftsight (a 2D cad program) on my slackware64 box..

Using the slackbuild script available at, I immediately get a


x86_64 is not supported...
I tried to pass the parameter ARCH=i386 to the script but I get strange errors such as


bash-4.1# ./draftsight.SlackBuild
x - debian-binary
x - control.tar.gz
x - data.tar.gz
ar: /home/lpallard/draftsight/draftSight.deb is not a valid archive

I have enabled multilib as per AlienBob's instruction on his wonderful Wiki (Thanks AlienBob for your efforts!!) and other 32 bit only apps are running and installing just fine..

Anybody can help?
Thanks !

ChrisAbela 11-19-2012 07:04 AM

Remove these lines from the SlackBuild:


if [ "$ARCH" != "i386" ]; then
printf "\n\n$ARCH is not supported...\n"
exit 1
and re-try. Leave $ARCH alone.

lpallard 11-19-2012 09:05 AM

I've already tried that but it didn't work. I first thought this didn't work for whatever reasons but I've discovered that the .deb file downloaded from dassault website was corrupted.. I have tried to download it several times getting files of different sizes.. not normal at all.

Later on I tried to get the archive again but their website was down again..

lpallard 11-19-2012 06:37 PM

Ok I have tried to run the slackbuild script with commented lines, compilation and installation are fine, but when I start the app I get


/opt/dassault-systemes/draftsight/bin/draftsight.bin: error while loading shared libraries: cannot open shared object file: No such file or directory
So I did a system sesrch and found 3 libvraries

Ive made a symbolic link from /usr/lib64/ to /usr/lib/

but of course when I start the app I get

/opt/dassault-systemes/draftsight/bin/draftsight.bin: error while loading shared libraries: wrong ELF class: ELFCLASS64
That would be because the library is compiled in 64bit correct? How can I compile the same library in 32 bit so I can put it in /usr/lib/ with the other 32 bit libraries..?

I thought "multilib" was actually more flexible than that. I have never played with mixed configs like 32 & 64 bits in the same OS so bear with me..


All times are GMT -5. The time now is 04:36 PM.