LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-19-2005, 04:28 AM   #1
s4006576
LQ Newbie
 
Registered: Dec 2003
Posts: 10

Rep: Reputation: 0
DPMS Question


Newbie here. Slack is up and running using stock bare.i kernel

Problem is I can't get the monitor to go on standby properly. Using xset dpms force off shows a distorted view on the monitor but the power is still on. But I can get it to sleep (no backlight, no display) on Knoppix and Windows.

Question is does DPMS in any way depend on APM or ACPI? Or are they independent? I've read that there are some posts describing of a blank monitor but with the backlight still on - probably the same problem as mine, but can't find any solution that goes with those posts. I would like to ignore X and try to get dpms to work on the console first if that helps at all, but I can't figure out how to set DPMS for the console.

Any help will be appreciated. Thank you.
 
Old 02-19-2005, 07:10 AM   #2
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,552

Rep: Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872
There is a line in /etc/rc.d/rc.M that should enable that for you :

/bin/setterm -blank 15 -powersave powerdown -powerdown 60

It rely on APM or ACPI power management to work.
Do you use ACPI or APM ?
 
Old 02-19-2005, 07:05 PM   #3
BrianW
Member
 
Registered: Jul 2003
Location: Montana
Posts: 297

Rep: Reputation: Disabled
Under the Section "Monitor" add Option "DPMS"
Then in the Section "ServerLayout" you can add the following to control the time it performs each mode:
Code:
    Option "StandbyTime" "5"
    Option "SuspendTime" "10"
    Option "OffTime" "15"
 
Old 02-20-2005, 04:47 AM   #4
s4006576
LQ Newbie
 
Registered: Dec 2003
Posts: 10

Original Poster
Rep: Reputation: 0
Checked rc.M and xorg.conf, both of those are there...and still not working.

I'm using the bare.i kernel from the installation cd, I'm not sure if that comes with APM or ACPI. Should I have used the bareacpi.i kernel instead?

i tried modprobe apm, but it returns apm: BIOS not found in dmesg.
 
Old 02-20-2005, 08:37 AM   #5
justin_p
Member
 
Registered: Jan 2004
Location: Virginia, USA
Distribution: slack 13; I've used it all :)
Posts: 433

Rep: Reputation: 30
All you should have to do is already described above.

Under the Section "Monitor" add Option "DPMS"
Then in the Section "ServerLayout" you can add the following to control the time it performs each mode:

code:

Option "StandbyTime" "5"
Option "SuspendTime" "10"
Option "OffTime" "15"

This has always worked for me. Take a look at this page:
http://linuxreviews.org/howtos/power.../index.html.en
 
Old 02-22-2005, 12:09 PM   #6
s4006576
LQ Newbie
 
Registered: Dec 2003
Posts: 10

Original Poster
Rep: Reputation: 0
I already have those lines in xorg.conf

The problem seems to be coming from some other place. Using xset dpms force off gives a distorted screen. Would it be fair to say that probably ACPI or APM is not working properly? I can't tell which of the two I am using.

So nobody can offer any more suggestions on how I might be able to solve this?
 
Old 02-22-2005, 02:00 PM   #7
cumbersome
LQ Newbie
 
Registered: Aug 2004
Location: Germany
Distribution: Slackware 10.0
Posts: 16

Rep: Reputation: 0
enable apm

Hello,
I enabled apm on my system by uncommenting the line

/sbin/modprobe apm

in /etc/rc.d/rc.modules

I can see the line:
"Starting APM daemon: /usr/sbin/apmd",
when my system boots. Maybe this could help you too.

Sönke
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dpms not enabling... jkassemi Linux - Software 1 12-02-2005 06:30 PM
how to disable dpms forever??? bloody_penguin Linux - General 0 11-29-2004 07:45 AM
dpms: stop from waking apberzerk Linux - General 1 10-17-2004 04:52 PM
Gnome keeps disabling dpms kidicarus Linux - Software 0 08-18-2004 03:34 PM
slack 10 DPMS... very confusing kule Slackware 8 07-18-2004 09:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration