LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-25-2017, 11:58 PM   #16
mrapathy
Member
 
Registered: Nov 2005
Distribution: slackware
Posts: 240

Original Poster
Rep: Reputation: 48

could not build dosbox in 64bit

using mount and
Quote:
imgmount [drive letter] path -t iso
in dosbox on linux and windows.
 
Old 07-26-2017, 12:02 AM   #17
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 9,672

Rep: Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316
Quote:
Originally Posted by mrapathy View Post
could not build dosbox in 64bit
Really?

Can you be more specific about what happened when you tried?

Quote:
imgmount [drive letter] path -t iso
And what happened when you did that?

Please note that I specifically said:

Quote:
and what happens (post the command output and errors) when you do the same in Linux?

Last edited by dugan; 07-26-2017 at 12:04 AM.
 
Old 07-26-2017, 12:03 AM   #18
mrapathy
Member
 
Registered: Nov 2005
Distribution: slackware
Posts: 240

Original Poster
Rep: Reputation: 48
I used the SBo and it complained. my dosbox is i486 package

hmm just retried and it built a 64bit package and dosbox works though is still not imgmount my .cue/bin file

Last edited by mrapathy; 07-26-2017 at 12:10 AM.
 
Old 07-26-2017, 12:05 AM   #19
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 9,672

Rep: Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316
Quote:
Originally Posted by mrapathy View Post
I used the SBo and it complained. my dosbox is i486 package
"it complained".

How every technical and specific.

I'm afraid that if you're not going to paste in actual terminal output, you're not going to get helpful advice.

Are you having trouble with copy and paste?

You do realize that "it works in windows" "no go" "it complained" "didn't work" etc are not enough for us to actually help you, right?

Last edited by dugan; 07-26-2017 at 12:12 AM.
 
Old 07-26-2017, 12:25 AM   #20
mrapathy
Member
 
Registered: Nov 2005
Distribution: slackware
Posts: 240

Original Poster
Rep: Reputation: 48
cant copy paste from dosbox window

as example I get same output as thread I linked to in first post
Quote:
Could not load image file: /home/john/Downloads/Betrayal at Krondor/KRONDOR.cue
MSCDEX: Failure: Invalid file or unable to open.
Just tried rebuilding dosbox 64bit and it worked but still cannot imgmount in dosbox with cue/bin file.

Getting confused its late. swear dosbox complained when I built it 64bit second to last time I tried and it didnt output a package per SBo script.
 
Old 07-26-2017, 12:46 AM   #21
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 9,672

Rep: Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316
If you want to confirm that you've actually built Dosbox with SDL_Sound support: look for this in the build output.

Code:
checking SDL_sound.h usability... yes                                    
checking SDL_sound.h presence... yes                                     
checking for SDL_sound.h... yes                                                                                                                   checking for Sound_Init in -lSDL_sound... yes                            
checking for Sound_Seek in -lSDL_sound... yes
Also, one possibility for why it works in Windows (which was brought up in the other thread) might be that the filename(s) listed in the .cue files are written in the wrong case. Windows would tolerate that because of its case-insensitive filesystem. Check that.

Last edited by dugan; 07-26-2017 at 12:54 AM.
 
Old 07-26-2017, 01:02 AM   #22
mrapathy
Member
 
Registered: Nov 2005
Distribution: slackware
Posts: 240

Original Poster
Rep: Reputation: 48
yes I built it with SDL_sound support captured the output to a file and searched it.

dosbox still doesnt want to imgmount cue/bin file same error as before.
 
Old 07-26-2017, 01:13 AM   #23
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 9,672

Rep: Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316
Open the cue sheet with a text editor. You know at this point what you're looking for.
 
Old 07-26-2017, 01:24 AM   #24
mrapathy
Member
 
Registered: Nov 2005
Distribution: slackware
Posts: 240

Original Poster
Rep: Reputation: 48
I was able to imgmount the .bin file. though this means no music tracks. the game is working which will have to do.

wonder if I should submit a bugreport to dosbox.
 
Old 07-26-2017, 09:47 AM   #25
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 9,672

Rep: Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316
Quote:
Originally Posted by mrapathy View Post
wonder if I should submit a bugreport to dosbox.
Only if you want to be told to open the cue sheet in a text editor again.
 
Old 07-26-2017, 10:49 AM   #26
chemfire
Member
 
Registered: Sep 2012
Posts: 265

Rep: Reputation: Disabled
Dos box should mount a cue file as others have pointed out. CUE files are a good choice for DOS box much of the time, over ISO. Lots of old dos games had audio tracks in addition to a data track, the bin/toc/cue image format allows you to represent/store those. ISO are just a filesystem image. DosBox's virtual cdrom driver will allow playback of the audio tracks in bin/toc/cue image.

Do not mount the image on the host. Well you can but it won't be helpful. Make sure the toc, bin, and audio file are in the same directory as the cue file. From inside dosbox use the command:

imgmount d: /path/to/your/cue/file/on/the/host.cue -t iso
 
Old 07-26-2017, 02:23 PM   #27
mrapathy
Member
 
Registered: Nov 2005
Distribution: slackware
Posts: 240

Original Poster
Rep: Reputation: 48
Quote:
Originally Posted by chemfire View Post
Dos box should mount a cue file as others have pointed out. CUE files are a good choice for DOS box much of the time, over ISO. Lots of old dos games had audio tracks in addition to a data track, the bin/toc/cue image format allows you to represent/store those. ISO are just a filesystem image. DosBox's virtual cdrom driver will allow playback of the audio tracks in bin/toc/cue image.

Do not mount the image on the host. Well you can but it won't be helpful. Make sure the toc, bin, and audio file are in the same directory as the cue file. From inside dosbox use the command:

imgmount d: /path/to/your/cue/file/on/the/host.cue -t iso
tried that countless times only to get error mentioned earlier.

game segfaults when mounting the .bin file. guess I will just play it in windows.
 
Old 07-26-2017, 02:33 PM   #28
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 9,672

Rep: Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316Reputation: 4316
Quote:
Originally Posted by mrapathy View Post
I will just play it in windows.
You can run Windows DosBox in WINE, you know.

Last edited by dugan; 07-26-2017 at 02:53 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache2 wont read my php files mtwilson Linux - Software 13 12-24-2015 03:53 PM
[SOLVED] Cannot mount CUE images in DOSbox 0.74 almosthere Slackware 18 08-30-2014 05:29 PM
how do i get xmms to read cue playlists imnah Linux - Newbie 2 06-14-2007 12:34 PM
Software to read .iso and .cue StarDragon Linux - Software 3 06-04-2005 01:22 PM
Zipslack wont read files created in windows? Stuartb21 Slackware 7 11-30-2003 11:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration