-   Slackware (
-   -   DOSBox .074 - Can't set CPU Cycles or get to Keymapper (

lkraemer 10-19-2012 06:34 PM

DOSBox .074 - Can't set CPU Cycles or get to Keymapper
I'm using Slackware 14, XFCE Desktop, with DOSBox 0.74 to run some Emulators.
My ASUS Laptop won't access the Keymapper with CTRL+F1. I can't Increase CPU
cycles with CTRL+F12 or Decrease the CPU Cycles with CTRL+F11.

I'm positive I've used these features with DOSBox 0.74 in Debian 6.0 on
my ASUS Laptop, but won't know 100% for sure until I swap my Hard Drive.
Yes, I just tested the CTRL+F1, CTRL+F11, and CTRL+F12 and it works correctly
in Debian 6.0 "Squeeze" with DOSBox 0.74.

Has anyone else had problems setting the CPU Cycles in DOSBox & Slackware 14?
There appears to be some anomaly in Slackware 14.



Fred-1.2.13 10-19-2012 07:31 PM

I also have had issues with DOSBox in Slackware 14.0. Same issues as you and some of the higher end DOS games (Jazz Jackrabbit) just freeze now.

DOSBox .074 works perfect under Slackware 13.37. Not sure if it is something with the newer kernel but that is what I suspect.

Sure wish they would update DOSBox! I have tried both the Slackbuild as well as the source from the DOSBox website, built each of them with the same results.

FeyFre 10-19-2012 08:23 PM

lkraemer, check if Your Desktop Environment does not intercepts this keystrokes. Since Slackware1 4 has newer versions of KDE/XFCE which could bind new keystrokes. As far as I can remember Ctrl+F12 was intercepted by KDE in both 13.1 and 13.37. In my case, since F12/Ctrl+F12 are one of hotkeys in Opera which I use very often also intercepted by KDE, I always turn off KDE's hotkeys in any new installation.

lkraemer 10-19-2012 08:54 PM

I'm using XFCE for my Desktop, with a FULL Install of Slackware 14. I'm not sure where that information would be located in the
XFCE menu's. I've looked at APPLICATIONS MENU -> SETTINGS -> Keyboard and don't see anything there. I've also looked at
APPLICATIONS MENU -> SETTINGS -> SETTINGS EDITOR where I found two locations where CNTL+F1, CNTL+F11, & CNTL+F12 are set to
type equal string and workspace_1_key, workspace_11_key, and workspace_12_key.

Is this what you are talking about? I don't have a clue as to what they would be changed to? How would
these be turned off?

and no where in any of those Menu's for CUSTOM, STANDARD, or GLOBAL Keyboard Shortcuts, do I find a CNTL+F1,
CNTL+F11, or CNTL+F12. Have I missed something? What am I overlooking?

I did change my DOSBox configuration file, and set the cycles to 10000 and the CPU cycles work properly there for my Emulator.
I just wish I could adjust it with the proper function Keys.



lkraemer 10-20-2012 07:26 AM

1 Attachment(s)
I finally found how to get the DOSBox CPU Speed (Cycles) Decreased with CNTL+F11, Increased with CNTL+F12, and how
to access the DOSBox Keymapper with CNTL+F1.

While using XFCE Desktop, look at:
APPLICATIONS MENU -> SETTINGS -> WINDOW MANAGER -> KEYBOARD TAB then scroll down until you see workspace_1,
workspace_11, workspace_12, and delete those assignments. If you wish to enable those again, just use RESET to Default.

This allows DOSBox to use CNTL+F1, CNTL+F11, and CNTL+F12 to access the Keymapper and Change the CPU Cycles accordingly.



Fred-1.2.13 10-20-2012 09:42 AM

Thanks Larry! I also use XFCE. I will try this, maybe if I can change the CPU cycles I can get the other games to run.

EDIT: I have access to the CPU Cycles now, but some of the more intensive games still will not run. Weird that they ran fine in Slackware 13.37.

EDIT EDIT: I flipped to the console I ran startx in to see if any errors were there, and I saw this:

ALSA lib pcm.c:7339:.(snd_pcm_recover) underrun occurred

Seems to be a problem with the sound library. Any ideas what I can do about this? I am going to Google the error and see if anything comes up.

lkraemer 10-20-2012 04:47 PM

Nope, I haven't a clue on your sound problem.

But, if you go to your /home/login/.dosbox/dosbox-0.74.conf file and scroll down.....
You will see some code like this:


I changed my cycles to 10000 versus auto, and I changed cycleup from 10 to 20, then saved the file.
Now it automatically comes up at 10,000 cycles, which is what I always run my Emulators at.

From the Midwest? What part? I'm in Southeast Missouri, (AKA..SwampEast Mis-er-e-y!).

Sorry, I can't be more help.



Fred-1.2.13 10-20-2012 05:34 PM

Thanks anyway Larry! Yep... I'm right next door to you in Kansas, about 60 miles from Topeka.

All times are GMT -5. The time now is 01:13 AM.