-   Slackware (
-   -   Does slackware have a http or ftp install method? (

edkhosting 11-20-2003 04:32 AM

Does slackware have a http or ftp install method?
I tried doing an nfs and when it went to go and install the packages it threw up an error and booted me back to the screen. If there is a way can you kindly tell me or perhaps direct me to a how to? I'm trying to put it on a armada 7400 laptop with no cdrom.

littleking 11-20-2003 06:06 AM

and what was the error?

edkhosting 11-20-2003 08:16 AM


Originally posted by littleking
and what was the error?
flashed too quick to see.

littleking 11-20-2003 08:54 AM

did you check the logs?

edkhosting 11-20-2003 10:04 AM


Originally posted by littleking
did you check the logs?
no I'm a n00b I only know so much

pele_smk 12-15-2003 09:55 PM

I'm having the same problem. I have both an ftp server and a smbclient running with the slack cd's. I'm trying to install onto my laptop. When I go to do an nfs install. It just throws me back to the main screen and to the first selection which is help. I don't see an error and I don't know where error logs would be kept if the system isn't installed anywhere.

malo_umoran 12-16-2003 02:01 AM

I installed Slack 9.1 on a laptop without built in drives a few days ago. But I had a WinXp on it ... and USB Cd-Rom.

This is what you can do .... and what I tried:

1. boot from cd-rom, Slack didn't recognize the source drive (no kernel usb support)
2. copied 1st ISO file from windows on a FAT partition, mounted it as a loop device, but Slack still didn't want to boot
3. installed Debian base system from mounted ISO files, made a new 2.6.r11 kernel with buit-in USB support in debian.... put it in Slackware ISO file, burn it again, and installed from USB drive

I don't understanda why Slack don't want to install from mounted ISO file ... i starts installation, and quits after 10 seconds with message "installation successfull" ....

I think it's bug, because I tried this ona few different boxes and it didn't work. (only with 9.1)


skog 12-16-2003 02:46 AM

it should malo_umoran.

could you boot off the slack cd and get to the setup? if you can get that far there is a much easier way to do it. just boot off some boot disk make a partition on the harddrive and copy the slackware directories from both cd1 and cd2 to that partition and when you get into setup just go through like normal and after you setup your partitions it will ask you where you want to install from ie nfs cdrom harddrive ... choose harddrive it will ask which partition to install from and tell it and proceed like normal.

malo_umoran 12-16-2003 02:53 AM

i never had problems with 8.1 or 9.0 ...

i know what I maybe did wrong, but this worked for me allways with debian and old slacks ... i never mounted ISO like in a official slackware faq, but:

$ mount -o loop /fat_partition/slackware1.iso /INSTALL

that was probably the reason for the error. but if ut was mounted correctly, it should install also.


pele_smk 12-16-2003 12:17 PM

I got it installed. I wasn't putting the complete name of the iso file in place of "slackware.iso" I guess I wasn't thinking

Linux.tar.gz 12-16-2003 10:37 PM

im sorry for the network install i ve never had the pleasure to commit it. :Pengy:
perhaps you have to specify the subfolder of the cd: /slackware/
like when you can plug another hard drive:

put all the FILES of the slack cd in subfolder of a fat32 partition ex.: c:/slackware
boot the cd
do the cfdisk job without touching at the fat32 partition ^^
---------note the id of the fat32 drive ex.: /dev/hda1 or /dev/hdd2 or......
run the setup normally
the setup will detect the fat32 and said the changes wont apply until reboot: no matter.
after that you have to choose the installation source. Choose hard disk partition
give the drive id
you have to specify the subfolder: /slackware
this folder u can see it when u make the step 1
read this bestseller:

All times are GMT -5. The time now is 06:49 AM.