-   Slackware (
-   -   Does ndiswrapper work with Slackware? I don't want to switch to Ubuntu. (

rovitotv 10-20-2005 12:22 PM

Does ndiswrapper work with Slackware? I don't want to switch to Ubuntu.
I need to get ndiswrapper working under Slackware 10.2 (running a customer kernel). Two posts in LQ mention they switched to Ubuntu so I have to ask the question does Slackware not work with ndiswrapper?
Link 1
Link 2

To me Linux is Linux and I am not sure why ndiswrapper would not work with Slackware.

My setup is a older Dell Notebook (USB 1.1) with a USB D-Link DWL-G120 which I have installed with ndiswrapper (version 1.2 and 1.4). All the ndiswrapper stuff appears to be working I get a message in "dmesg" with the device's MAC address and I can see the MAC address on my router. I use the following commands to configure the port


iwconfig wlan0 essid ESSID
iwconfig wlan0 mode Managed
ifconfig wlan0 up
dhcpcd wlan0

I get back a valid IP address from DHCP but I can't ping anything outside of the local machine. This problem is driving me crazy because I get a valid IP address but I can't ping any other machine??? I have chmod -x /etc/rc.d/rc.inet1 and chmod -x /etc/rc.d/rc.wireless so I can configure the network by hand. My ifconfig and iwconfig settings appear to be correct (I will post them latter when I get to the machine). Thanks for the help, I hope I can get this resolved.


Hangdog42 10-20-2005 12:56 PM

Yeah, ndiswrapper does work quite well with Slackware. In fact I'm posting courtesy of ndiswrapper on Slackware. That said, the USB wireless adapters can be a royal pain to get working. Have you tried anything besides ping? What happens if you try using a browser? Are you sure that you got your USB support correct in your custom kernel.

Oh, and on more thing. The 2.6.13 kernels use a new verision of Wireless exentions that isn't really supported by the Wireless Tools that comes with Slackware 10.2. Unless you've done a custom compile of wireless tools, that could be part of the problem.

rovitotv 10-20-2005 01:30 PM

I feel confident in my USB support because I can use a USB pendrive. I have _NOT_ compiled the wireless tools so I will try and move back to the 2.4.x kernel. No I have not tried anything but ping because I figured if ping does not work nothing will work.

Which windows driver do you use (win 98, win xp, win 2000)? My usb wireless device has a driver for all the Windows flavors. Thanks for the help, I feel better knowing that Slackware works OK with ndiswrapper because I don't want to switch to Ubuntu.

egag 10-20-2005 01:45 PM

if you get an ip address from dhcp, the driver is working.
what is the output of "route " ?

there should be a line like this:

default SpeedTouch.lan UG 0 0 0 eth0

this defines the default gateway to use ( here that's my router )


Hangdog42 10-20-2005 01:55 PM

I use an XP driver. That should probably be the first choice followed by 2000, then 98. By the way, do you know the sites you are pinging actually respond to ping? Not all sites do. And egag's suggestion about looking at route is an excellent idea.

scuzzman 10-20-2005 10:26 PM

Also - can you ping with an ethernet connection? (You may have an iptables firewall that drops pings from any end...)

Namaseit 10-20-2005 10:51 PM

or your resolv.conf is empty so you have no dns servers listed. Read your /etc/resolv.conf file and if it's empty change it to your ISP's provided dns servers.

rovitotv 10-21-2005 12:12 AM

At this point I am not trying to go beyond my internal network, note I have not setup a gateway yet. I should be able to ping the router I can from other computers on the same network. Pinging the router or trying to pull up the admin program from a web browser does not work! I am pinging by IP address. I have tried both the Windows XP and Windows 98 driver. Please help, I am getting ready to freak! If I get a dhcp address it should be working I am so close! Thanks for your help.

Output from ndiswrapper -l

Installed ndis drivers:
prisma02        driver present, hardware present

Output from iwconfig

wlan0    IEEE 802.11g  ESSID:"stargt" 
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:06:25:77:52:1D 
          Bit Rate:11 Mb/s 
          RTS thr:2347 B  Fragment thr:2432 B 
          Encryption key:off
          Power Management:off
          Link Quality:100/100  Signal level:-59 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:239  Missed beacon:0

Output from ifconfig

lo        Link encap:Local Loopback 
          inet addr:  Mask:
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:19 errors:0 dropped:0 overruns:0 frame:0
          TX packets:19 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2128 (2.0 Kb)  TX bytes:2128 (2.0 Kb)

wlan0    Link encap:Ethernet  HWaddr 00:0D:88:C2:4C:EF 
          inet addr:  Bcast:  Mask:
          RX packets:103 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:13607 (13.2 Kb)  TX bytes:1532 (1.4 Kb)

Output from route

Kernel IP routing table
Destination    Gateway        Genmask        Flags Metric Ref    Use Iface    *      U    0      0        0 wlan0
loopback        *          U    0      0        0 lo
default        UG    0      0        0 wlan0

Output from dmesg

uhci_hcd 0000:00:07.2: Intel Corporation 82371AB/EB/MB PIIX4 USB
uhci_hcd 0000:00:07.2: new USB bus registered, assigned bus number 1
uhci_hcd 0000:00:07.2: irq 11, io base 0x0000ece0
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
usb 1-1: new full speed USB device using uhci_hcd and address 2
ndiswrapper version 1.2 loaded (preempt=yes,smp=no)
ndiswrapper: driver prisma02 (GlobespanVirata,11/11/2003, loaded
ndiswrapper (NdisWriteErrorLogEntry:314): log: C000138A, count: 3 (00000103), return address: d08b5ba6
ndiswrapper (NdisWriteErrorLogEntry:314): log: C000138A, count: 3 (c0000001), return address: d08b5195
wlan0: ndiswrapper ethernet device 00:0d:88:c2:4c:ef using driver prisma02, configuration file 2001:3701.0.conf
wlan0: encryption modes supported: WEP, WPA with TKIP, WPA with AES/CCMP
usbcore: registered new driver ndiswrapper

Hangdog42 10-21-2005 07:07 AM

This is weird. I don't see any problems that would cause you connection trouble. You've obviously connected to your access point, and you have an IP address and your gateway is pointing to your router the way it should be. Unless you have a firewall on this box locking down all access outside of itself (post the output of iptables -L if you don't know) you should be able to point a browser at and get the config page.

So at this point I'm guessing the firewall.

rovitotv 10-21-2005 04:58 PM

Thanks for the post I appreciate any help that I can get. I can ping my router from another computer on the network so I don't think it is the router. At this point I am just trying to ping computers internal to my network, in this case my router at from another computer on my network I can successfully ping . I am totally confused this should work I am about to give up.


Hangdog42 10-21-2005 05:11 PM

As I said in my previous post I think it may be a firewall issue on your Slackware box. At very least that is currently the most likely suspect. If you don't know what your firewall is set to do, post the output of iptables -L . You'll have to su to root to run this command.

rovitotv 10-21-2005 07:07 PM

I turned iptables off when I compiled the kernel. When I type in the command "iptables -L" as root I get:

FATAL: Module ip_tables not found.
iptables v1.3.3: can't initialize iptables table `filter`: iptables who? (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.

I think this proves a firewall is _NOT_ running.

rovitotv 10-21-2005 10:47 PM

Yes, I got ndiswrapper working after all with Slackware :-) but I didn't get it working with the DWL-G120. It does work perfectly with the DWL-G122. Thanks for all the help.

All times are GMT -5. The time now is 03:18 AM.