LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-09-2010, 08:32 AM   #1
tuxhedo
LQ Newbie
 
Registered: Jan 2010
Posts: 2

Rep: Reputation: 0
Does citrix ica client work on slackware 64 (with multilib enabled)


Need to use remote access via citrix ica client. My workplace has updated the citrix server ("citrix web access") and now I cannot get the client to work.
I can authenticate and get a list of available applications, but I cannot use any of those applications. Error message says "no route to server".
Has anybody had success with the citrix client on slackware that they are willing to share?

Thanks
Tuxhedo
 
Old 01-10-2010, 04:51 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,447

Rep: Reputation: 5711Reputation: 5711Reputation: 5711Reputation: 5711Reputation: 5711Reputation: 5711Reputation: 5711Reputation: 5711Reputation: 5711Reputation: 5711Reputation: 5711
I use the citrix client on Slackware 13.0 x86_64 and you have to have a multilib setup because the citrix client is 32-bit.

Works really well.
Personally I am using openmotif because the citrix client is linking against it, but I heard a story of a collegue that using Slackware's lesstif works too. My massconvert32.sh script that is part of the compat32-tools will create a lesstiff-compat32 package for you for use with the 32-bit citrix client.

My openmotif package can be found here (use installpkg to install openmotif after you have run "removepkg lesstif", the two packages conflict): http://slackware.com/~alien/slackbuilds/openmotif/

Eric
 
Old 02-15-2010, 05:16 PM   #3
tuxhedo
LQ Newbie
 
Registered: Jan 2010
Posts: 2

Original Poster
Rep: Reputation: 0
Lightbulb Update

Thanks Alien Bob,

I have used your compat32 scripts and tools with great success, Thank You.

Looks like my problem is more likely due to not establishing a vpn connection properly. In the past I haven't specifically had to do this (perhaps I didn't need to?), the citrix linux ica client just worked.

Am in the process of attempting to set up openvpn (my aim is to have it working seamlessly so that when I select an application to run the vpn is autmatically selected/used/set up.)

Tuxhedo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu 7.10 Citrix ICA Client Issues (2) jordo2323 Linux - Software 8 08-08-2008 05:30 AM
Citrix ICA Client for Sarge Stable cccc Debian 2 02-21-2008 03:58 AM
Configuring Citrix ICA client on Suse chriswright128 Linux - Software 1 08-31-2007 10:15 AM
Citrix ICA Client - Weird Connection Issue Caputs411 Linux - General 2 03-26-2005 05:33 PM
Installing Citrix ICA client Cypionate Fedora 5 06-24-2004 06:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration