LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-30-2019, 01:06 AM   #1
the_zone
Member
 
Registered: Nov 2008
Distribution: Slackware
Posts: 57

Rep: Reputation: 0
Docker on slackware64 current fails on runc


I wanted to give docker a go and learn more about.
So I started installing docker with sbopkg from a queue file.

My slackware install is x86_64 of January 2nd or 3rd this year.

I ran in to problems with runc.

Quote:
go build -buildmode=pie -ldflags "-X main.gitCommit=ccb5efd37fb7c86364786e9137e22948751de7ed -X main.version=1.0.0-rc6 " -tags "seccomp" -o runc .
go build: when using gccgo toolchain, please pass linker flags using -gccgoflags, not -ldflags
# _/tmp/SBo/runc-1.0.0-rc6
/usr/bin/ld: $WORK/b001/_pkg1_.a(_cgo_defun.o): relocation R_X86_64_32 against `.rodata' can not be used when making a PIE object; recompile with -fPIC
So I tried manually installing runc with a modified makefile where I replaced -ldflags with mentioned -gccgoflags.

Quote:
go build -buildmode=pie -gccgoflags "-X main.gitCommit=ccb5efd37fb7c86364786e9137e22948751de7ed -X main.version=1.0.0-rc6 " -tags "seccomp" -o runc .
# _/tmp/SBo/runc-1.0.0-rc6
gccgo: error: main.gitCommit=ccb5efd37fb7c86364786e9137e22948751de7ed: No such file or directory
gccgo: error: main.version=1.0.0-rc6: No such file or directory
gccgo: error: unrecognized command line option -X
gccgo: error: unrecognized command line option -X
Look like the packages are not sane for automatic building.

Any one suggestions ?


br,

SImon
 
Old 01-30-2019, 02:37 AM   #2
Qury
Member
 
Registered: Feb 2004
Location: Dublin
Distribution: Slackware
Posts: 161

Rep: Reputation: 140Reputation: 140
i had similar issues with building docker and it's dependencies...

The below things helped me:
- using ponce's repository in sbopkg
- rebooting after golang was installed
- continuing the build logged in as root

Opening up a terminal and becoming root via "su" was not working as i guess some environmental variables were not picked up.
 
Old 01-30-2019, 02:38 AM   #3
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,810

Rep: Reputation: Disabled
when you install google-go-lang from SBo you should add its tools to your path by executing some specific scripts in /etc/profile.d, it's written in its README: the faster way is to logout and login again after having installed the package.
if you don't do this you will keep using the go compiler shipped with gcc and this won't work with docker's dependencies.
so, if you want to build it using sbopkg you should break your queue at google-go-lang, logout, login again and resume the queue from where you interrupted it.

EDIT: Qury has been faster, and I completely agree with his suggestion to become root via "su -", it's also in the HOWTO (step 4): if you don't do it, /etc/profile.d/*.sh script are not sourced.

Last edited by ponce; 01-30-2019 at 02:43 AM.
 
1 members found this post helpful.
Old 01-30-2019, 04:19 PM   #4
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,292

Rep: Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653
I'll point out that the slackbuilds for 14.2 aren't guaranteed to work with -current.
 
Old 01-30-2019, 06:09 PM   #5
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,974

Rep: Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231
For docker, it's working fine on -current.
You just need to make sure to use "su -" before building the script, either manually or using automated tools such as sbopkg.
 
Old 01-31-2019, 04:20 AM   #6
vbatts
Member
 
Registered: Jun 2005
Location: Raleigh, NC, USA
Distribution: slackware
Posts: 84

Rep: Reputation: 58
Compile runc with google-go-lang package, not the gccgo that is stock on slackware. Be sure to source /etc/profile.d/go.sh first.
 
Old 01-31-2019, 08:08 AM   #7
the_zone
Member
 
Registered: Nov 2008
Distribution: Slackware
Posts: 57

Original Poster
Rep: Reputation: 0
Thanks to all for the answers.

I'll try asap.

br,

ST
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Fail to install runc package( ... for docker) mpregos Slackware 4 10-22-2017 04:55 PM
runc won't start a container jr_bob_dobbs Linux - Containers 0 09-18-2017 04:45 PM
LXer: runC: The little container engine that could LXer Syndicated Linux News 0 08-15-2016 10:01 AM
LXer: Docker 1.11 Debuts with runC, Supports IPv6 LXer Syndicated Linux News 0 04-14-2016 02:33 AM
Updating from Slackware64-current to Slackware64 13. glore2002 Slackware 4 08-28-2009 06:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration