LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-28-2024, 01:20 PM   #1
SlackCoder
Member
 
Registered: Nov 2020
Posts: 48

Rep: Reputation: Disabled
Docker on IPv4


Anyone else running into problems with Docker on IPv4 networks?

Code:
# docker run -ti liveslak/slackware:latest /bin/bash -l
Unable to find image 'liveslak/slackware:latest' locally
docker: Error response from daemon: Get "https://registry-1.docker.io/v2/liveslak/slackware/manifests/sha256:fb04153b5debc3ea9540336f1253538df860d0758f8ae78cafd8499ff8723678": dial tcp [2600:1f18:2148:bc01:571f:e759:a87a:2961]:443: connect: network is unreachable.
See 'docker run --help'.
I've tried disabling IPv6 entirely by appending ipv6.disable=1 as a kernel parameter with no luck.

Code:
# docker run -ti liveslak/slackware:latest /bin/bash -l
Unable to find image 'liveslak/slackware:latest' locally
docker: Error response from daemon: Get "https://registry-1.docker.io/v2/liveslak/slackware/manifests/sha256:fb04153b5debc3ea9540336f1253538df860d0758f8ae78cafd8499ff8723678": dial tcp [2600:1f18:2148:bc01:571f:e759:a87a:2961]:443: socket: address family not supported by protocol.
Neither did upgrading docker, docker-cli, and containerd help.
 
Old 05-28-2024, 02:30 PM   #2
Windu
Member
 
Registered: Aug 2021
Distribution: Arch Linux, Debian, Slackware
Posts: 599

Rep: Reputation: Disabled
Add this to /etc/docker/daemon.json :
Code:
{
  "ipv6": false
}
 
Old 06-06-2024, 10:17 AM   #3
SlackCoder
Member
 
Registered: Nov 2020
Posts: 48

Original Poster
Rep: Reputation: Disabled
The above didn't work.

The problem appears to stem from Golang and a buggy (?) router nameserver. Other Golang programs were having similar errors.

One fix is to use google's DNS servers by setting 'nameserver 8.8.8.8' in /etc/resolv.conf.

Preferring to avoid google, another way is to run a local nameserver. Below are the steps.

Configure bind to listen on localhost:

Code:
options {
  [...]
  listen-on { 127.0.0.1; };
  [...]
};
Use localhost as the nameserver by editing /etc/resolv.conf:

Code:
[...]
nameserver 127.0.0.1
[...]
Configure dhcp to avoid overwriting /etc/resolv.conf. For me this done by editing /etc/rc.d/rc.inet1.conf for eth0.

Code:
[...]
DHCP_KEEPRESOLV[0]="yes"
[...]

Enable the service:

Code:
chmod +x /etc/rc.d/rc.bind
/etc/rc.d/rc.bind start
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Difference between docker.io, docker-cd, and Docker Desktop LXer Syndicated Linux News 0 08-15-2022 05:39 PM
transitioning IPv4 router to dual IPv4/IPv6 psycroptic Linux - Networking 0 04-22-2014 01:44 AM
In tspc ipv6 tunnelling, does tunnel broker required for ipv4 to ipv4 communication? nyk.mat Linux - Newbie 2 08-13-2013 09:48 PM
Disabling IPv4 packet forwarding: net.ipv4.ip_forward = 0 (CentOS 5.5) troiwulful Red Hat 3 11-22-2010 11:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration