LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-21-2010, 09:08 PM   #1
Tim Johnson
Member
 
Registered: Oct 2004
Location: Palmer, Alaska
Distribution: ubuntu 10.04, Slack 13.0/32-bit
Posts: 206

Rep: Reputation: 30
Disturbing Screen Flicker On Slackware 13.0


I'm getting a screen flicker every minute or so. Don't like it
and would sure like to make it go away. I've enabled the screen saver,
and that has not changed the problem.

Any ideas would be welcome.
thanks
tim
 
Old 01-22-2010, 02:12 AM   #2
affinity
Member
 
Registered: Nov 2009
Distribution: Slackware64
Posts: 132

Rep: Reputation: 20
More information would be helpful. Is this a brand new installation? Does it only do this with Slackware? (IE: have you tried a live cd and gotten the same results?) Is it really about every minute, or is it only when you play videos or use desktop effects? etc...
 
Old 01-22-2010, 10:44 AM   #3
Tim Johnson
Member
 
Registered: Oct 2004
Location: Palmer, Alaska
Distribution: ubuntu 10.04, Slack 13.0/32-bit
Posts: 206

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by affinity View Post
More information would be helpful. Is this a brand new installation? Does it only do this with Slackware? (IE: have you tried a live cd and gotten the same results?) Is it really about every minute, or is it only when you play videos or use desktop effects? etc...
1)This is a recent installation of slackware 13.0
2)The flicker appears to be on xfce only.
And I have just recently started using xfce.
I used KDE for several days prior and did not have
that problem
3)It occurs consistently. I haven't timed the intervals, but
can. I've suspected my graphics card, but am not seeing this
flicker on KDE. The flicker does not seem related to playing
videos. I have not used any desktop effects. I see it in
konsole sessions as well as on firefox and other x apps.
However, I will now boot back into xfce and see if my observations
are amended.
 
Old 01-22-2010, 02:31 PM   #4
DonnieP
Member
 
Registered: Jan 2008
Location: Richmond, VA USA
Distribution: Slackware
Posts: 144

Rep: Reputation: 29
Do you perhaps have Intel graphics?
 
Old 01-22-2010, 02:52 PM   #5
Tim Johnson
Member
 
Registered: Oct 2004
Location: Palmer, Alaska
Distribution: ubuntu 10.04, Slack 13.0/32-bit
Posts: 206

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by DonnieP View Post
Do you perhaps have Intel graphics?
Not sure:
Here is the lspci dump for my graphics card:
Code:
VGA compatible controller: nVidia Corporation C61 [GeForce 6150SE nForce 430] (rev a2)
Here's a side issue:
I can't make my choice of screen saver to work on XFCE:
Example:
xfce Menu->System->System Settings->Desktop->Screen Save->Blank Screen
Choose "Start Automatically" and 4 minutes as the time.
Doesn't work.
I still get the default XFCE random rendering screen saver, which is
entertaining (for a while) but, if not a graphics card problem (and to reiterate, I don't have the problem with KDE).
could this be a screen saver issue, and why can't I get the screen saver of choice to work?
thanks
tim

Last edited by Tim Johnson; 01-22-2010 at 02:57 PM.
 
Old 01-22-2010, 03:23 PM   #6
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2
Posts: 7,679
Blog Entries: 57

Rep: Reputation: Disabled
Code:
VGA compatible controller: nVidia Corporation C61 [GeForce 6150SE nForce 430] (rev a2)
That's the same as I've got. No flickering, though. My monitor's an Acer AL1906 19". And I'm using the NVIDIA driver (NVIDIA-Linux-x86_64-185.18.36-pkg2.run, not the latest but it works OK).

Last edited by brianL; 01-22-2010 at 03:27 PM.
 
1 members found this post helpful.
Old 01-22-2010, 04:41 PM   #7
Tim Johnson
Member
 
Registered: Oct 2004
Location: Palmer, Alaska
Distribution: ubuntu 10.04, Slack 13.0/32-bit
Posts: 206

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by brianL View Post
Code:
VGA compatible controller: nVidia Corporation C61 [GeForce 6150SE nForce 430] (rev a2)
That's the same as I've got. No flickering, though. My monitor's an Acer AL1906 19". And I'm using the NVIDIA driver (NVIDIA-Linux-x86_64-185.18.36-pkg2.run, not the latest but it works OK).
And I'm using an 22-inc Acer X221W. Not a very nice display, but it
works.
Two questions Brian:
1)How do I know which driver I'm using?
2)I suspect the XFCE screen saver as a possible source
of the problem. Any ideas of how to turn it off? (See what I tried
from my previous post).
And BTW: After booting into KDE, logging off and restarting XFCE,
I'm seeing this flicker much less often.
thanks
tim
 
Old 01-22-2010, 05:15 PM   #8
affinity
Member
 
Registered: Nov 2009
Distribution: Slackware64
Posts: 132

Rep: Reputation: 20
Post your Xorg.0.log from /var/log, wrap it in code tags if you do please. Double check that desktop effects are not being used, specifically make sure compositing is not being used.
Edit: Also, while waiting for more help, try changing your resolution to each setting your monitor supports to see if that solves the problem.

Last edited by affinity; 01-22-2010 at 05:17 PM.
 
Old 01-22-2010, 05:28 PM   #9
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2
Posts: 7,679
Blog Entries: 57

Rep: Reputation: Disabled
If you haven't installed the nvidia driver you must be using the stock open source nv one.
13.0 doesn't come with an xorg.conf, but you can create one by running xorgsetup as root, and that might(?) sort out your flickering. Try it, at runlevel 3.
Code:
telinit 3
xorgsetup
 
1 members found this post helpful.
Old 01-22-2010, 05:48 PM   #10
Tim Johnson
Member
 
Registered: Oct 2004
Location: Palmer, Alaska
Distribution: ubuntu 10.04, Slack 13.0/32-bit
Posts: 206

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by affinity View Post
Post your Xorg.0.log from /var/log, wrap it in code tags if you do please. Double check that desktop effects are not being used, specifically make sure compositing is not being used.
Edit: Also, while waiting for more help, try changing your resolution to each setting your monitor supports to see if that solves the problem.
See http://www.johnsons-web.com/demo/slack/Xorg.0.log.txt

Desktop effects are turned off. (I turned them off earlier)
From Settings->Window Manager Tweaks->Compositor (tab)
the "Enable display compositing" option is unchecked.
(I think I turned that off also).

The flicker is gone.

And the question remaining is how to enable a screensaver option.
I have tried numerous times from
Menu->System Settings->Desktop->Screen Saver
Picked "Blank Screen", tested, choose "Apply", but that screen
saver is not coming on. Instead, I keep getting that darned XFCE
random screen saver.

Thanks
 
Old 01-22-2010, 05:57 PM   #11
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2
Posts: 7,679
Blog Entries: 57

Rep: Reputation: Disabled
I've logged in to my XFCE desktop to look at the screensaver GUI. There's a drop down menu, "Mode", and one of the choices is "Disable screensaver". Have you tried that?

Last edited by brianL; 01-22-2010 at 05:59 PM.
 
Old 01-22-2010, 06:14 PM   #12
Tim Johnson
Member
 
Registered: Oct 2004
Location: Palmer, Alaska
Distribution: ubuntu 10.04, Slack 13.0/32-bit
Posts: 206

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by brianL View Post
I've logged in to my XFCE desktop to look at the screensaver GUI. There's a drop down menu, "Mode", and one of the choices is "Disable screensaver". Have you tried that?
I'm sorry. I do not see any drop down menus on the panel labeled "mode"
The only one I do see is the Main Xfce Menu.
 
Old 01-22-2010, 06:21 PM   #13
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2
Posts: 7,679
Blog Entries: 57

Rep: Reputation: Disabled
On mine: Xfce main menu => Settings => Screen Saver, and "Mode" is just above where all the screen savers are listed.
 
1 members found this post helpful.
Old 01-22-2010, 06:41 PM   #14
affinity
Member
 
Registered: Nov 2009
Distribution: Slackware64
Posts: 132

Rep: Reputation: 20
Quote:
Originally Posted by Tim Johnson View Post
See http://www.johnsons-web.com/demo/slack/Xorg.0.log.txt

Desktop effects are turned off. (I turned them off earlier)
From Settings->Window Manager Tweaks->Compositor (tab)
the "Enable display compositing" option is unchecked.
(I think I turned that off also).

The flicker is gone.

Thanks
Do you know what you did that made the flicker go away for future reference if anyone else has the problem?
 
Old 01-22-2010, 07:23 PM   #15
Tim Johnson
Member
 
Registered: Oct 2004
Location: Palmer, Alaska
Distribution: ubuntu 10.04, Slack 13.0/32-bit
Posts: 206

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by brianL View Post
On mine: Xfce main menu => Settings => Screen Saver, and "Mode" is just above where all the screen savers are listed.
Yes! There it is. Let's see how it goes now.
thank you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen Flicker xXDarkwolfXx Solaris / OpenSolaris 3 03-03-2009 07:24 PM
nvidia screen flicker 1veedo Linux - Hardware 1 12-23-2008 12:23 PM
Boot Screen Flicker ricbax Fedora 2 09-13-2007 06:43 AM
ATI 9200 SE screen flicker in screen saver gargamel Slackware 12 07-09-2005 04:10 PM
very very slow flicker of the screen wolfchild Red Hat 0 08-19-2004 01:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration