-   Slackware (
-   -   Display Turns Off When startx is used (

Maverickmage 11-03-2004 09:21 PM

Display Turns Off When startx is used

I have installed slackware 10.0 I used the walkthrough on the top of the forum. However, when I go to startx it turns my moniter off and the system hangs. I tried to get xf86config to run as root but it won't I also tried it as a regular user no effect. I found another spot where I could edit the file and tried changing my horizontal and vertical sync. This caused the moniter to turn off and on rapidly but still not bring up xwindows. I installed kde as the graphic program.

Thanks alot for your help

Netizen 11-03-2004 09:29 PM

Sounds like you need to make sure your monitor and video card settings in your xorg.conf or XF86Config.conf match your hardware.

Maverickmage 11-04-2004 09:41 AM

I changed the horizontal and vertical syncs in xorg.conf this created a new problem, the moniter half turns on/off It is hard to explain but the screen that shows when the power is off (NO Device connected) starts to show up then it dissapears, then shows up and disapears. It does this really, really fast, you have to be watching for it to come up. On other sites it said try running xf86config and XF86config I looked all over to find where these programs were contained and I can't find them anywhere. It would be easier to run the program they are talking about rather then for me as a newbie to did through config files to find where to set the settings. thanks

gbonvehi 11-04-2004 11:14 AM

Since the move to instead of Xfree86, the configuration program is xorgconfig. Others are xorgcfg, X -configure.

Maverickmage 11-04-2004 11:38 AM

okay, I have seen the file xorgconfig.... what is the full path to it /etc/X11R6 once I am in that directory do I just type xorgconfig to get it to run and should I be logged in as root or just a normal user? thanks

XavierP 11-04-2004 11:40 AM

Use the su command to become root (you then have to type in root's password) and then run xorgconfig.

187807 11-04-2004 03:17 PM


Originally posted by XavierP
Use the su command to become root (you then have to type in root's password) and then run xorgconfig.
Just a thought regarding "su" ...

On my machine (may have messed with paths in the past and don't remember) if I "su" to become root then "xorgconfig" is not found in the paths.

However, if I "su -" to become root then "xorgconfig" is found in the path.

Again, not sure if this is particular to my system or if this is true in general...just wanted to say it in case it's the case with others' systems as well.

suslik 11-04-2004 05:43 PM

Dude, dont confuse xorg.conf (- config file in /etc/X.. folder) with xorgcfg, xorgconfig, xorgsetup (the utilities to configure X, usually somewhere in /usr/X11R6/bin/

Maverickmage 11-04-2004 06:10 PM

okay, I got the xorgconfig to run.... I had to do it as a regular user save it, switch to root and then put it in the /etc/X11 folder. However a new problem arrises, Xserver now errors out and says that no screens are found.... any suggestions on this one, otherwise more searching for me....

J.W. 11-04-2004 06:20 PM

Post your xorg.conf file -- J.W.

Maverickmage 11-04-2004 06:22 PM

hey I got x to start and kde

I messed up the config when I did it that is why I got the screen message like I did, I simple search on linuxquestions got me the answer for that one.

when i rewrote the file I used # su - to log on as root, and that allowed for it to find xorgconfig.

thanks guys for the help

All times are GMT -5. The time now is 06:31 AM.