-   Slackware (
-   -   display chinese characters in file browser (

patostevens 01-27-2011 06:46 PM

display chinese characters in file browser
Using Fluxbox, have tried this in XFCE and KDE. Chinese characters display properly in whatever browser I use online. I do need to see some in the file manager and this is not working. I have installed the following chinese display files from Slack -

No results so far. What am I missing here?

dugan 01-27-2011 06:49 PM

Have you edited /etc/profile.d/ and set your $LANG variable to something other than en_US? en_US.UTF-8, perhaps?

patostevens 01-27-2011 07:46 PM

Thanks Dugan. I did as you suggested and now am getting a few chinese characters and then a lot of black diamonds with a question mark in the center of them. Better than before but didn't quite cure the problem.

brixtoncalling 01-27-2011 11:02 PM

Generally Qt programs have very good support for different character sets. It could be that you need to find a font with better Chinese support. Try KDE's system settings to see if changing things works. kde-l10n-zh only gives you KDE in the Chinese language, you don't need it to actually see Chinese text or filenames.

patostevens 01-28-2011 10:56 AM

I probably wasn't clear enough to start with. My specific need is to be able to see chinese filenames with the native characters in them. (Got to do with some files for a Kindle.) I have tried running kde and using dolphin and got no different results.

patostevens 01-28-2011 08:52 PM

Tried the system settings in KDE - no luck. All I need to do is see some filenames in the file manager. Any suggestions?

linuxs64 01-29-2011 02:02 AM

edit /etc/profile.d/


# en_US is the Slackware default locale:
# export LANG=en_US
export LANG=en_US.UTF-8
You need to logout and log in to see the effect.

I don't use KDE, maybe try another file manager such as thunar. It works in thunar using what I've described above.

grissiom 01-29-2011 02:14 AM

Are your Chinese-named files located in a EXT or a ntfs partition? If they are in ntfs, please add "locale=zh_CN.UTF-8" to /etc/fstab(assume your desktop encoding is UTF-8)

Good Luck.

patostevens 01-29-2011 10:41 AM

linuxs64: did log out/in. Slight improvement as noted in my second post in this thread.

grissiom: the files are on a regular linux partition - no NTFS.

brixtoncalling 01-29-2011 10:57 AM

What font are you using in KDE? Could you past a couple of the problematic file names here so we can try to reproduce the problem?

patostevens 01-29-2011 07:56 PM

Here is a list of two of the directory names
pat[~]$ dir /home/pat/Duokan/
12-31++ݾ 1231ŷ汾

In any browser, these names are showing in chinese characters. It's just when it hits my system that the display goes south.

brixtoncalling 01-29-2011 09:51 PM

Perhaps in copying the file from its source the filename became corrupted due to conversion problems coming from a filesystem not using unicode?

Can you create a new file with Chinese characters? I just created a new file called "汉语⁄漢語" (which is Chinese for Chinese apparently!) in Dolphin and on the commandline using urxvt. No problems.

patostevens 01-29-2011 10:51 PM

That sounds likely. I think this guy's file names are just corrupted. Oh well - thanks for all the effort and ideas.

All times are GMT -5. The time now is 11:21 PM.