LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-13-2016, 02:47 AM   #1
cgorac
Member
 
Registered: Oct 2009
Posts: 146

Rep: Reputation: 87
disabling PulseAudio


In about 5 minutes after installing latest -current update, I started to hate this new PulseAudio thing: my scripts for ACPI toggle-mute/volume-up/volume-down events (based on simple commands like "amixer set Master toggle" for muting/unmuting, and alike) aren't working any more, alsamixer seems completely unreliable now (sometimes it executes volume level change, sometimes it doesn't), then I really hate that Pulse spits .esd-* and pulse-* directories all over my /tmp directory, etc. Moreover, the documentation available on the net is very confusing, it seems like that users are expected to learn every single detail about sound server architecture in order to be able to do anything with this thing... So, is it possible to somehow disable it completely? If I understood properly what I was able to parse from the docs, it seems like it acts as a layer between apps and ALSA, so I hope that it's possible to disable it somehow. I tried with changing "autospawn=yes" to "autospawn=no" in the /etc/pulse/client.conf but that doesn't work, any other suggestions?

Thanks.
 
Old 01-13-2016, 02:51 AM   #2
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 10,435

Rep: Reputation: 4914Reputation: 4914Reputation: 4914Reputation: 4914Reputation: 4914Reputation: 4914Reputation: 4914Reputation: 4914Reputation: 4914Reputation: 4914Reputation: 4914
I'd assume you'd need to remove the lines in /etc/asound.conf that redirect audio sent to ALSA to Pulseaudio.

Last edited by dugan; 01-13-2016 at 02:55 AM.
 
Old 01-13-2016, 03:03 AM   #3
cgorac
Member
 
Registered: Oct 2009
Posts: 146

Original Poster
Rep: Reputation: 87
Quote:
Originally Posted by dugan View Post
I'd assume you'd need to remove the lines in /etc/asound.conf that redirect audio sent to ALSA to Pulseaudio.
That was quick, many thanks! Indeed it seems that removing /etc/asound.conf, and then adding following two lines to /etc/pulse/client.conf:
Code:
autospawn = no
daemon-binary = /bin/true
would do in order to disable the damn thing.
 
9 members found this post helpful.
Old 01-13-2016, 03:10 AM   #4
_gin
Member
 
Registered: Aug 2012
Distribution: Oracle Linux
Posts: 106

Rep: Reputation: Disabled
Fn+F8 and Fn+F9 doesn't work anymore to increase or decrease the sound volume (xfce).

I tried to rewrite /etc/asound.conf with alsa instead of pulse but clearly this does not work.
 
Old 01-13-2016, 03:15 AM   #5
kkady32
Member
 
Registered: Dec 2010
Distribution: Slackware64-current
Posts: 115

Rep: Reputation: 42
have you /etc/rc.d/rc.pulseaudio executable?
 
Old 01-13-2016, 03:51 AM   #6
ReaperX7
LQ Guru
 
Registered: Jul 2011
Location: California
Distribution: Slackware64-15.0 Multilib
Posts: 6,510
Blog Entries: 15

Rep: Reputation: 2071Reputation: 2071Reputation: 2071Reputation: 2071Reputation: 2071Reputation: 2071Reputation: 2071Reputation: 2071Reputation: 2071Reputation: 2071Reputation: 2071
Also don't forget -Current is still in Beta status, and Pulse is new to the mix.
 
1 members found this post helpful.
Old 01-13-2016, 04:28 AM   #7
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 8,559

Rep: Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086
In my blog article about -current and pulseaudio I pointed to this Arch Wiki article which shows how you can keep ALSA as the boss and allow pulse-enabled apps to fire up a pulseaudio server "on-demand" to pipe sound into ALSA:
https://wiki.archlinux.org/index.php...b_pipe_to_ALSA
 
6 members found this post helpful.
Old 01-13-2016, 04:48 AM   #8
cgorac
Member
 
Registered: Oct 2009
Posts: 146

Original Poster
Rep: Reputation: 87
Quote:
Originally Posted by ReaperX7 View Post
Also don't forget -Current is still in Beta status, and Pulse is new to the mix.
What's the point of this post, what makes you think that anyone here needs your reminders about such obvious facts?
 
Old 01-13-2016, 04:56 AM   #9
cgorac
Member
 
Registered: Oct 2009
Posts: 146

Original Poster
Rep: Reputation: 87
Quote:
Originally Posted by Alien Bob View Post
In my blog article about -current and pulseaudio I pointed to this Arch Wiki article which shows how you can keep ALSA as the boss and allow pulse-enabled apps to fire up a pulseaudio server "on-demand" to pipe sound into ALSA:
https://wiki.archlinux.org/index.php...b_pipe_to_ALSA
Thanks Eric. You mention in your blog post that several other packages get recompiled against PulseAudio, but neither your blog post nor -current change log explicitly lists those packages. I guess one can find them by looking at binaries linked with PulseAudio libraries, but my questions here is: are there some packages that now use PulseAudio API directly and exclusively, instead of going through backwards-compatible ALSA API -> PulseAudio -> ALSA driver route?
 
Old 01-13-2016, 05:03 AM   #10
ReaperX7
LQ Guru
 
Registered: Jul 2011
Location: California
Distribution: Slackware64-15.0 Multilib
Posts: 6,510
Blog Entries: 15

Rep: Reputation: 2071Reputation: 2071Reputation: 2071Reputation: 2071Reputation: 2071Reputation: 2071Reputation: 2071Reputation: 2071Reputation: 2071Reputation: 2071Reputation: 2071
Quote:
Originally Posted by cgorac View Post
What's the point of this post, what makes you think that anyone here needs your reminders about such obvious facts?
First off turn down your tone a bit because clearly you're the one who failed to see an obvious fact. So pot meet kettle.

Not liking something that is in the testing stages is more or less a piss poor argument to make over an included package. You knew full well using -Current means things are going to not work correctly on any level and there's going to be issues until everything is finalized.

If you have problems with Pulse, ask about how you can fix it, tweak it, tune it, or disable it to use another service, but expect replies like mine when you use -Current because 5 minutes in isn't really saying much to hold water.

Above all else you can be respectful, even if you do not agree with what is said.
 
1 members found this post helpful.
Old 01-13-2016, 06:00 AM   #11
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 8,559

Rep: Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086
Quote:
Originally Posted by cgorac View Post
Thanks Eric. You mention in your blog post that several other packages get recompiled against PulseAudio, but neither your blog post nor -current change log explicitly lists those packages. I guess one can find them by looking at binaries linked with PulseAudio libraries, but my questions here is: are there some packages that now use PulseAudio API directly and exclusively, instead of going through backwards-compatible ALSA API -> PulseAudio -> ALSA driver route?
Hopefully, all packages have been recompiled that optionally can be built against libpulse or where Slackware had to explicitly disable pulseaudio in the past to make the software compile. The intention is that all packages in Slackware use PulseAudio directly. If any package was overlooked, it's just that - overlooked - and should be reported to Pat.
 
Old 01-13-2016, 06:47 AM   #12
igor29768
LQ Newbie
 
Registered: Oct 2015
Distribution: Slackware64-current
Posts: 25

Rep: Reputation: Disabled
ALSA/dmix without grabbing hardware device

Instead of configuring ALSA to use PulseAudio, I configured the opposite --
to make PulseAudio using ALSA/dmix instead of grabbing ALSA hardware device,
as it described on Archwiki:
  • remove/disable asound.conf
  • configured /etc/pulse/deafult.pa
    as:

Code:
load-module module-alsa-sink device=dmix
load-module module-alsa-source device=dsnoop
Both, ALSA and PulseAudio applications work fine for me.
 
2 members found this post helpful.
Old 01-13-2016, 06:49 AM   #13
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 8,559

Rep: Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086
Quote:
Originally Posted by igor29768 View Post
Instead of configuring ALSA to use PulseAudio, I configured the opposite --
to make PulseAudio using ALSA/dmix instead of grabbing ALSA hardware device,
as it described on Archwiki:
  • remove/disable asound.conf
  • configured /etc/pulse/deafult.pa
    as:

Code:
load-module module-alsa-sink device=dmix
load-module module-alsa-source device=dsnoop
Both, ALSA and PulseAudio applications work fine for me.
Yes, that was what I also told a few posts back... only I posted the URL and not part of its contents. Good to have the module-alsa example lines here though, because that makes the LQ search find this thread in future.
 
Old 01-13-2016, 07:13 AM   #14
igor29768
LQ Newbie
 
Registered: Oct 2015
Distribution: Slackware64-current
Posts: 25

Rep: Reputation: Disabled
Quote:
Originally Posted by Alien Bob View Post
Yes, that was what I also told a few posts back... only I posted the URL and not part of its contents. Good to have the module-alsa example lines here though, because that makes the LQ search find this thread in future.
I am wondering, if Pulse Audio is still nowadays resampling all audio data to a preferred output resolution?
That was one of my original issues with Pulse Audio, when I had to add it about two years ago. In the recent article on opensource.com, Chris Hermansen, still advises to get a second sound card just to bypass Pulse Audio via sending music directly to ALSA controlled card #2.
 
Old 01-13-2016, 07:47 AM   #15
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 8,559

Rep: Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086Reputation: 8086
Quote:
Originally Posted by igor29768 View Post
I am wondering, if Pulse Audio is still nowadays resampling all audio data to a preferred output resolution?
That was one of my original issues with Pulse Audio, when I had to add it about two years ago. In the recent article on opensource.com, Chris Hermansen, still advises to get a second sound card just to bypass Pulse Audio via sending music directly to ALSA controlled card #2.
The KODI WIki has a section on resampling and PulseAudio and what your options are: http://kodi.wiki/view/PulseAudio#Audiophile_Pulse_User
 
4 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
pulseaudio Phorize Slackware 4 12-24-2011 06:40 AM
PulseAudio blakey Linux - Software 1 06-22-2011 03:13 PM
[SOLVED] Squeeze + Pulseaudio + Alsa and USB Midi device causes Pulseaudio crash mad4linux Debian 1 01-26-2011 03:57 AM
Winecfg crashes on sound tab with Pulseaudio and no 'sounddrivers' without pulseaudio William (Dthdealer) Linux - Software 5 06-13-2010 07:30 AM
Pulseaudio RAFAL Linux - Software 7 08-23-2008 03:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration