LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-14-2014, 01:19 PM   #1
kikinovak
MLED Founder
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: CentOS, OpenSUSE
Posts: 3,437

Rep: Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095
Disabling IPv6 seems to break CUPS


Hi,

I have a headless LAN server running Slackware64 14.1. I've disabled IPv6 using "ipv6.disable=1" in the kernel boot options.

I'm currently trying to setup a printer (Sharp AR-M256) using CUPS. Here's my cupsd.conf file:

Code:
# Log general information in error_log - change "warn" to "debug"
# for troubleshooting...
LogLevel warn

# Administrator user group...
SystemGroup sys root


# Only listen for connections from the local machine.
Port 631
Listen /var/run/cups/cups.sock

# Show shared printers on the local network.
Browsing On
BrowseAddress @LOCAL
BrowseOrder allow,deny
BrowseAllow 192.168.2.*
BrowseLocalProtocols CUPS

# Default authentication type, when authentication is required...
DefaultAuthType Basic

# Web interface setting...
WebInterface Yes

# Restrict access to the server...
<Location />
  Order allow,deny
  Allow From 127.0.0.1
  Allow From 192.168.2.*
</Location>

# Restrict access to the admin pages...
<Location /admin>
  Order allow,deny
  Allow From 127.0.0.1
  Allow From 192.168.2.*
</Location>

# Restrict access to configuration files...
<Location /admin/conf>
  AuthType Default
  Require user @SYSTEM
  Order allow,deny
  Allow From 127.0.0.1
  Allow From 192.168.2.*
</Location>

...
I tried to send a test page to the printer and got the following error message in the CUPS web interface:

"Failed to connect to system bus"

A peek in /var/log/cups/error.log shows me this:

Code:
E [14/Sep/2014:19:42:17 +0200] Unable to open listen socket for address [v1.::1]:631 - Address family not supported by protocol.
E [14/Sep/2014:19:43:49 +0200] Unable to open listen socket for address [v1.::]:631 - Address family not supported by protocol.
E [14/Sep/2014:19:46:22 +0200] Unable to open listen socket for address [v1.::]:631 - Address family not supported by protocol.
E [14/Sep/2014:19:47:16 +0200] [cups-deviced] PID 4035 (snmp) stopped with status 1!
E [14/Sep/2014:19:48:24 +0200] [Job 1] Failed to connect to system bus
E [14/Sep/2014:19:53:41 +0200] [Job 1] Stopping unresponsive job!
I googled about the problem, but found nothing conclusive besides reactivating IPv6.

Any suggestions?
 
Old 09-14-2014, 01:30 PM   #2
fsLeg
Member
 
Registered: Dec 2013
Location: Russia, Moscow
Distribution: Slackware, Debian
Posts: 81

Rep: Reputation: Disabled
Quick googling revealed possible solution: try removing/commenting all IPv6 addresses from /etc/hosts.
 
Old 09-14-2014, 03:16 PM   #3
kikinovak
MLED Founder
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: CentOS, OpenSUSE
Posts: 3,437

Original Poster
Rep: Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095
Quote:
Originally Posted by fsLeg View Post
Quick googling revealed possible solution: try removing/commenting all IPv6 addresses from /etc/hosts.
I don't have any IPv6-related lines in /etc/hosts. On the other hand, reactivating IPv6 solved the problem, at least temporarily.
 
Old 09-14-2014, 03:56 PM   #4
fsLeg
Member
 
Registered: Dec 2013
Location: Russia, Moscow
Distribution: Slackware, Debian
Posts: 81

Rep: Reputation: Disabled
Did you try to explicitly specify `Listen 127.0.0.1:631` (or whatever address you want to bind it to) instead of `Port 631`? I just did and it looks like that "Address family not supported by protocol" error is gone. But I don't have any printers, neither do I know how to work with CUPS, so I can't test if it actually helps.

It is strange that CUPS tries to bind itself to IPv6 address even if kernel doesn't have IPv6 support. It's even more strange that this doesn't happen on some installations.
 
Old 09-14-2014, 05:09 PM   #5
kikinovak
MLED Founder
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: CentOS, OpenSUSE
Posts: 3,437

Original Poster
Rep: Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095Reputation: 2095
Apparently this is a weird bug in CUPS.
 
Old 09-14-2014, 07:28 PM   #6
Andersen
Member
 
Registered: Dec 2008
Distribution: Slackware
Posts: 123

Rep: Reputation: 49
Have you tried disabling ipv6 by adding blacklist ipv6 in /etc/modprobe.d/blacklist.conf? Does it make any difference?
 
Old 09-15-2014, 12:53 AM   #7
BratPit
Member
 
Registered: Jan 2011
Posts: 239

Rep: Reputation: 86
I've got no compiled IPv6 at all /custom karnel/ and CUPS work.
Must be another cause.
 
Old 09-17-2014, 06:18 AM   #8
EYo
Member
 
Registered: Jun 2009
Location: Cloverdale, northern california
Distribution: Slackware 14.2
Posts: 185

Rep: Reputation: 153Reputation: 153
getaddrinfo?

Long shot: /etc/gai.conf
Code:
# Configuration for getaddrinfo(3).
#
# So far only configuration for the destination address sorting is needed.
# RFC 3484 governs the sorting.  But the RFC also says that system
# administrators should be able to overwrite the defaults.  This can be
# achieved here.
#
# All lines have an initial identifier specifying the option followed by
# up to two values.  Information specified in this file replaces the
# default information.  Complete absence of data of one kind causes the
# appropriate default information to be used.  The supported commands include:
#

#    For sites which prefer IPv4 connections change the last line to
#
precedence ::ffff:0:0/96  100
Or this (unresolved):
Avahi reports IPv6/IPv4 and "dnssd" CUPS backend only tries IPv6, no IPv4 fallback
https://www.cups.org/str.php?L4305

Last edited by EYo; 09-17-2014 at 07:48 AM. Reason: Link to CUPS bug #4305
 
Old 09-17-2014, 07:49 AM   #9
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,230

Rep: Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724
Maybe say explicitly to listen to an IPV4 address in cupsd.conf?
Code:
Listen 127.0.0.1:631
Edit, I believe you have to add the server network IP (192.168.2.?) to make it accessible from Lan
(not sure though)

Code:
#Port 631
Listen 127.0.0.1:631
Listen /var/run/cups/cups.sock
Listen <server IP>:631
Edit2, just noticed fsLeg posted same suggestion a long time ago, bah..

Last edited by keefaz; 09-17-2014 at 08:16 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Opensuse 12.3 and disabling IPv6 pancakefiend Linux - Newbie 2 04-19-2013 11:04 AM
Disabling ipv6 on SuSE 10.0 VIR3NT SUSE / openSUSE 3 05-14-2009 06:08 AM
Disabling IPv6 thomaspsimon Linux - Networking 2 06-25-2007 04:36 AM
confused on disabling IPv6 arnuld Debian 5 06-13-2007 06:11 PM
disabling ipv6 felosi Debian 7 06-05-2006 10:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration