LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-22-2005, 11:44 AM   #1
Kane2002
Member
 
Registered: Dec 2002
Location: UK
Distribution: Slackware, Zenwalk
Posts: 173

Rep: Reputation: 30
Disable Modules on startup


hi
well ive managed to get my sound working in slackware 10

using the nvsound drivers.

but the problem i have now is that everytime i reboot i have to type

/etc/init.d/alsasound stop

then

modprobe nvsound

before i can have sound working.

im pretty much new and dont know much about modules. but looked in /etc/modules.conf and it was blank.

and looked in the rc.modules ...but i couldnt see anything related to alsa being loaded.

so what do i need to do to stop alsa from loading and automatically load nvsound?

thanks alot guys
Kane
 
Old 01-22-2005, 11:49 AM   #2
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
you could put them in /etc/hotplug/blacklist.
that will prevent loading them by hotplug

and to load the other module at boot, add a line like
" /sbin/modprobe nvsound "
in rc.modules.

egag
 
Old 01-22-2005, 12:00 PM   #3
Kane2002
Member
 
Registered: Dec 2002
Location: UK
Distribution: Slackware, Zenwalk
Posts: 173

Original Poster
Rep: Reputation: 30
sorry to be so n00bish .. but what would i need to add to the blacklist file?

i have no idea what im looking for

but have added the nvsound to the modules file
 
Old 01-22-2005, 12:06 PM   #4
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
look at the output of " $lsmod "
all modules starting with " snd " are alsa.

but i remember there was another way to stop alsa but i wonder where i saw that.......

maybe someone else can answer that.
meanwhile you could check if the blacklist option works for you....

egag
 
Old 01-22-2005, 12:14 PM   #5
sybille
Member
 
Registered: Dec 2004
Location: France
Posts: 41

Rep: Reputation: 15
In /etc/rc.d, do you find a file called "rc.alsa"? Is it executable?

If so, then I'd think that this is what is loading the alsa drivers at boot. You could prevent this by changing the permissions of the rc.alsa file, so that it no longer can be executed.
 
Old 01-22-2005, 12:19 PM   #6
Kane2002
Member
 
Registered: Dec 2002
Location: UK
Distribution: Slackware, Zenwalk
Posts: 173

Original Poster
Rep: Reputation: 30
^^ yeh i think i do remember seeing a rc.alsa in there

i'll have a look later.

and so to change it so it cant be execute i just use chmod 0666 ?

(im still learning )

thanks
Kane
 
Old 01-22-2005, 12:26 PM   #7
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
me to......
guess that's it.
thanks sybille

egag
 
Old 01-22-2005, 12:31 PM   #8
sybille
Member
 
Registered: Dec 2004
Location: France
Posts: 41

Rep: Reputation: 15
Well, I'm still learning, too.

In fact, I find the whole thing with permissions kind of confusing and I often resort to setting them ROX-Filer, which I suppose some of you out there will find amusing...

However, I've also read this HOWTO:
http://www.linuxquestions.org/questi...ticle&artid=20

In order to remove the permission to execute for owner, group, and everyone else, this is what I think you want:
Code:
chmod 600 /etc/rc.d/rc.alsa
I sure someone will be along to straighten things out if that isn't correct.
 
Old 01-22-2005, 12:40 PM   #9
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
or you can use :

#chmod -x /etc/rc.d/rc.alsa

egag
 
Old 01-22-2005, 04:06 PM   #10
Kane2002
Member
 
Registered: Dec 2002
Location: UK
Distribution: Slackware, Zenwalk
Posts: 173

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by egag
or you can use :

#chmod -x /etc/rc.d/rc.alsa

egag
thanks that worked fine

its working great now

(starting to love linux hehe)

although i get a warning message, i got the same message just after i installed the drivers. and its:
/something/nvsound.o will taint the kernell: no license

i still works fine ...but does anyone know what this means? and if i cant stop it?

thanks once again everyone

Kane
 
Old 01-22-2005, 04:26 PM   #11
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
------------
/something/nvsound.o will taint the kernell: no license
------------

that's just a message. ( don't think it's bad....)

egag
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I disable modules without recompiling my Kernal? thorlin SUSE / openSUSE 1 09-23-2005 07:15 AM
Apache 2 Modules which I can disable loading.. latino Linux - Networking 2 10-16-2004 03:14 AM
disable modules from loading on boot spyderusa11 Fedora 1 05-23-2004 05:58 PM
how do I disable kernel modules from being loaded hdagelic Linux - General 1 04-09-2004 03:53 AM
HOWTO - disable modules at boot lazlow69 Debian 4 01-21-2004 05:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration