LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Digital Camera Broke my ISP Connector (https://www.linuxquestions.org/questions/slackware-14/digital-camera-broke-my-isp-connector-389148/)

jeff1500 12-04-2005 12:03 PM

Digital Camera Broke my ISP Connector
 
I just got a digital camera working with Slackware 9.1 using gphoto / gtkam

I ran the standard installs and did not mess with anything. It worked fine.

However, Now I can't connect to the internet as a regular user. The KPPP dialer to my ISP connects as user, but when I enter an addres into Mozila Firefox it won't connect to the address. It worked fine until I did something with the camera that I can't figure out.

When I log in as root, everything works fine. Does that mean I have a user permission problem?

ls -al /etc/resolv.conf
-rw-r--r-- 1 root root 163 Dec 4 11:41 /etc/resolv.conf

ls -al /usr/sbin/pppd
-rwxr-xr-x 1 root bin 193968 Sep 13 2003 /usr/sbin/pppd*

I tried chmod 777 on both the above files but that didn't help so I put them back as they were.

Any advice would be appreciated.

What files should have what permission to allow users to use KPPP for a dialup ISP?

jeff1500 12-04-2005 03:38 PM

Fixed it.

The domain name got deleted from the user's KPPP window. Root had it but user didn't. It had enough info to connect to the ISP but not to go anyplace.

Must have hit something by accident.


All times are GMT -5. The time now is 05:05 PM.