LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-18-2017, 01:01 PM   #16
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,802

Rep: Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713

I would not regret kde4, probably the worst version of kde, since the first, it's just my opinion
 
Old 07-25-2017, 01:55 AM   #17
Bourdieu
Member
 
Registered: Jan 2006
Location: Paris
Distribution: Slackware current
Posts: 38

Original Poster
Rep: Reputation: 11
I ran digikam in gdb and found out that a qt5 library was the culprit :

Code:
Program received signal SIGSEGV, Segmentation fault.
0x00007fffdfe4a567 in QMetaObject::className() const () from /usr/lib64/libQt5Core.so.5
I removed qt5-5.7.1-x86_64-1alien package and rebuilt all the digikam queue.

Problem solved.

Thanks for your help
 
1 members found this post helpful.
Old 07-25-2017, 04:22 PM   #18
cwizardone
LQ Guru
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 5,765
Blog Entries: 1

Rep: Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105
Quote:
Originally Posted by willysr View Post
That's because i didn't build the extra package which contains the kipi-plugins in the current digiKam in SBo.
In my personal script, i have added that build and it's available in digiKam's menu.
Just built digiKam using sbopkg and there are now, between Images, Tools and Batch Processing, 31 plug-ins available via Gwenview (not counting import and export).
Opencv-3.2 from Alien Bob was installed when I built it and when I tried to access the plug-ins from Gwenview, Gweniew would seg fault.
So, I tried firing up digiKam from a prompt and it wouldn't start and said it was looking for libopencv_face.so.3.1. So I installed opencv-3.1 and then when I tried to start digikam the message was it was looking for libopencv_face.so.3.2.

Doesn't matter. I never use digiKam, but with opencv-3.1 installed, the plug-ins now work in Gwenview. That's all I need.

Last edited by cwizardone; 07-25-2017 at 04:25 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
digikam 4.14 on -Current hoodlum7 Slackware 2 11-12-2016 07:02 AM
[SOLVED] Slack64-current and Digikam-5.2.0 3rensho Slackware 2 09-26-2016 05:55 AM
Segfault with E17 on Slackware --Current frankbell Slackware 5 03-26-2013 07:19 PM
[SOLVED] -current and Digikam smoooth103 Slackware 28 09-19-2012 04:27 AM
Xterminal + current GTK = segfault crxssi Linux - Software 3 01-28-2006 06:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration