-   Slackware (
-   -   digikam no compile (

micder 02-12-2009 10:10 AM

digikam no compile
Got Slack-12.1 and KDE-3.5.9.
Tried to install digikam.
./configure went OK

checking for Qt... libraries /usr/lib/qt-3.3.8b/lib, headers /usr/lib/qt/include using -mt

-- digiKam configure results -------------------
-- libsqlite3 library found....... YES
-- libgphoto2 library found....... YES
-- libkipi library found.......... YES
-- libtiff library found..... .... YES
-- libpng library found........... YES
-- libjasper library found........ YES
-- liblcms library found.......... YES
-- libkexiv2 library found........ YES
-- libkdcraw library found........ YES

Good - your configure finished. Start make now

make fails with

grep: /usr/lib/qt-3.3.8/lib/ No such file or directory
/usr/bin/sed: can't read /usr/lib/qt-3.3.8/lib/ No such file or directory
libtool: link: `/usr/lib/qt-3.3.8/lib/' is not a valid libtool archive

Searching on linuxquestions brought me to ~alien/slackbuilds.
Installation of Bob's packages gave me digikam.:)
I'l keep that site in mind, it's fantastic!

However, it keeps nagging me that my compilation did not succeed.
Anybody any ideas why?

gegechris99 02-12-2009 12:31 PM


Your compile error seems to indicate that is missing.

Have you 12.1 package qt-3.3.8b-i486-2.tgz installed on your system? If yes, try to reinstall the package.

Furthermore, digikam has several dependencies. So make sure to install them to avoid any trouble.

One way to compile flawlessly digikam and its dependencies is to use Slackbuilds (shell scripts that automate the compilation and creation of packages).

Here's the link to digikam Slackbuild for 12.1 (the dependencies are listed in the README):

micder 02-13-2009 10:10 AM

Reinstallation of qt-3.3.8b-i486-2.tgz solved the problem.
Original install somehow borked...?
Anyhow thank you.

All times are GMT -5. The time now is 10:13 AM.