-   Slackware (
-   -   Digikam from SBo does not compile on 64-current of 2010-03-09 (

gargamel 03-10-2010 04:44 PM

Digikam from SBo does not compile on 64-current of 2010-03-09
Hi everyone,

I just used sbopkg to download and compile Digikam 1.0.0 from But compilation stops with an error regarding "png loader". I guess this has to do with the libpng issue mentioned in the changelog.

Nevertheless: Has anyone been able to compile Digikam on the latest Slackware64-current?



Daedra 03-10-2010 04:53 PM

same here, I heard that its fixed in SVN but I can't find a patch for 1.0.0 or 1.1.0

55020 03-10-2010 05:11 PM

1 Attachment(s)
I've cooked up a patch against 1.1.0, it builds but I haven't tested it yet - you're welcome to do the testing for me ;)

I've also done similar patches for enblend-enfuse and hugin. Hopefully I'll be putting them up on github when I've got the hang of it.

kd5zex 03-14-2010 11:57 PM

Built on 64-current on 2010-03-14
I applied the patch and Digikam compiled on 64-current for me.

gargamel 03-15-2010 03:04 PM

Will try it on the weekend --- short on time, for the next few days. But thanks, anyway!


Nille_kungen 03-16-2010 01:56 PM

If the patch works as it should then i can add it to SBo since i will update it for 1.1.0.
I made a patch from svn that i'm trying now.

BrZ 03-16-2010 07:48 PM

@Nille, your path include this:

--- /libs/dimg/loaders/pngloader.cpp 2009-12-21 11:20:36.000000000 +0200
+++ /libs/dimg/loaders/pngloader.cpp 2010-01-20 20:18:51.000000000 +0200
@@ -29,6 +29,7 @@

#include "pngloader.h"
+#include "pngconf.h"

// C ANSI includes

I built mine with the same patch floating around and still get this error when start Digikam from console:


libpng warning: Application was compiled with png.h from libpng-1.2.42
libpng warning: Application is running with png.c from libpng-1.4.1
libpng warning: Incompatible libpng version in application and library
I'll try the third build with "pngconf.h" and another patch to libjpeg8...

BrZ 03-16-2010 08:33 PM

No lucky =[

Nille_kungen 03-17-2010 05:34 AM

1 Attachment(s)
No i don't have that in my patch.
Uploaded my patch that needs some testing first.

BrZ 03-17-2010 11:24 AM

I think I found my mistake... I have qt-462 (kde-git) and it was built before libpng14 was introduced. This night I recompiled qt and now digikam 'seems' to work, but I lost firefox and konqueror only start from console... feck! I'll try to sorth the mess and play again with digikam. As I was playing with gtk2-2.18.8 and rebuilt/updated a few deps, this can take some time...


ps: I'll remove that reference to "pngconf".

edit: Sorted the mess (was gtk+2). Digikam built fine after patched, but exporting to png always segfault. Tried svn rev.1104823 and failed to build with warnings about "selectInAlbumManager". The good news: the dev team scheduled 1.2.0 to be released around march 28 =]

gargamel 03-21-2010 05:28 PM


Originally Posted by Nille_kungen (Post 3901573)
No i don't have that in my patch.
Uploaded my patch that needs some testing first.

Thanks a lot, with your patch I was able to compile Digikam 1.1.0 on my Slackware64-current system. First few tests were successful with showFoto.


All times are GMT -5. The time now is 02:25 AM.