Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 12-06-2006, 08:56 AM   #1
LQ Newbie
Registered: Jul 2005
Location: Slovakia
Distribution: Slackware
Posts: 9

Rep: Reputation: 0
digikam and usbcam permissions on slackware 11 - tried everything :(

hello guys.

i wonder whether there is anybody who can shed some light into my mysterious problems with digikam/gphoto2/libgphoto. i've been using those on my laptop and desktop for the past two years without any problems. i always followed simple instructions on setting up the /etc/hotplug/usb/usbcam file for correct permissions and it simply worked. not anymore!

after upgrade to slack 11, digikam doesn't work properly on neither of my computers. that means, i can only access my camera as root. i've tried everything i've was able to find on forums without any success. than i've tried one of those desperate solutions and set suid on gphoto2. after that, i was able to access my camera via CLI with gphoto2. but it still didn't help to get digikam working.

i'm not the only one accessing those computers as my wife uses camera a lot and it's somehow tricky to explain her that she must log-in as root to download pictures, agrrrr.

i'm no expert on these things and cannot come up with some logical solution on my own. all i can say is that i have a gut feeling that usbcam script is never called after i plug my camera in. maybe i'm just being stupid and don't see some crucial details, but having no problems for 2 years (even after upgrading previous slackware versions) i feel a bit dissoriented.

therefore, any help would be appreciated.

Old 12-06-2006, 01:06 PM   #2
Senior Member
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,519

Rep: Reputation: 62
I had an issue like this, but it was for a scanner. I wound up finding on the qemu forums a gent who advised to do the following, note it worked for me your mileage may vary:

A note of caution: I have read an old security advisory, but cannot confirm if this is still a potential security risk or not. I by no means am a security expert. I found along my travels a note of something to the effect that SuSe had a security advisory regarding this, however, even as of 10.1 GM they still had this in their fstab as default. So I'm thinking ? and cannot be sure that some how maybe ? this got fixed in a patch somewhere along the lines.

But like I said it worked for me.

First: let's say you have group number 120 available, then:

groupadd -g 120 usb
Secondly, you add a usbfs in /etc/fstab:

none /proc/bus/usb usbfs defaults,devgid=120,devmode=0664 0 0
now add your user into group 'usb', you can do it with pico as root in cli

then as a test, simply
mount -a
see if you get any goofball error's or not.

if not reboot and you should be good to go. that should "git er' done" (TM)
Old 12-06-2006, 02:11 PM   #3
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 507
Blog Entries: 1

Rep: Reputation: Disabled
Using digikam/gphoto2/libgphoto with udev is a bit obscure, but not difficult. Here is a link to a post describing how I did it.
edit: fixed link

Last edited by TSquaredF; 12-06-2006 at 02:13 PM.
Old 12-06-2006, 03:42 PM   #4
LQ Newbie
Registered: Jul 2005
Location: Slovakia
Distribution: Slackware
Posts: 9

Original Poster
Rep: Reputation: 0
thank you both

old fogie:
i've tried your solution, but it didn't work for me (i mean, i couldn't mount usbfs intentionally). i'm not quite sure, but the reason might be i'm using kernel which does it somehow for me(?). your post, however, inspired me to refine my search and finally, i was able to find the right solution somewhere on the web. thank you for that.

i was just about to post what i've found when i've noticed your reply. i've checked the thread you suggested and found essentially the same kind of solution i stumbled upon. now i can recommend to anybody to check and test your solution. works great for me!

as i understand now, the key was to set up correct udev rules for my camera. the link provided by TSquaredF explaines that in details.

thanx a lot !

ps: just wondering how's that i didn't find TSquaredF's thread earlier; my bad


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hotplug, digikam, usbcam, Slackware 11.0 problem arubin Slackware 6 10-17-2006 06:39 AM
Slackware 10.1 Permissions?! knyght_ryder Linux - Security 2 12-29-2005 07:25 AM
User permissions - Slackware ch424 Linux - Newbie 8 10-05-2004 02:47 PM
modifying permissions in slackware noxious Slackware 3 09-09-2004 10:45 PM
slackware permissions / mplayer hjles Slackware 2 03-20-2003 09:48 PM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:05 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration