-   Slackware (
-   -   Digikam 1.2.0 on Slackware64-current of 31st March, 2010 (

gargamel 04-01-2010 05:42 AM

Digikam 1.2.0 on Slackware64-current of 31st March, 2010
Hi everyone,

I just tried to build Digikam 1.2.0 using the SlackBuild script from for version 1.0.0. While Lensfun 0.2.5 and Kipi-Plugins 1.2.0 compiled and installed without problems, the Digikam build stops at 97%. Here's the log:


[ 97%] Building CXX object themedesigner/CMakeFiles/digikamthemedesigner.dir/mainwindow.o
/tmp/pkg/digikam-1.2.0/themedesigner/mainwindow.cpp:52:24: error: folderitem.h: No such file or directory
/tmp/pkg/digikam-1.2.0/themedesigner/mainwindow.cpp:53:24: error: folderview.h: No such file or directory
[ 98%] Building CXX object digikam/CMakeFiles/digikam.dir/__/utilities/advancedrename/parser/modifiers/casemodifier.o
/tmp/pkg/digikam-1.2.0/themedesigner/mainwindow.cpp:107: error: ISO C++ forbids declaration of 'FolderView' with no type
/tmp/pkg/digikam-1.2.0/themedesigner/mainwindow.cpp:107: error: expected ';' before '*' token
/tmp/pkg/digikam-1.2.0/themedesigner/mainwindow.cpp: In constructor 'Digikam::MainWindowPriv::MainWindowPriv()':
/tmp/pkg/digikam-1.2.0/themedesigner/mainwindow.cpp:80: error: 'folderView' was not declared in this scope
/tmp/pkg/digikam-1.2.0/themedesigner/mainwindow.cpp: In constructor 'Digikam::MainWindow::MainWindow()':
/tmp/pkg/digikam-1.2.0/themedesigner/mainwindow.cpp:145: error: 'class Digikam::MainWindowPriv' has no member named 'folderView'
/tmp/pkg/digikam-1.2.0/themedesigner/mainwindow.cpp:145: error: expected type-specifier before 'FolderView'
/tmp/pkg/digikam-1.2.0/themedesigner/mainwindow.cpp:145: error: expected ';' before 'FolderView'
/tmp/pkg/digikam-1.2.0/themedesigner/mainwindow.cpp:282: error: 'class Digikam::MainWindowPriv' has no member named 'folderView'
/tmp/pkg/digikam-1.2.0/themedesigner/mainwindow.cpp:283: error: 'class Digikam::MainWindowPriv' has no member named 'folderView'
/tmp/pkg/digikam-1.2.0/themedesigner/mainwindow.cpp:283: error: 'Q3ListView' has not been declared
/tmp/pkg/digikam-1.2.0/themedesigner/mainwindow.cpp:284: error: 'class Digikam::MainWindowPriv' has no member named 'folderView'
/tmp/pkg/digikam-1.2.0/themedesigner/mainwindow.cpp:289: error: 'FolderItem' was not declared in this scope
/tmp/pkg/digikam-1.2.0/themedesigner/mainwindow.cpp:289: error: 'folderItem' was not declared in this scope
/tmp/pkg/digikam-1.2.0/themedesigner/mainwindow.cpp:289: error: expected type-specifier before 'FolderItem'
/tmp/pkg/digikam-1.2.0/themedesigner/mainwindow.cpp:289: error: expected ';' before 'FolderItem'
/tmp/pkg/digikam-1.2.0/themedesigner/mainwindow.cpp:293: error: 'class Digikam::MainWindowPriv' has no member named 'folderView'
make[2]: *** [themedesigner/CMakeFiles/digikamthemedesigner.dir/mainwindow.o] Error 1
make[1]: *** [themedesigner/CMakeFiles/digikamthemedesigner.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 98%] Building CXX object digikam/CMakeFiles/digikam.dir/__/utilities/advancedrename/parser/modifiers/defaultvaluemodifier.o
[ 98%] Building CXX object digikam/CMakeFiles/digikam.dir/__/utilities/advancedrename/parser/modifiers/fillmodifier.o
[ 98%] Building CXX object digikam/CMakeFiles/digikam.dir/__/utilities/advancedrename/parser/modifiers/rangemodifier.o
[ 98%] Building CXX object digikam/CMakeFiles/digikam.dir/__/utilities/advancedrename/parser/modifiers/replacemodifier.o
[ 98%] Building CXX object digikam/CMakeFiles/digikam.dir/__/utilities/advancedrename/parser/modifiers/trimmedmodifier.o
[ 98%] Building CXX object digikam/CMakeFiles/digikam.dir/__/utilities/advancedrename/parser/modifiers/uniquemodifier.o
[ 98%] Building CXX object digikam/CMakeFiles/digikam.dir/__/utilities/advancedrename/parser/options/cameranameoption.o
[ 98%] Building CXX object digikam/CMakeFiles/digikam.dir/__/utilities/advancedrename/parser/options/dateoption.o
[ 98%] Building CXX object digikam/CMakeFiles/digikam.dir/__/utilities/advancedrename/parser/options/directorynameoption.o
[ 99%] Building CXX object digikam/CMakeFiles/digikam.dir/__/utilities/advancedrename/parser/options/filepropertiesoption.o
[ 99%] Building CXX object digikam/CMakeFiles/digikam.dir/__/utilities/advancedrename/parser/options/metadataoption.o
[ 99%] Building CXX object digikam/CMakeFiles/digikam.dir/__/utilities/advancedrename/parser/options/sequencenumberoption.o
[ 99%] Building CXX object digikam/CMakeFiles/digikam.dir/main.o
[ 99%] Building CXX object digikam/CMakeFiles/digikam.dir/digikamadaptor.o
Linking CXX executable digikam
[ 99%] Built target digikam
make: *** [all] Error 2

Is this still related to the libpng issue?


titopoquito 04-01-2010 10:07 AM

If you compare the 1.1.0 and 1.2.0 tarballs you will see that the two files folderview.cpp and folderview.h are indeed missing in the newer release tarball. I'm not familiar with programming, but since the include-lines are still present it looks like a packaging error to me!?!? Would be worth a try to copy the two files from an 1.1.0 version and see if it compiles fine then ...

EDIT: Or look at the CMakeLists.txt in the source dir of 1.2.0 - looks like there is a line exactly about the themedesigner at the top which is commented out. If you don't need it you could try uncommenting it.

ponce 04-01-2010 10:48 AM

it works fine for me with standard SBo lensfun, kipi-plugins and slackbuild (changing only the $VERSION) on latest 64-current (multilib - alien's kde 4.4.2/qt 4.6.2).
themedesigner's build (maybe because it looks bugged) seems to default to off.

gargamel 04-01-2010 04:34 PM

I changed $VERSION and $ARCH in the respective SlackBuild scripts. lensfun and kipi-plugins build just fine, then. Only digikam fails to build.

@titopoquito. I copied the files from the older version into the source directory AND uncommented the line. Same result. BTW, I use the tar ball from the Digikam Sourceforge download page. I therefore doubt that it is a packaging error, and if it was one, the above measures should have an effect.

@ponce. I have KDE 4.3.5 and Qt 4.5.3. Do I need to upgrade? I hesitate, because there has been no official statement, that the next stable release of Slackware will include KDE 4.4, although it is quite likely. I'd like to return to stable with the next release. I am only using -current, because of the many improvements of KDE, at the moment.


Nille_kungen 04-01-2010 04:38 PM

I build it on current with my SBo Slackbuild and only changed the version and it built fine.
The source had md5sum 8f68022008cf1650924cc8688f176572

gargamel 04-01-2010 05:19 PM

I downloaded the SlackBuild script from SBo and the source tar ball a second time, and this time it worked flawlessly. Frankly, I have no idea, what was wrong before.

Thanks for all your replies. Knowing that it worked for you in a similar environment saved me a lot of time that I would otherwise have spent on analysing this further.


slackass 04-01-2010 10:05 PM

Same thing here.
I did the new lensfun and kipi and all was well.
Did the new digikam and it failed near the end.
After reading gargamel's post I downloaded a new SlackBuild and it rolled right on through without a hitch. .. ???
Mustive been a bad download on the 1st one.

Slack64-C (03.31) / Multilib / KDE4.4.2

gargamel 04-02-2010 07:51 AM

I don't think, it was a bad download, as I used the same SlackBuild script file that I had used before successfully for building digikam 1.1.0.

BTW, thanks for the good work, Nille_kungen!


All times are GMT -5. The time now is 07:40 PM.