-   Slackware (
-   -   difficulties with samba config on slack 13.0 SOLVED (

unclejed613 03-13-2011 02:50 PM

difficulties with samba config on slack 13.0 SOLVED
on a fresh install of slack 13.0, i couldn't get samba to run. went through /etc/samba/smb.conf and made sure everything looked ok. i ran SWAT and checked the config, and everything LOOKED ok. but when i went to start smbd and nmbd, they would not load. looking at the log files showed errors like this:

[2011/02/20 15:11:34,  0] lib/messages_local.c:messaging_tdb_init(96)
  ERROR: Failed to initialise messages database: No such file or directory
[2011/02/20 15:11:34,  0] lib/messages.c:messaging_init(204)
  messaging_tdb_init failed: NT_STATUS_OBJECT_NAME_NOT_FOUND
[2011/02/20 15:11:34,  0] lib/util.c:smb_panic(1670)
  PANIC (pid 3312): Could not init smbd messaging context
[2011/02/20 15:11:34,  0] lib/util.c:log_stack_trace(1774)
  BACKTRACE: 6 stack frames:
  #0 /usr/sbin/smbd(log_stack_trace+0x2d) [0xb7dc2724]
  #1 /usr/sbin/smbd(smb_panic+0x80) [0xb7dc2881]
  #2 /usr/sbin/smbd(smbd_messaging_context+0x64) [0xb800085f]
  #3 /usr/sbin/smbd(main+0x6ac) [0xb8002651]
  #4 /lib/ [0xb76c96a5]
  #5 /usr/sbin/smbd [0xb7bab921]
[2011/02/20 15:11:34,  0] lib/fault.c:dump_core(201)
  dumping core in /var/log/samba/cores/smbd

as it turns out, several of the entries in the /etc/samba/smb.conf file such as lock directory and pid directory began with "file:///" (i.e. "lock directory=file:///var/cache/samba"). since this was, except for the addition of a share containing movies for viewing on the network, a "stock" install of samba, i assumed that these defaults were correct. as it turns out, they are not. i removed all "file:///" prefix to these settings (i.e. "/var/cache/samba"), and again tried starting smbd and nmbd, and it worked.

corp769 03-14-2011 08:03 AM

I noticed how you appended SOLVED to the end of your subject. You can delete that, as you can properly mark your thread solved using the thread tools located at the top of your thread.


unclejed613 03-14-2011 05:35 PM

it was solved before i wrote it, so i just wrote the title that way... i just thought it might prevent others from headaches caused by the same problem.... i don't know if the installer wrote the file that way, or possibly the KDE config app wrote it that way. KDE config (i.e. "System Settings") seems to gum up the works a lot when it comes to networking configuration in general.

All times are GMT -5. The time now is 10:26 PM.