-   Slackware (
-   -   did a slackware-current update nuke .Xmodmap for anyone else? (

Danus ex 09-13-2005 11:58 PM

did a slackware-current update nuke .Xmodmap for anyone else?

Just installed the September 8th, 10th, and 12th updates from slackware-current and seem to have lost the functionality provided by my /etc/X11/xinit/.Xmodmap file (the 'pointer = 1 2 3 6 7 4 5' thing). Happens in any window manager. Now my wheel and back/forth buttons are screwed up. Anyone else get the same problem?

Bruce Hill 09-14-2005 12:22 PM

Have you read ?

Before you begin, I would strongly recommend making a backup of your
system, or, if not the entire system, at least the /etc directory. You
might find that you need to refer to a few things about the upgrade
process is complete. Back it up, or take your chances.

6. Fix your config files. Some of the config files in /etc are going to
need your attention. You'll find the new incoming config files on
your system with the ".new" extension. You may need to fill these in
with information from your old config files and then move them over.

Feel brave? You can use this little script to install all of the
.new config files in /etc. If you've made any local changes you'll
need to add them to the newly installed files. Your old config files
will be copied to *.bak. Anyway, it might be an easier starting
point. Here it is:

cd /etc
find . -name "*.new" | while read configfile ; do
if [ ! "$configfile" = "./rc.d/" \
-a ! "$configfile" = "./" \
-a ! "$configfile" = "./" \
-a ! "$configfile" = "./" ]; then
cp -a $(echo $configfile | rev | cut -f 2- -d . | rev) \
$(echo $configfile | rev | cut -f 2- -d . | rev).bak 2> /dev/null
mv $configfile $(echo $configfile | rev | cut -f 2- -d . | rev)

You'll probably also need to edit your /etc/X11/xorg.conf to change
the name of the keyboard driver from "Keyboard" to "kbd". I don't
know why this changed, but it did.
Could this be the problem? Read that entire file, which should be
located wherever you saved your -current download.

cathectic 09-14-2005 06:25 PM

I had the same problem, although I log in at runlevel 4 using KDM and IIRC it was caused by the latest kdebase upgrade. I reverted /opt/kde/share/config/kdm/Xsession to a previous version of the file and it started reading .Xmodmap again.

Bruce Hill 09-14-2005 09:16 PM

If this is indeed a bug, I know Patrick would appreciate you
sending him a report. He's about to release Slackware-10.2
and it would be nice to get that fixed beforehand.

Slinky 09-15-2005 03:30 AM

Hi i have this same problem (although i have only just realised it might not be me, as have done two fresh installs and around 6 kernel recompiles to try and fix it) I am a newbie and have not got a clue how to fix this. any help would be most welcome!

Bruce Hill 09-15-2005 06:38 AM

It is not so much a bug, as the KDE files are now unmodified, whereas in earlier versions Pat had put in his own versions of Xsession.

And btw ... Slackware-10.2 has been released.

cathectic 09-15-2005 07:53 AM

The easiest solution would be to create /etc/xprofile (or ~/.xprofile for individual users is you want), and in it put these lines from the original /opt/kde/share/config/kdm/Xsession:


# /etc/xprofile: This file contains system-wide defaults used by X


# merge in defaults and keymaps

if [ -r $sysresources ]; then
        xrdb -merge $sysresources

if [ -r $sysmodmap ]; then
        xmodmap $sysmodmap

if [ -r $userresources ]; then
        xrdb -merge $userresources

if [ -r $usermodmap ]; then
        xmodmap $usermodmap

Slinky 09-15-2005 08:44 AM

thankyou for your reply, i will when i get back from work tonight. Hopefully that will sort it if not "i will be back" ;)

thankyou for your time.

Slinky 09-15-2005 01:12 PM

No joy as i dont have any of these files? (sysresources=/usr/X11R6/lib/X11/xinit/.Xresources

anymore help would be most welcome!

cathectic 09-15-2005 05:49 PM

Well, can you elaborate on what you mean by "the same problem"? You refer to two fresh installs and 6 kernel recompiles, whereas the original poster refers to a simple problem with the kdebase upgrade regarding their .Xmodmap file?


1) What *exactly* is the problem you are having?
1B) What hardware is involved, if any (i.e. are you saying the scroll wheel on your mouse doesn't work? What kind of mouse is it?)

2) What have you done so far to try and cure it?
(e.g. editing /etc/X11/xorg.conf, custom .Xmodmap, etc)

Slinky 09-15-2005 06:24 PM

Hi sorry for not being very clear on my first post. Yes the problem is with my scroll wheel mouse the wheel does not work at all. I have done about everything i could dig up have done mouseconfig, edited xorg.conf with ZAxisMapping Buttons ect recompliled the kernel to include all mouse options and vice versa. have taken the above steps also. have really tried all sorts to no avail. the mouse is one that came with this pc dell 4600 its an optical usb one. Hope this makes it a bit clearer.

many thanks

cathectic 09-15-2005 06:35 PM

For future reference, your PC appears to be a Dimenson 4600 (There's also a server called the PowerEdge 4600, so just making sure).

The links from that page takes me to this for the USB Optical Mouse.

If I'm right, it classes as a five button mouse (left + right, wheel = up, down, click) you shouldn't need to start fiddling with .Xmodmap (unless I'm wrong, and you have two side buttons or more).

Can you please post the mouse section from your /etc/X11/xorg.conf?

All times are GMT -5. The time now is 02:56 PM.