LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 02-15-2013, 11:52 PM   #1
cnelson2307
LQ Newbie
 
Registered: Feb 2013
Distribution: Slackware 14
Posts: 7

Rep: Reputation: Disabled
dhcp server not producing ip address?


So, this is my first linux distro, and im running slackware 14
wireless card: tp-link "tl-wn951n"
Having trouble executing
#slackpkg update gpg
results:
PHP Code:
                      Downloading http://slackbuilds.org/mirror/slackware/slackware64-current/GPG-KEY...
--2013-02-15 23:10:12--  http://slackbuilds.org/mirror/slackware/slackware64-current/GPG-KEY
Resolving slackbuilds.org (slackbuilds.org)... failedTemporary failure in name resolution.
wgetunable to resolve host address 'slackbuilds.org' 
#ifconfig
results:
PHP Code:
eth0flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80
::12bf:48ff:fe74:84  prefixlen 64  scopeid 0x20<link>
        
ether 10:bf:48:74:00:84  txqueuelen 1000  (Ethernet)
        
RX packets 1177  bytes 128080 (125.0 KiB)
        
RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 4  bytes 328 
(328.0 B)
        
TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 48  base 0xc000  

lo
flags=73<UP,LOOPBACK,RUNNING>  mtu 16436
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 
::1  prefixlen 128  scopeid 0x10<host>
        
loop  txqueuelen 0  (Local Loopback)
        
RX packets 12  bytes 776 (776.0 B)
        
RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 12  bytes 776 
(776.0 B)
        
TX errors 0  dropped 0 overruns 0  carrier 0  collisions 
#iwconfig
results:
PHP Code:
0
               
        lo        no wireless extensions
.

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode
:Managed  Access PointNot-Associated   Tx-Power=0 dBm   
          Retry  long limit
:7   RTS thr:off   Fragment thr:off
          Encryption key
:off
          Power Management
:off
          
eth0      no wireless extensions

 
Old 02-17-2013, 09:08 AM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,289

Rep: Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802
There should no problem with your device as it is supported by the ath9k kernel module. You can check that the kernel module is loaded with 'lsmod | grep ath9k'.
Quote:
Access Point: Not-Associated
It appears that you do not have a connection to you access point, so the wireless connection is down and does not appear in the output of 'ifconfig'. You should see the device with 'ifconfig -a'.
Try using NetworkManager to configure your wireless access.

Last edited by allend; 02-17-2013 at 09:09 AM.
 
1 members found this post helpful.
Old 02-17-2013, 04:44 PM   #3
cnelson2307
LQ Newbie
 
Registered: Feb 2013
Distribution: Slackware 14
Posts: 7

Original Poster
Rep: Reputation: Disabled
I tried using "network connections" in kde but the only tab i can interact with is vpn, the rest are grayed out.

# lsmod | grep ath9k
Quote:
ath9k 86079 0
ath9k_common 1978 1 ath9k
ath9k_hw 348866 2 ath9k_common,ath9k
ath 14755 3 ath9k_hw,ath9k_common,ath9k
mac80211 227731 1 ath9k
cfg80211 169025 3 mac80211,ath,ath9k

# ifconfig -a
Quote:
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet6 fe80::12bf:48ff:fe74:84 prefixlen 64 scopeid 0x20<link>
ether 10:bf:48:74:00:84 txqueuelen 1000 (Ethernet)
RX packets 191 bytes 19793 (19.3 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 4 bytes 328 (328.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 49 base 0xc000

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 16436
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 0 (Local Loopback)
RX packets 12 bytes 776 (776.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 12 bytes 776 (776.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4098<BROADCAST,MULTICAST> mtu 1500
ether 90:f6:52:87:09:29 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
 
Old 02-17-2013, 05:18 PM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,289

Rep: Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802
The "network connections" in KDE is not compatible with Slackware.

To use NetworkManager in Slackware you need to have the NetworkManager daemon running.
From http://docs.slackware.com/slackware:..._configuration (under the "Graphical Network Configuration Services" heading
Quote:
Starting with Slackware 14, there is also Networkmanager. It will be installed as part of a full install, but the network daemon will not be started by default. As with wicd, you have to make its init script executable:

# chmod +x /etc/rc.d/rc.networkmanager

which will make NetworkManager start at boot. You will have to configure NetworkManager using an X-based graphical utility.
Slackware 14 includes a KDE widget for Networkmanager. If you are using another Desktop Environment like XFCE, you can install the Gnome network-manager-applet from SlackBuilds.org
As an alternative you can do this
From the mail to root from Patrick Volkerding with the header "Welcome to Linux (Slackware 14.0)!"
Quote:
With NetworkManager or wicd, it's
a good idea to remove any existing network configuration in
/etc/rc.d/rc.inet1.conf first. This can be done by running netconfig
and setting the machine to use loopback. Then, if you're using
NetworkManager run it a second time and select NetworkManager.
You may want to reboot to after completing this.
 
3 members found this post helpful.
Old 02-17-2013, 07:19 PM   #5
cnelson2307
LQ Newbie
 
Registered: Feb 2013
Distribution: Slackware 14
Posts: 7

Original Poster
Rep: Reputation: Disabled
Smile

After executing

# chmod +x /etc/rc.d/rc.networkmanager

I was unsure how to go about installing gnome so i proceeded to reset my network using

#netconfig

(a)loopback
(b)networkmanager

and rebooting my system which fixed my issue.

result
Quote:
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.0.11 netmask 255.255.255.0 broadcast 192.168.0.255
inet6 fe80::12bf:48ff:fe74:84 prefixlen 64 scopeid 0x20<link>
ether 10:bf:48:74:00:84 txqueuelen 1000 (Ethernet)
RX packets 150944 bytes 203644859 (194.2 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 93072 bytes 10949563 (10.4 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 48 base 0xe000

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 16436
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 0 (Local Loopback)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether 90:f6:52:87:09:29 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
And now i'm happily browsing on slackware 14.
Thank you!
Now on to slay my GeForce GTX 560

Last edited by cnelson2307; 02-17-2013 at 07:23 PM.
 
Old 03-30-2013, 10:47 AM   #6
cnelson2307
LQ Newbie
 
Registered: Feb 2013
Distribution: Slackware 14
Posts: 7

Original Poster
Rep: Reputation: Disabled
while going through the process of

slackpkg update
slackpkg install-new
slackpkg upgrade-all

i have seamed to disable the network manager. after retrying

# chmod +x /etc/rc.d/rc.networkmanager

and netconfig in possibly every imaginable config i am back where i started. perhaps i did something wrong while running

slackpkg update
slackpkg install-new
slackpkg upgrade-all



root@slacker:~# iwconfig
lo no wireless extensions.

wlan0 IEEE 802.11bgn ESSIDff/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thrff Fragment thrff
Encryption keyff
Power Managementff

eth0 no wireless extensions.

root@slacker:~# ifconfig
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 16436
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 0 (Local Loopback)
RX packets 48 bytes 2568 (2.5 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 48 bytes 2568 (2.5 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

root@slacker:~# ifconfig -a
eth0: flags=4098<BROADCAST,MULTICAST> mtu 1500
ether 10:bf:48:74:00:84 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 48 base 0xc000

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 16436
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 0 (Local Loopback)
RX packets 48 bytes 2568 (2.5 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 48 bytes 2568 (2.5 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4098<BROADCAST,MULTICAST> mtu 1500
ether 90:f6:52:87:09:29 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
 
Old 03-30-2013, 11:02 AM   #7
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,289

Rep: Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802
Welcome to the perils of running -current

I think you have been caught by this. http://www.linuxquestions.org/questi...3/#post4918278

Perhaps you could download the required package on another computer and then install it on to your affected Slackware-current.
 
Old 03-30-2013, 11:06 AM   #8
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,114

Rep: Reputation: Disabled
If you are running Slackware 14 that should not have happened.

If on the other hand, you configured slackpkg to use a slackware-current repository, then yes, this is a known issue with slackpkg and the NetworkManager update of last week...

See http://www.linuxquestions.org/questi...3/#post4918278 and the posts that follow. I think the best way forward for you is to download the Slackware updates to another computer, copy them to a USB stick or external USB drive, connect that to the Slackware computer, configure slackpkg to look at the USB stick and update the rest of the packages without having to download them from the Internet.

Eric
 
Old 03-30-2013, 05:42 PM   #9
zrdc28
Member
 
Registered: Dec 2007
Location: Alabama USA
Distribution: Slackware current
Posts: 234

Rep: Reputation: 40
I got out of this situation by going to terminal and

"dhclient"
iwconfig wlan0 essid yourname
dhcpcd -d wlan0

then when it connects go ahead an do the upgrades, and it worked!
 
Old 03-30-2013, 08:22 PM   #10
cnelson2307
LQ Newbie
 
Registered: Feb 2013
Distribution: Slackware 14
Posts: 7

Original Poster
Rep: Reputation: Disabled
root@slacker:~# /etc/rc.d/rc.inet1.conf
root@slacker:~# /etc/rc.d/rc.inet1 eth0_restart
root@slacker:~# dhclient
root@slacker:~# iwconfig wlan0 essid root
root@slacker:~# dhcpck -d wlan0
bash: dhcpck: command not found
root@slacker:~# dhcpcd -d wlan0
dhcpcd[3129]: version 5.5.6 starting
dhcpcd[3129]: wlan0: using hwaddr 90:f6:52:87:09:29
dhcpcd[3129]: wlan0: executing `/lib/dhcpcd/dhcpcd-run-hooks', reason PREINIT
dhcpcd[3129]: wlan0: executing `/lib/dhcpcd/dhcpcd-run-hooks', reason NOCARRIER
dhcpcd[3129]: wlan0: waiting for carrier
dhcpcd[3129]: timed out
dhcpcd[3129]: allowing 8 seconds for IPv4LL timeout
dhcpcd[3129]: timed out
root@slacker:~# /etc/slackpkg/slackpkg.conf
bash: /etc/slackpkg/slackpkg.conf: permission denied

Last edited by cnelson2307; 03-30-2013 at 08:27 PM.
 
Old 03-31-2013, 12:32 AM   #11
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,289

Rep: Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802
If you want to configure your wireless connection without using NetworkManager, then the process will depend on how your computer connects to your access point.

If you use WPA2 only, then the process is outlined here. http://www.linuxquestions.org/questi...3/#post4918382

If you use WPA then using the technique outlined by zrdc28 should work. Perhaps check the state of your wireless with 'rfkill list'. You may need to unblock with 'rfkill unblock 1' or something similar.

The 'sneakernet' option is still the easiest if you have not worked out how to connect without using NetworkManager.
 
Old 03-31-2013, 04:30 PM   #12
cnelson2307
LQ Newbie
 
Registered: Feb 2013
Distribution: Slackware 14
Posts: 7

Original Poster
Rep: Reputation: Disabled
Having trouble updating via 'sneakernet'
I go to http://packages.slackware.com/ but really don't know where to do from there to even download the packages.


root@slacker:~# rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

root@slacker:~# /etc/rc.d/rc.networkmanager stop
Stopping NetworkManager: stopped
root@slacker:~# pkill wpa_supplicant
root@slacker:~# rfkill unblock 1
root@slacker:~# wpa_supplicant -B -c/etc/wpa_supplicant.conf -iwlan0 -Dwext
root@slacker:~# dhcpcd
dhcpcd[3036]: version 5.5.6 starting
dhcpcd[3036]: no interfaces have a carrier
dhcpcd[3036]: forked to background, child pid 3073
root@slacker:~# sh /etc/rc.d/rc.firewall
sh: /etc/rc.d/rc.firewall: No such file or directory
root@slacker:~# sh /etc/rc.d/rc.firewall
sh: /etc/rc.d/rc.firewall: No such file or directory
root@slacker:~# /etc/rc.d/rc.networkmanager start
Starting NetworkManager daemon: /usr/sbin/NetworkManager
/usr/sbin/NetworkManager: symbol lookup error: /usr/lib64/libnm-util.so.2: undefined symbol: g_type_ensure

oot@slacker:~# /etc/rc.d/rc.inet1.cong
bash: /etc/rc.d/rc.inet1.cong: No such file or directory
root@slacker:~# /etc/rc.d/rc.inet1.conf
root@slacker:~# /etc/rc.d/rc.inet1 etho restart
root@slacker:~# slackpkg upgrade all

You need the GPG key of Slackware Linux Project <security@slackware.com>.
To download and install that key, run:

# slackpkg update gpg

You can disable GPG checking too, but it is not a good idea.
To disable GPG, edit slackpkg.conf and change the value of the CHECKGPG
variable to off - you can see an example in the original slackpkg.conf.new
file distributed with slackpkg.

Last edited by cnelson2307; 03-31-2013 at 05:00 PM.
 
Old 03-31-2013, 07:18 PM   #13
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,289

Rep: Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802
Assumimng you are running Slackware64-current as suggested by the PHP code block in post#1, then the package glib2-2.34.3-x86_64-1.txz can be found at http://mirrors.slackware.com/slackwa...slackware64/l/
 
Old 04-02-2013, 04:10 PM   #14
cnelson2307
LQ Newbie
 
Registered: Feb 2013
Distribution: Slackware 14
Posts: 7

Original Poster
Rep: Reputation: Disabled
ok, so I gave up on networkmanager and installed wicd and now im about to retry slackpkg update
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Single DHCP server ,to provide the ip address to a MAC address in two different subne alix123 Linux - Software 5 05-08-2007 11:16 PM
How To know if a host configured with DHCP has obtained IP address from DHCP server? Prassanta Suse/Novell 1 06-29-2006 09:48 AM
eth0 ip assigned by dhcp , how would i know the ip address of the dhcp server where.. kublador Linux - Networking 14 05-16-2006 06:33 AM
DHCP Server address srbbabu Linux - Networking 1 11-05-2005 09:33 PM
DHCP Server MAC Address found, IP address not assigned wmburke Linux - Wireless Networking 17 11-17-2004 10:33 AM


All times are GMT -5. The time now is 05:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration