LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-31-2009, 08:05 AM   #16
debuserua
LQ Newbie
 
Registered: Aug 2009
Posts: 3

Rep: Reputation: 1

Quote:
Originally Posted by lamosa View Post
I updated the dhcpcd to version 5.0.7 and also tried to use dhclient command. In both cases did not work.

Sorry for my English. I'm Brazilian.

Thanks
Lamosa
You restart your system? Maybe, but I'm not sure, must be restarted DHCP-client - dhcpcd. When system start, execute script - /etc/rc.d/rc.inet1 where is located string such /sbin/dhcpcd.
For more detailed visit this link, were I find this information:http://www.slackbook.org/html/book.h...GURATION-TCPIP
 
Old 08-31-2009, 08:35 AM   #17
dwr1
Member
 
Registered: Aug 2009
Distribution: slack-current
Posts: 46

Rep: Reputation: 17
I tried with the netconfig utility, and hand editing the rc.wireless.conf script (i usually run the iwconfig command manually) and no other files in /etc/rc.d/. And I ran iwconfig and 'dhcpcd eth0' manually. Both worked on my system.

To all those with problems, I assume you can see eth0, or wlan0, or whatever with ifconfig?

Last edited by dwr1; 08-31-2009 at 08:43 AM.
 
Old 08-31-2009, 08:55 AM   #18
debuserua
LQ Newbie
 
Registered: Aug 2009
Posts: 3

Rep: Reputation: 1
Quote:
Originally Posted by dwr1 View Post
I tried with the netconfig utility, and hand editing the rc.wireless.conf script (i usually run the iwconfig command manually) and no other files in /etc/rc.d/. And I ran iwconfig and 'dhcpcd eth0' manually. Both worked on my system.

To all those with problems, I assume you can see eth0, or wlan0, or whatever with ifconfig?
Before netconfig I can see eth0 by ifconfig -a, which means that you can see your eth0 without assign IP; when I put ifconfig eth0 was not. After netconfig eth0 appeared.
 
Old 08-31-2009, 10:36 AM   #19
dwr1
Member
 
Registered: Aug 2009
Distribution: slack-current
Posts: 46

Rep: Reputation: 17
In that case, if you're doing everything manually, I'd run dhcpcd with the -d option. Or, if you're doing everything with the scripts, i'd change DHCP_DEBUG[0] from "" to "yes" in /etc/rc.d/rc.inetd1 as previously suggested. Then post/google the debug output you get.
 
Old 08-31-2009, 01:11 PM   #20
zyli2006
LQ Newbie
 
Registered: May 2009
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by rworkman View Post
There's a known bug in dhcpcd-3.x that very few people ran across during hte -current cycle, but it was too late to consider an upgrade to dhcpcd-5.0.x. You might consider trying to build and install it instead, but probably it's easier to just try dhclient instead.
Thanks torworkman. Seems that dhclient works for me, here is what I did:
1. run netconfig, choose DHCP
2. run /etc/rc.d/rc.inet1 stop and then
run /etc/rc.d/rc.inet1 start, the response is

Code:
Polling for DHCP server on interface eth0:
err, eth0: timed out
warn, eth0: using IPV4LL address 169.254.57.222
dhcpcd.sh: interface eth0 has been configured with new IP=169.254.57.222
The ip 169.***.... is not correct, seems just a randomly assigned ip. And I couldn't connect to internet using this ip.

3. run dhclient, the response is
Code:
Listening on LPF/eth0/00:2e:4f:f7:ef:e4
Sending on   LPF/eth0/00:2e:4f:f7:ef:e4
Sending on   Socket/fallback
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 128.161.176.1
bound to 128.161.178.143 -- renewal in 39857 seconds.
where 128.161.178.143 is the correct ip I got when the network was normal, and I can access internet now.

How to config the system to use dhclient automatically? Now when I reboot the system, I still need to run dhclient as root manually.
 
Old 08-31-2009, 02:04 PM   #21
Hardtack
LQ Newbie
 
Registered: Aug 2009
Posts: 3

Rep: Reputation: 1
I had the same problem with dhcp not working in version 13.0. I tried replacing the dhcp and dhcpd packages from 13.0 with those from 12.2 and it now works.
 
Old 08-31-2009, 03:27 PM   #22
rg3
Member
 
Registered: Jul 2007
Distribution: Fedora
Posts: 527

Rep: Reputation: Disabled
Quote:
How to config the system to use dhclient automatically? Now when I reboot the system, I still need to run dhclient as root manually.
First, remove any configuration for eth0 that appears in /etc/rc.d/rc.inet1.conf. Then, add the following in a line at the end of /etc/rc.d/rc.local:

/sbin/dhclient eth0

I think that should do it, but I'm not 100% sure.
 
Old 09-01-2009, 04:03 AM   #23
NetNightmare
Member
 
Registered: Sep 2005
Location: Rome
Distribution: Slackware
Posts: 34

Rep: Reputation: 15
Post

Quote:

The ip 169.***.... is not correct, seems just a randomly assigned ip. And I couldn't connect to internet using this ip.

Those are APIPA address , they are used for zeroconf on microsoft machine, pratically when a DHCP client is not able to aquire an IP , it automatically assign an APIPA one : http://compnetworking.about.com/cs/p...ldef_apipa.htm

you can disable that behavior on dhcpcd using the -L option or --noipv4ll
 
Old 09-01-2009, 11:37 AM   #24
lamosa
LQ Newbie
 
Registered: Aug 2009
Distribution: Slackwarex64 13.0
Posts: 5

Rep: Reputation: 0
Hi all. Network DHCP is working now! Just installed slackware again. I don't know what happened before.

Thanks all.
Lamosa
 
Old 09-11-2009, 02:48 PM   #25
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware
Posts: 1,876

Rep: Reputation: 49
In case it helps someone, let me add my experiences from today:

A machine I upgraded to 13.0 last weekend and have been using since decided to hang on "Polling for DHCP server on interface eth0" this morning. It would not time out, nor would it acquire an IP address. The kernel had not panicked, but the system would not boot past this step. Intel mobo with on-board Intel gigabit NIC.

I rebooted several times, with no change in symptoms. The system is dual-boot and worked in Windows. Booted with the Slack DVD, chrooted into the system and saw this in /var/log/messages:

Code:
Sep 11 09:33:17 wingnut logger: /etc/rc.d/rc.inet1:  /sbin/ifconfig lo 127.0.0.1
Sep 11 09:33:17 wingnut logger: /etc/rc.d/rc.inet1:  /sbin/route add -net 127.0.0.0 netmask 255.0.0.0 lo
Sep 11 09:33:17 wingnut logger: /etc/rc.d/rc.inet1:  /sbin/dhcpcd -t 10  eth0
Sep 11 09:33:17 wingnut dhcpcd[2939]: eth0: dhcpcd 3.2.3 starting
Sep 11 09:33:17 wingnut dhcpcd[2939]: eth0: hardware address = 00:1c:c0:01:8d:9e
Sep 11 09:33:18 wingnut dhcpcd[2939]: eth0: DUID = 00:01:00:01:12:35:6c:3a:00:1c:c0:01:8d:9e
Sep 11 09:33:18 wingnut dhcpcd[2939]: eth0: broadcasting for a lease
Sep 11 09:33:19 wingnut kernel: e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
Sep 11 09:33:19 wingnut kernel: 0000:00:19.0: eth0: 10/100 speed: disabling TSO
Sep 11 09:33:21 wingnut dhcpcd[2939]: eth0: offered 192.168.1.111 from 192.168.1.1 `foothill'
Sep 11 09:33:21 wingnut dhcpcd[2939]: eth0: received NAK: (null)
Sep 11 09:33:22 wingnut dhcpcd[2939]: eth0: broadcasting for a lease
Sep 11 09:33:22 wingnut dhcpcd[2939]: eth0: offered 192.168.1.111 from 192.168.1.1 `foothill'
Sep 11 09:33:22 wingnut dhcpcd[2939]: eth0: received NAK: (null)
The last three lines repeated ad infinitum.

DHCP timeout was set for 10s in both the inet1 script and inet1.conf file. No lingering .new files floating around. Tried adding a gateway IP address in inet1.conf. Nada.

Finding this thread, I got the most recent stable dhcpcd code, compiled and installed it. System booted first try. (LQ saves my a$$ once again.)

By way of comparison, here's the message log now:
Code:
Sep 11 10:01:33 wingnut logger: /etc/rc.d/rc.inet1:  /sbin/ifconfig lo 127.0.0.1
Sep 11 10:01:33 wingnut logger: /etc/rc.d/rc.inet1:  /sbin/route add -net 127.0.
0.0 netmask 255.0.0.0 lo
Sep 11 10:01:33 wingnut logger: /etc/rc.d/rc.inet1:  /sbin/dhcpcd -t 10  eth0
Sep 11 10:01:33 wingnut dhcpcd: version 5.1.0 starting
Sep 11 10:01:34 wingnut dhcpcd: eth0: broadcasting for a lease
Sep 11 10:01:35 wingnut kernel: e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex
, Flow Control: RX/TX
Sep 11 10:01:35 wingnut kernel: 0000:00:19.0: eth0: 10/100 speed: disabling TSO
Sep 11 10:01:37 wingnut dhcpcd: eth0: offered 192.168.1.100 from 192.168.1.1 `fo
othill'
Sep 11 10:01:37 wingnut dhcpcd: eth0: acknowledged 192.168.1.100 from 192.168.1.
1 `foothill'
Sep 11 10:01:37 wingnut dhcpcd: eth0: checking for 192.168.1.100
Sep 11 10:01:42 wingnut dhcpcd: eth0: leased 192.168.1.100 for 259200 seconds
Sep 11 10:01:42 wingnut dhcpcd: forking to background
Since I did not take the time to put dhcpcd into debug, I can't say this was very scientific but it seems like the new version fixed my issue.
 
Old 09-11-2009, 09:14 PM   #26
globaltree
Member
 
Registered: Oct 2007
Location: Oregon
Distribution: Slackware 12.2
Posts: 65

Rep: Reputation: 18
Well... make sure it's not a firewall issue:

if your machine is running in a local network behind a firewall, the firewall could interfere with dhclient or dhcpcd or dhcpd if the necessary ports were blocked...

just wanted to rule out the obvious
 
Old 09-11-2009, 11:38 PM   #27
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware
Posts: 1,876

Rep: Reputation: 49
My firewall is also the DHCP server. The only rules are WAN to LAN. No rules for LAN to LAN and no changes were made to the firewall recently.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
slackware13 amd64 + external drive = kernel panic alexiy Slackware 2 08-21-2009 09:17 AM
slackware13-RC1: how to setup up a german keyboard? wingevil Slackware 4 07-04-2009 08:08 AM
New pkg zipping algorithm for Slackware13 ? grissiom Slackware 1 04-14-2009 06:42 PM
DHCP Won't Work Damien295x Linux - Networking 1 10-27-2005 05:40 AM
DHCP.. How does it work ? qwijibow Linux - Networking 1 07-20-2004 03:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration