-   Slackware (
-   -   devfs(d) (

lackluster 06-02-2002 02:31 AM

I compiled devfs support & auto-mount @ boot into the kernel and compiled the devfsd. The documentation for devfs instructs me to invoke devfsd upon startup - before anything else. I found /etc/rc.d/rc.sysvinit but am not sure this is the very first script. Is it? Also, devfs(d) does not seem to be picking up my usb mouse. What could be the problem?

P.S - On an unrelated side note (I do of course mean rant), I destroyed my gf's copy of win2k and replaced with mandrake 8. After screwing around w/Mandrake for a few days I decided it was nothing more than a pain in the GUI ass and promptly replaced it w/Slack. With all it's "helpful" GUI menus and whatnot it sure didn't help very much. I found it got in the way more than it did help me. I ended up having to edit the files myself anyways (which was a pain in the ass considering it didn't give me emacs or pico (I hate vi)).

Config 06-02-2002 03:41 AM

I think if you shouldn't use auto-mount compiled into the kernel. devfsd is doing this as far as I know. There is a Tutorial about devfs(d) at IBM:

lackluster 06-02-2002 10:29 AM

Thanks, that'll be helpful when I wanna write a driver (not being sarcastic :)). Aside from that, the article wasn't very helpful. I will turn off auto-mount (is there a better way other than adding an append="devfs=nomount" to lilo?

lackluster 06-02-2002 10:52 AM

Also, I have this (/lib/modules/2.4.18/kernel/usb/) usbmouse.o module which dosen't seem to be helping. I have to manually modprobe it. Even then it is unused. Is there a way to spring this thing into action? Can't I beat it with something and force it to support my mouse?

lackluster 06-04-2002 12:38 PM

I suck. I forgot to enable usb full hid support in the kernel config :rolleyes:

All times are GMT -5. The time now is 09:16 AM.