-   Slackware (
-   -   /dev/sda2 does not exist. (

aje 07-16-2005 08:58 PM

/dev/sda2 does not exist.
Earlier today, my slack box was started up again for the first time in a long while. The power went out. Now, when I try to mount my ipod with the following command: "mount /dev/sda2 /mnt/ipod" I get the error: "mount: special device /dev/sda2 does not exist".

I'm wondering, first of all, how can I get around this problem? And second of all, what could have caused this?


AresXP 07-16-2005 09:08 PM

Try /dev/uba instead :)
Just do "mount /mnt/usbdisk", always works for me and it's a default in Slackware :)

aje 07-16-2005 10:32 PM

When I tried "mount /mnt/ipod" I got the same error.

I also got the same error when trying /dev/uba.

AresXP 07-16-2005 10:39 PM


Originally posted by aje
When I tried "mount /mnt/ipod" I got the same error.

I also got the same error when trying /dev/uba.
That might help you. I don't have an iPod anymore so I can't help any further ;) Good luck

aje 07-16-2005 10:50 PM

I now have output from cat /proc/scsi/scsi:


root@grey-machine:/home/aje# cat /proc/scsi/scsi
Attached devices:
Host: scsi5 Channel: 00 Id: 00 Lun: 00
  Vendor: Apple    Model: iPod            Rev: 1.62
  Type:  Direct-Access                    ANSI SCSI revision: 02

I see scsi5, does this mean I would have to use /dev/sdf? /dev/sdf, /dev/sda, /dev/sdb are all not found.

Haiyadragon 07-17-2005 06:06 AM

Try "fdisk -l" and see if it lists the ipod.

phil.d.g 07-17-2005 07:08 AM

Plug the Ipod in and examine the output of dmesg, it should recognise that the ipod has been plugged in and give you a device that you can mount

All times are GMT -5. The time now is 05:42 AM.