-   Slackware (
-   -   /dev/dsp missing, no sound Slackware 12.2 (

zeelog 03-05-2009 10:11 AM

/dev/dsp missing, no sound Slackware 12.2
/dev/dsp does not exist in my Slackware 12.2
I have no sound. What do I do ?

perfect_circle 03-05-2009 10:45 AM


as root

gegechris99 03-07-2009 05:04 PM

Hello zeelog,

This post might be of interest to you:

kea_kea 07-04-2009 05:06 PM

I'm afraid I've gone (very) wrong somewhere.

I've installed Slack 12.2 onto a HP 6730s laptop (all packages for simplicity) with an integrated Intel HD audio in it. I have no sound. I've tried the above mentioned tricks and some other without any success. E.g. I've reinstalled a/devs-xxx.tgz in order to have /dev/dsp0 etc. After I had reinstalled the package I had /dev/dsp0, /dev/dsp as a symlink etc. There were no sound at all. After a reboot I noticed that the reinstalled devices disappeared. (!???)

lsmod says that there are a large number of snd modules are loaded.

alsaconf, alsactl etc. seems to work correrctly, Master, Headphone, PCM is on.

Neiter aplay nor mpg123 can produce a hearable sound.

What should (can) I do? Thx, KEA.

Uncle_Theodore 07-04-2009 05:19 PM

Does alsamixer have the volumes up and not muted?

kea_kea 07-04-2009 06:20 PM


kea_kea 07-19-2009 04:16 AM

Hey Guys,

I've noticed by luck that I have sound in the earphones (but the builtin speakers remained silent).

Upgraded alsa-lib and drviers which was suggested somewhere, tried different module parameters without any success.

Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
Codec: Analog Devices AD1984A.

Any idea?


Bruce Hill 07-20-2009 08:56 AM

Hey kea_kea,

Maybe you also don't have the character devices /dev/dsp or /dev/mixer.

Can you run "ls -l /dev/dsp" and "ls -l /dev/mixer" and see?

If they're not there, run "ls -l /var/log/packages/devs*" and post that output.

kea_kea 07-21-2009 02:12 PM


I have /dev/dsp and /dev/mixer (at least after re-installing alsa-lib and alsa-drivers):
crw-rw---- 1 root audio 14, 3 2009-07-21 18:04 /dev/dsp
crw-rw---- 1 root audio 14, 0 2009-07-21 18:04 /dev/mixer

Earphones work, builtin speakers do not.


jmacloue 07-21-2009 02:58 PM


Originally Posted by kea_kea (Post 3612505)
I've noticed by luck that I have sound in the earphones (but the builtin speakers remained silent).

It may be that the built-in speakers are still muted in alsamixer - check all the output channels there.

Bruce Hill 07-21-2009 07:41 PM

Since you rebuilt alsa, did you start all over by issuing "alsamixer"?

All times are GMT -5. The time now is 05:23 PM.