-   Slackware (
-   -   Default users group setup (

fatalerror0x00 11-23-2012 01:47 PM

Default users group setup
So I messed with something I probably shouldn't have messed with and now I'm paying the price. if someone using slackware (to be sure groups are the right groups) how can I put my groups back to the default I tried adding myself to video group for my normal user but I did both

usermod -G video shawn

along with

usermod -a -G video shawn

from what I can tell users in the group I should be using primarily so i went back and did

usermod -G users shawn

I'm sure video isn't part of my groups and I added that manually but can't seem to get rid of it now I don't need it anymore. How can I get back to the default group setup in every way I ruined it I'm assuming I have my primary group back to normal but maybe I'm wrong. I just need to get things back to normal if possible if I must I will just update all my files and redo the system but thats all I've done that would effect my groups that i haven't for sure put back to normal.

I tried editing /etc/group and taking my name off video but i'm still in video group but before today mplayer couldn't access my soundcard because alsa but now it can since I given myself permission to video i can access alsa and don't know how to reverse all of this

camorri 11-23-2012 02:13 PM

Here is the groups my user belongs to.


users lp wheel floppy mail audio video cdrom plugdev power netdev
This is Slack 14, 32 bit. I looked at my Slack 13.37, 64 bit, it was the same.

What 'problems' are you having that you think are group related?

T3slider 11-23-2012 02:26 PM


# usermod -g users shawn
# usermod -a -G audio,cdrom,floppy,plugdev,video,power,netdev,lp,scanner shawn

should fix everything up, assuming that is your only problem.

ottavio 11-24-2012 06:55 AM

If it was me, I would tar.gz all your used data in a temp dir, delete the user with deluser, recreate the user with adduser making sure you add yourself to _all_ additional groups, restore data from the archive. I think this is also a good way to get rid of clutter.

fatalerror0x00 11-24-2012 06:13 PM

I've reinstalled my OS to fix the issue and also have fixed many other issues I was having at the same time guys so I'm all good now on this issue.

Habitual 11-24-2012 07:50 PM


Originally Posted by fatalerror0x00 (Post 4835644)
So I messed with something I probably shouldn't have messed with and now I'm paying the price...


So, I hope you get my drift here. :)
Cause I am here to tell you, you will get tired of re-installing just to fix stuff you "shouldn't have messed with".

fatalerror0x00 11-24-2012 08:33 PM

haha I'm working on writing a backup script taking sometime but i'm getting there but i do have a backup currently don't worry :P I decided I needed to start doing that :P

Habitual 11-25-2012 10:24 AM


I had to restrain myself from flaming the hell out of you. :tisk:

"Help!..." said the poster.
"Restore from backup...", I urged.
"I have no backups...", he replied.
"Now you have two problems."

nuff said.


fatalerror0x00 11-25-2012 12:49 PM

haha Yeah I know :P I made a backup :P NOW

All times are GMT -5. The time now is 03:31 PM.