-   Slackware (
-   -   DCOP communication error! (

manitoulinnerd 11-25-2003 10:10 PM

DCOP communication error!
This is my first post and first serious attempt at linux on a modern system. I am using Slackware 9 and just completed a new installation and decided it would be best to use the ATI drivers (AIW8500DV). This is the first thing I did, started x, downloaded the drivers, used rpm to install them, followed the onscreen instructions to add the module, ran fglrxconfig and used all of the right refresh rates etc. I did this twice, and got the same error both times.
After I exit x and try to startx
it looks like it is working but the normal kde loading box does not appear
instead i get a consol message
"DCOP aborting call from 'anonymous-1465' to 'kded'
ERROR: KUniqueApplication: DCOP communication error!"
followed by what looks like a normal kde shutdown

I have no idea how to fix this. I reran the x configuration utility that came with the ati drivers with no success.
I think it has something to do with links made by the rpm setup to gain access to an ATI Control Panel of sorts but am unsure.

Any help with this woule be greatly appreciated.

subekk0 11-26-2003 08:02 AM

What type of ATI card do you have? If it is a radeon the drivers are built into 9.x All you need to do is specify "radeon" as the driver and change the resolutions to something more usable. Also, when installing anything from ATI it is best to download and install using the source.

manitoulinnerd 11-26-2003 11:12 AM

I have an ATI All in Wonder 8500 DV, it has the R200 chip and 64 MB of ram. 9.0 does have drivers that work but they are very rudimentary 2d drivers only. I was able to startx before i loaded ati's drivers... i downloaded them in linux. I know the resolution ok and tried a few different ones to be sure, same result. I don't think ATI provides the source for its closed drivers but I may just be unable to find it. If all i need to do is specify radeon as the driver how do i do so?

subekk0 11-26-2003 11:52 AM

in /etc/X11/XF86Config file scroll down to "Graphics Device Section"

Section "Device"
Identifier "ATI"
Driver "radeon"
VideoRam "64000"

However, since you have an all in wonder card I don't know if this will work correctly. But it testing it would not hurt anything.

manitoulinnerd 11-26-2003 02:28 PM

i have ruled out problems with x and my configuration of it. I have been able to start gnome but am still haveing the same problem with kde. This was a fresh install... the only thing I did was install the ATI linux video drivers version 3.2.8 for xfree86 4.3.0
I tried what was suggested above and this did not change the error.

All times are GMT -5. The time now is 08:56 AM.