Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 10-20-2005, 11:25 PM   #1
Registered: Mar 2005
Location: Illinois, US
Posts: 38

Rep: Reputation: 15
Date gets messed up after a reboot

Every time I reboot my date gets messed up. Also, when loading there are some issues with hwclock. It takes forever to load. I tried setting hwclock equal to sysclock, but failed:

root@sledgehammer:/home/kosmonaft# date -u 10202339
Thu Oct 20 23:39:00 UTC 2005
root@sledgehammer:/home/kosmonaft# hwclock --systohc

Why does it say "Hangup?" Would could be a problem?
Old 10-21-2005, 01:20 AM   #2
Registered: Dec 2003
Location: Roc City (Rochester-NY)
Distribution: Slacker 4 Life
Posts: 125

Rep: Reputation: 15
I honestly don't know about the "Hangup" response, I literally just learned of the hwclock command yesterday, however, having the time be screwy after reboot is a tell-tale sign of a dead/dying mobo battery. Forgive me if I talking beneath you, but this is how the computer keeps it date (along with a few other settings). Oversimplified, it's all stored in a RAM-like chip that gets the power to function off of a little 3v battery on your motherboard.
If the motherboard battery gets low on juice and can't quite put out enough power for the chip to keep its settings, then the settings will start to slip, such as your HW date setting. If you crack open your chassis (WARNING: This may void a warranty of some sort) you should be able to see a little round battery (like what would be in a watch) in plain view. Replace that and reset your settings and chances are your HW clock will be good. Best of luck

Old 10-21-2005, 02:16 AM   #3
Registered: Oct 2003
Location: USA Fresno Callifornia
Distribution: Gentoo (workstation), ArchLinux (file/mail server), Freebsd (web server), Ubuntu (laptop)
Posts: 115

Rep: Reputation: 16
I am having this same problem with hwclock also on Archlinux but instead of hangup I am getting a different error that I will have to post at a later date.
I just remembered that there is also a command "clock" that I think maybe useable to set the hardware clock.
Old 10-21-2005, 10:02 AM   #4
Senior Member
Registered: Mar 2005
Location: USA::Pennsylvania
Distribution: Slackware
Posts: 1,065

Rep: Reputation: 45
you may want to check to see if you have
set in the kernel...

from the kernel help


If you say Y here and create a character special file /dev/rtc with
major number 10 and minor number 135 using mknod ("man mknod"), you
will get access to the real time clock (or hardware clock) built
into your computer.

I know I ran into a problem with this, different than yours, but involving RTC when setting up VMware.
When I tried a `hwclock --debug` it told me that /dev/rtc was not available. I compiled it in and now hwclock works fine.

If you go this route, CONFIG_RTC is under 'character devices' in the kernel config.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
No keyboard/mouse after reboot. Requires second reboot to work. rottie Linux - Hardware 6 01-16-2006 05:04 AM
Start Date + Time Duration = End Date/Time calculator? ToBe Linux - General 3 09-26-2005 10:17 AM
after reboot ....gui got all messed up luna6 SUSE / openSUSE 15 05-20-2005 11:42 AM
time and date not correct, after reboot vasanthraghavan Linux - General 4 03-10-2005 11:55 AM
lastlog date does not match system date? jcmj Linux - Networking 6 10-22-2002 12:09 PM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:38 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration