-   Slackware (
-   -   Dark gray text on black background or psychedelic colors and 99% CPU in use (

w1k0 10-19-2008 02:44 PM

Dark gray text on black background or psychedelic colors and 99% CPU in use
The problem described below seems to be partially resolved when I used the proprietary fglrx driver by ATI. Window Maker and X applications work now well on my Thinkpad T60 with ATI Radeon X1300 and Slackware 12.1. Some strange problem persists in case of KDE.


I try to configure Slackware 12.1 with generic kernel on my new ThinkPad T60 (Intel Core Duo 2x1.83 GHz, 1 GB DDR, ATI Radeon X1300 64 MB RAM). I just finished to work on console and started to tune X Window.

Earlier I stated the problem with framebuffer (see: ``Linux logo in strange colors'' thread). It was unable to display 224-colors Linux logo. Now I stated two problems with X Window. I'm starting to suspect there is something wrong with the video card in my laptop.

At the beginning I prepared xorg.conf using xorgconfig. I used safe settings -- the same I use on my old T41 and T40 (both with ATI Radeons).

I started Window Maker, exited it, and stated console screen became almost black: on the black background was visible small regular patterns of dark gray scaled down letters.

I rebooted machine and tried standard xorg.conf. The result was slightly better: after exiting Window Maker I saw dark gray almost invisible text on the black background.

I rebooted machine and tried KDE with the same result.

That problem concerns all six consoles. X Window works good but spoils the work of framebuffer.

I tried a few minimalistic configurations of X Window. The best result gives standard xorg.conf. In that case ``the best'' doesn't mean ``good'' or even ``acceptable''.

I tried xorgconfig as well as xorgsetup. Results was as bad as before.

Then I checked how xv and xine display pictures and movies.

There are no problems with pictures.

There is the problem with movies. Xine is unable to play movie in a smooth way -- image skips from scene to scene. Moreover colors are invalid: psychedelic green and purple stains on monochrome image. Furthermore movie slows down the machine. I checked top command. Xine uses 7-10% of CPU but X uses 97-99% of CPU!

Is there something I could to do to avoid those problems or I should leave my machine to the service or return it to the shop?

Have a nice day...

T3slider 10-19-2008 02:53 PM

As for the framebuffer issues upon exiting X, try using the "vga = normal" option in lilo.conf (don't forget to run `lilo` after editing). I'm sure you won't want to use this permanently, but I think that may stop the fading text upon exiting X. I'm no expert on ATI cards in Linux (I use only nVidia cards), but you could try installing fglrx and let it configure xorg.conf and see if that helps video playback (ie try getting DRI enabled). Beyond that I'm afraid I can't help you.

w1k0 10-19-2008 05:39 PM

I inspected twelve console displaying syslog messages when X Window was running. The console looked well. It means X server spoils the console on exit.

I tried vga = normal option of lilo.conf. In that mode it's possible to exit from X Window back to the console and see a regular text. It's first good news because in such situation I don't need to reboot the machine continuously.

I use DRI in my own xorg.conf. In that mode CPU usage during watching movies falls from 99% to 95%. It's second good news because I can use mouse then in X Window. (When CPU is used in 99% mouse cursor jams and jumps on the screen.)

Movies in DRI mode are still in psychedelic colors and are stuck.

I closed accidentally laptop's lid when console was in VGA text mode. When I opened it I saw instead of the dull white text on the black background a beautiful pattern of multicolor flashing rectangles. Because it was impossible to reboot machine in that situation using Ctrl+Alt+Del I needed to turn the power off.

So I done three ``lid tests''.

First I run KDE and closed the lid. When I opened it I saw blue screen. Not that famous Blue Screen but humble light blue screen with subtle vertical purple stripes.

Then I run Window Maker and closed and opened the lid. I saw purple screen with black stripes and two rows of nice flashing rectangles in different colors on the top.

Good news: it's possible to exit from blue or purple screen to console in VGA mode using Ctrl+Alt+Backspace and console is intact in such case.

After consecutive reboot I tried to spoil in that manner console but I couldn't repeat that beautiful effect I saw at the beginning.

I just downloaded fglrx driver and module together with ATI driver but I don't think I'll use it. I don't like proprietary drivers. In fact I don't need them. I don't use any demanding programs.

Thank you T3slider for your assistance.

niels.horn 10-20-2008 07:52 AM

If this problem is still bothering you, check some of the documentation files in /usr/src/linux/Documentation/fb
I've had some weird problems with configuring the framebuffer in the past, but all on some older, non-vesa-2.0 compatible graphics cards.

vga=normal will basically disable the framebuffer (so you won't see Tux anymore) and leave you with a very basic 80x24 console. You can choose a smaller font afterwards though.
With vga=ask in lilo.conf you can check several options without changing lilo.conf and running lilo every time.

I also remember some suggestion of changing the APG-aperture setting in the BIOS, but I think it never worked for me.

On some machines (with the older cards) I never got it to work, but these were for people who just wanted X running with KDE and had no need for a console.

Unfortunately I have no experience at all with Thinkpads...

McSlack 10-20-2008 09:34 AM

My T60P uses the ATI Mobility FireGL V5200 card but exhibits many of the same issues you're having. I've pretty much have given up on fixing it. T3Slider's advice of changing your Lilo to use "VGA=Normal" is the only way I can exit X-Windows without the screen being garbaged. Funny thing is FB works fine until I run "Startx" but after exiting X-Windows back to shell it doesn't. I also had the same problem you had with Xine but after running xorgsetup Xine worked normally. I have the flexview screen and 1600x1200 works fine. After finishing all my configurations I boot to KDE and have left my Lilo at "VGA=Normal" since I only see it during bootup and shutdown I'm not too concerned. On the occasions I close the lid I just hit <CTRL<ALt>F2 wait a few seconds then hit <Ctrl><ALT>F7 which causes the screen to get refreshed. I know this is a kludgy work around, but I've been too lazy to investigate why X-windows can't exit correctly.

McSlack 10-20-2008 12:50 PM

had a little time to play with my config and discovered if you add these lines to your file which is in /etc/acpi/actions you can close and open your lid without seeing those colorful little rectangles.

# go to sleep <-after this line switch to text mode.
chvt 1
# restore USB support <- after this line switch to X-windows
chvt 7

Still working on the text screen problem. What is your screen size? XGA? SXGA? For some reason if I match the screen size in my lilo to the screen size in X-windows I don't have the problem when exiting X-windows to a text screen. However, I haven't been able to set lilo to 1600x1200 without using "Vga = ask" Then I have the option of 1600x1200x24 (376) But this isn't a VesaFB setting. I think it's a Atyfb setting, but I'm not smart enough to figure out how to set that in lilo.

w1k0 10-20-2008 06:01 PM

I made a phone call to Lenovo. That laptop has International Warranty Service in ``All Sites'' version. The latter means Lenovo guy arrive to me the same day I call to him and repair my machine.

Service guy from Lenovo advised me to test my laptop with the other systems. He suggested Windows but agreed to Red Hat (Lenovo just starts to sell laptops with that system). He suspected it can be the problem with the video card driver in my Slackware.

0. Windows trial Active @ Boot Disk

At the beginning I tried to download trial version of Windows from Microsoft home page but I gave up at the second page of extensive questionnaire asking me about everything except my credit cards PIN numbers. It was to much questions for me. Then I downloaded trial version of Windows from It wasn't ISO image but an installer in EXE format. Hopefully I have old Windows on my old laptop so I was able to unpack the installer. Setup suggested me to get Registration Key from I filled short poll in and was assured I'll get Registration Key soon by e-mail. It was six hours ago and I still can't see that e-mail.

In the meantime I did the other tests...

1. Slax 6.03

MPlayer displayed movies in a correct way. I could display subtitles, use OSD, and switch to full screen mode. CPU usage had acceptable value.

``Lid test'' failed: after closing and opening the lid of my laptop I saw a corrupted image instead of KDE desktop and applications.

2. Ubuntu 8.04 (live version)

I couldn't open AVI files because of lacking of the appropriate codecs. I didn't try to install them.

``Lid test'' failed as above.

3. Slackware 12.1 -- once again

At the beginning I tried Xine. It couldn't display movie in a proper way and caused 99% CPU usage. Then I tried MPlayer. It displayed movie in a correct way but I couldn't access OSD, and after switching to the full screen mode I saw image in the same size as in normal mode with wide black frame around it.

``Lid test'' failed as above. Moreover after exiting X Window framebuffer screen was corrupted.

4. Fedora 9

Fedora is a strange kind of Linux.

I couldn't watch movie with standard Fedora's application because of lacking of some codecs. Fedora told me I can buy them for 28 euro. I bought Linux-oriented magazine with Fedora for 7 euro and I have to buy a few codecs for 28 euro? Is it possible a few little codecs are worth four times greater than the entire Fedora?

So I tried to install MPlayer in Fedora. Without success because after default installation there are no cc nor gcc in the system. I tried to install them from DVD but Fedora complained: ``You don't have necessary privileges to install local packages''. I'm root and I haven't sufficient privileges? If root hasn't those privileges who has? Maybe God?

Surprisingly ``lid test'' made on my laptop with Fedora's GNOME passed. Unfortunately X Window still corrupts framebuffer.

5. Conclusion

Each system I install on my new laptop fails in some way. It can concern framebuffer, X Window or some particular programs. On good machine every system works well. It looks like video card in my laptop is corrupted. Tomorrow I'll call to Lenovo for the second time...

w1k0 10-20-2008 07:30 PM

niels.horn: I'll look to /usr/src/linux/Documentation/fb later. My problem isn't limited to framebuffer. It concerns also X Window and some applications. VGA mode is good for testing purposes but not for everyday work. In framebuffer mode I see three times more text on the screen. Framebuffer is like wide open window. VGA mode is like window vent. BIOS in T60 is limited in comparison to T40 and T41. There are no options concerning some power saving functions in it (in T40 and T41 there were). I suppose ``lid problem'' can concern these functions.

McSlack: Bad news. Earlier I thought it's some strange damage of that particular video card in my laptop. After reading your post I'm starting to be afraid it's normal behavior of Lenovo machines. I tried xorgsetup. Xine still corrupts movies. I tried your trick with VGA mode and Ctrl+Alt+F1, Ctrl+Alt+F7. It works partially. It repairs application windows in X Window but the desktop is still corrupted. Using of chvt is interesting idea. I'll try it soon. T60's LCD screen is 15'' 1024x768. I use 1024x768x256 mode in lilo.conf and 1024x768 mode in xorg.conf. So both screen sizes are the same but the problem appears. I simply can't understand it. Each machine works in another manner.

w1k0 10-20-2008 07:50 PM

I just found an interesting script...


# if launched through a lid event and lid is open, do nothing
echo "$1" | grep "button/lid" && grep -q open /proc/acpi/button/lid/LID/state && exit 0

# remove USB 1.1 driver
rmmod uhci_hcd
# sync filesystem and clock
/sbin/hwclock --systohc

# switch to console
chvt 1

# go to sleep
sleep 5
echo -n "mem" > /sys/power/state
sleep 5

# readjust the clock (it might be off a bit after suspend)
/sbin/hwclock --adjust
/sbin/hwclock --hctosys

# reload USB 1.1 driver
modprobe uhci_hcd

# turn on the backlight and switch back to X

After preparing the script run those commands:

mkdir -p /etc/acpi/actions/
cp /etc/acpi/actions/
echo "event=button/lid" > /etc/acpi/events/lid
echo "action=/etc/acpi/actions/ %e" >> /etc/acpi/events/lid

Then reboot your machine...


That script works good but not for me. I don't want my machine sleeping with closed lid. I usually close the lid to let my machine compile some huge programs or download some large files.

w1k0 10-20-2008 08:13 PM

I just tried to minimize and maximize Terminal window in Slackware's 12.1 KDE and X-Term window in Window Maker. These operations use on my T60 up to 101% of CPU. I called it ``terminal problem''. Both these environments are simply useless on T60 with Slackware.

I tested it in Fedora. Everything works good there.

At that moment Fedora 9 is the best choice for T60. There is no ``lid problem'' and there is no ``terminal problem'' in Fedora. There is still ``framebuffer problem''.

And my problem is I don't like Fedora and I like Slackware.

T3slider 10-20-2008 09:26 PM

Regarding your high CPU usage -- is your hard drive being detected as hda or sda? See this from CHANGES_AND_HINTS.TXT:

If you notice extremely long wait times when formatting partitions in the
  installer, and you're installing on a Thinkpad that has a SATA drive, it's
  possible that the wrong driver is being used, which disables DMA on the drive
  (and could happen on other machines). A bit more detail about it is here:
  Try passing "hda=noprobe" to the kernel when booting the installer, and it
  should use the correct libata driver.

I'm not sure that that's relevant at all, but it's the only thing that comes to mind immediately.

w1k0 10-20-2008 09:52 PM

At long last I tried ATI proprietary fglrx driver taken from SlackBuilds. It's huge (1743044) but useful in the case of T60. ``Lid problem'' disappeared. Xine displays movies in a proper way. MPlayer works good too (except OSD). Even ``framebuffer problem'' disappeared. (I don't mean ``Tux problem'' described in ``Linux logo in strange colors'' thread -- it has nothing to do with X Window.)

In KDE maximizing and minimizing windows still causes up to 100% of CPU usage and is painfully slow. Maybe it's issue of some clever switch in xorg.conf. In Window Maker CPU usage durig window operations is on very low level. (I use Window Maker exclusively so I don't bother a lot about KDE.)

Now Slackware is better than Fedora because there is no there ``framebuffer problem''. Fedora's xorg.conf uses radeon driver. I suspect it's tuned driver -- not the original one. It behaves in the other way than radeon delivered with Slackware.

You was right T3slider. I should try fglrx at the beginning. Although I don't like proprietary drivers in such situation it's the only alternative.

w1k0 10-20-2008 10:05 PM


I had the problem with DMA at the beginning. I resolved it thanks to the valuable hint I found somewhere in Internet among a lot of useless hints.

My laptop recognizes hard disk as sda.

# fdisk -l /dev/hda

<null output>

# fdisk -l /dev/sda

Disk /dev/sda: 160.0 GB, 160041885696 bytes
240 heads, 63 sectors/track, 20673 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes
Disk identifier: 0xcccdcccd

Device Boot Start End Blocks Id System
/dev/sda1 1 900 6803968+ 83 Linux
/dev/sda2 901 1958 7998480 83 Linux
/dev/sda3 1959 6605 35131320 83 Linux
/dev/sda4 6606 20673 106354080 5 Extended
/dev/sda5 6606 11251 35123728+ 83 Linux
/dev/sda6 11252 15897 35123728+ 83 Linux
/dev/sda7 15898 20543 35123728+ 83 Linux
/dev/sda8 20544 20673 982768+ 82 Linux swap

Thank you T3slider for your kind assistance...

McSlack 10-21-2008 11:25 AM

I'm glad to see you're getting things sorted out. For Mplayer to use the OSD you have to run "gmplayer". You also might want to look at VLC media player and Kaffeine. They both play DVDs. Are the missing codecs libdvdcss, libdvdread and libdvdnav? If so those are available free from many sources. Can you show me your lilo.conf file? I can't seem to get the ATI frame buffer drivers to load. I do have them installed. I should have mentioned that my kernel is which may have also cleared up many of my problems. It for sure fixed my Wifi problem.

ED: Never mind I figured out the value 376 for 1600x1200 is Hex the decmial value 988 works great.

w1k0 10-22-2008 05:03 AM

When I said about OSD in MPlayer I thought about status information you can display using letter o key. It should display timer and total time informations. In T60 with Slackware it shows only arrow for some reason.

I don't like gmplayer. It's uncomfortable to use mouse with that small interface and all those enigmatic buttons.

To see AVI movies I use the command:

mplayer -ass -ass-color ffffff00 -sub EN Movie

EN it's symbolic link to subtitle file and Movie it's symbolic link to AVI file.

MPlayer without -ass* switches doesn't display subtitles for some reason.

To see DVD movies on T60 I use the command:

mplayer -alang en -slang en -dvd-device /dev/dvd1 -dvd-speed 1 dvd://

T60 with Slackware uses /dev/dvd1 device and MPLayer in standard settings recognizes /dev/dvd device.

T40 and T41 with Slackware use /dev/dvd device so MPlayer doesn't need -dvd-device switch.

I installed only libdvdcss. Should I install libdvdread and libdvdnav too?


Here is my lilo.conf...


boot = /dev/sda
append="vt.default_utf8=0 acpi_sleep=s3_bios,s3_mode libata.atapi_enabled=1 combined_mode=libata"
timeout = 50
vga = 773
image = /boot/vmlinuz
  root = /dev/sda2
  label = linux.custom
image = /boot/vmlinuz-generic-smp-
  initrd = /boot/initrd.gz
  root = /dev/sda2
  label = linux.generic
image = /boot/vmlinuz-huge-smp-
  root = /dev/sda2
  label = linux.huge

Magic append switches are to enable DMA on SATA HDD. To enable it I set also T60's BIOS Serial ATA (SATA) | SATA Controller Mode Option to AHCI.


Thank you for WiFi tip. At the moment I don't use it but who knows what will be in the future?


I'm glad you found lilo.conf switch to set the appropriate resolution of the framebuffer.

All times are GMT -5. The time now is 05:52 AM.