LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 03-02-2010, 08:18 PM   #1
zhoun
Member
 
Registered: Oct 2007
Location: anywhere
Distribution: slackware64 current & win7 64 on thinkpad X61
Posts: 104

Rep: Reputation: 18
Red face custom kernel not boot after current lastest update


After the bunch of updates with current, my custom kernel (2.6.33) can't boot.

The error is:
/sbin/e2fsck: No such file or directory while trying to open /dev/sda6

The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate
superblock:
e2fsck -b 8193 <device>

The /dev/sda6 is ext4 and is ok since it can boot with official huge smp kernel 2.6.33.

My custom kernel can boot before this bunch of updates in current.
What i missing in kernel?
 
Old 03-02-2010, 08:23 PM   #2
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 200Reputation: 200Reputation: 200
Is there possibly a problem with the initrd? It sounds like it doesn't have support for the ext4 filesystem.
 
Old 03-02-2010, 08:23 PM   #3
koenigdavidmj
Member
 
Registered: Oct 2009
Posts: 73

Rep: Reputation: 25
Have you ensured that ext2, ext3, and ext4 are built in the kernel? Only ext3 is default, if I recall.
 
Old 03-02-2010, 09:26 PM   #4
zhoun
Member
 
Registered: Oct 2007
Location: anywhere
Distribution: slackware64 current & win7 64 on thinkpad X61
Posts: 104

Original Poster
Rep: Reputation: 18
thanks for your help!

Yes, i ensured that ext2, ext3, and ext4 are built in the kernel,
and i build most things into kernel and so not use initrd.

The ext4 paritation and custom kernel worked fine before upgrade.
Some changes in this update caused this, devicemapper?...
 
Old 03-02-2010, 09:35 PM   #5
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 200Reputation: 200Reputation: 200
Are you sure you are using the custom kernel still? Slackpkg upgrade-all will remove kernel versions. Usually not a custom kernel, but it could depend on how that custom kernel was named. It's possible that what you are actually booting is actually the new generic kernel.
 
Old 03-03-2010, 05:32 AM   #6
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 6,702
Blog Entries: 51

Rep: Reputation: 1243Reputation: 1243Reputation: 1243Reputation: 1243Reputation: 1243Reputation: 1243Reputation: 1243Reputation: 1243Reputation: 1243
Maybe you should have put your custom kernel in /etc/slackpkg/blacklist.
 
Old 03-03-2010, 07:44 PM   #7
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 200Reputation: 200Reputation: 200
Slackpkg usually won't replace a custom kernel, but the slack forum is full of people that might have wanted to read this from /etc/slackpkg/blacklist:
Quote:
# This is a blacklist file. Any packages listed here won't be
# upgraded, removed, or installed by slackpkg.
#
# The correct syntax is:
#
# To blacklist the package xfree86-devel-4.3.0-i386-1 the line will be:
# xfree86-devel
#
# DON'T put any blank line(s) or any space(s) before or after the package name.
# If you do this, the blacklist will NOT work.
#
# Automated upgrade of kernel packages aren't a good idea (and you need to
# run "lilo" after upgrade). If you think the same, uncomment the lines
# below
#
kernel-ide
kernel-modules
kernel-source
kernel-headers
kernel-generic
Having said that, I just used this file and my kernel-firmware package got upgraded and I was told to rerun lilo which I've done. What I haven't done is reboot. If this post gets edited then you know I'm in the same boat.

3-2-1 reboot!
 
Old 03-03-2010, 08:20 PM   #8
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,904

Rep: Reputation: Disabled
1) if the stock kernel works, then failure of your custom kernel is not a bug. Consider looking at the differences in the two kernel configurations (see ./scripts/diffconfig in the kernel source).

2) The slackpkg blacklist is irrelevant for someone following -current. In fact, it should be cleared out completely for a -current system.

3) Slackware -current is NOT intended for people who want the latest and greatest and expect it to "just work" and to get support for every little thing that goes wrong. -current is the development tree, and quite frankly, it's *expected* to break from time to time, and if you can't handle that (or more importantly, figure out the little stuff yourself), then quite frankly, you should stick to the latest -stable release.
 
Old 03-03-2010, 08:51 PM   #9
zhoun
Member
 
Registered: Oct 2007
Location: anywhere
Distribution: slackware64 current & win7 64 on thinkpad X61
Posts: 104

Original Poster
Rep: Reputation: 18
thanks for all your help.

The huge smp kernel worked fine, but generic kernel can't boot.
the error is "can't mount root filesystem".

just like 792973

huge smp can't work with kms and i915.

I am not complain, just want some clues to fix it.
The more guys help test the current, the more stable, right?
 
Old 03-03-2010, 08:57 PM   #10
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 200Reputation: 200Reputation: 200
Have you tried to create a new initrd yet? I upgraded to current MINUS the kernel (I like to run the release candidates when available and since I've had a 2.6.33 kernel for a month now, I'm waiting for a maintenance release to bother) and it boots fine, however I don't need the initrd.

It just sounds like your initrd isn't working properly or is missing. Also I've seen one report of the new mkinitrd script not working for someone, but they reported the original worked for them. I have no way to confirm that.
 
Old 03-03-2010, 09:08 PM   #11
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,231

Rep: Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573
The generic kernel requires an initrd (initial ramdisk) since the filesystems are compiled as modules -- and therefore it cannot mount your root filesystem without an initial ramdisk that loads the right module(s) for your system. There should be a script in /usr/share/mkinitrd/mkinitrd_command_generator.sh that can generate the proper command for you. This is unchanged between stable and -current, and there should be tons of threads explaining this and /boot/README.initrd contains the relevant information. Honestly, if you didn't know about the initrd (which has been required for the generic kernel since 12.0 as far as I remember) then you probably should be running stable (13.0) instead of -current.

As to 'The more guys help test the current, the more stable, right?' -- that's true to an extent, but if it becomes necessary to try to distinguish user error from real problems, it makes it much more frustrating for the developers who may not have the time to deal with these non-issues. -current really should be reserved for those that know what they're doing, and though that may be you some day, right now I would really advise sticking with stable.
 
1 members found this post helpful.
Old 03-03-2010, 09:28 PM   #12
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 200Reputation: 200Reputation: 200
I would suggest doing this to make sure your kernel is what you think it is:
Code:
ls -alt /path/toyour/customkernelsource
check the dates. The most likely explanation is that the upgrade replaced your kernel and if that looks right then check /etc/lilo.conf to make sure that your boot options are pointing where you think they are. If all this checks out then run the generator script and run mkinitrd accordingly.

Last edited by damgar; 03-03-2010 at 09:44 PM.
 
Old 03-04-2010, 08:18 AM   #13
zhoun
Member
 
Registered: Oct 2007
Location: anywhere
Distribution: slackware64 current & win7 64 on thinkpad X61
Posts: 104

Original Poster
Rep: Reputation: 18
I know initrd and i had compiled everything needed into custom kernel.
so just like huge smp kernel to not depend on initrd.

I used this custom kernel config for almost 3 years.

I not realized that this CHANGED after recent update.

The generic kernel and initrd.gz worked fine.
So i merged my custom config with generic config and generate the initrd.gz,
all worked fine.

thanks all.
 
Old 03-06-2010, 09:33 PM   #14
zhoun
Member
 
Registered: Oct 2007
Location: anywhere
Distribution: slackware64 current & win7 64 on thinkpad X61
Posts: 104

Original Poster
Rep: Reputation: 18
finally found the original cause:

missing-devsda-etc-when-booting-custom-kernels-793583/

Udev will not work with the CONFIG_SYSFS_DEPRECATED* option

thanks drmozes!

Last edited by zhoun; 03-06-2010 at 09:34 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel panic after update to -current Intel_ Slackware 14 05-02-2010 11:32 PM
-current and 12.2 Kernel security update Interject Slackware 21 08-19-2009 10:48 PM
Lastest Xorg update MURDERED my system! Exospaciac Ubuntu 1 01-18-2008 09:32 PM
lastest kernel? linuxmandrake Debian 1 09-28-2005 12:32 PM
Red Hat Update Agent for kernel updates and custom kernels SparceMatrix Linux - General 5 09-03-2002 04:58 PM


All times are GMT -5. The time now is 06:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration