-   Slackware (
-   -   Custom Install ISO: Kernel Panic (

froedi 08-22-2004 08:44 AM

Custom Install ISO: Kernel Panic
hi there!

currently I'm trying to create my very own slackware install cd with a custom kernel that will detect my hdd correctly as a sata drive.
I've compiled a kernel for this purpose und replaced one of the 'original' kernels from the official slackware cd.
But when trying to boot this kernel I get a kernel panic, saying:


VFS: Cannot open root device "ram" or unknown-block(1,0)
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on unknown-block(1,0)

I still haven't figured out why. :/
I tried some different kernel configurations but that didn't help.

I don't know if there's something else I have to do besides replacing the original kernel ...

As I'm still new to compiling kernels and all that stuff so I probably made a mistake or just missed something.

I'd be very(!) happy if someone could give me a hint on how to get rid of that kernel panic :>



RestInPieces 08-22-2004 10:07 AM

yup..this is what the noobs do :D... just follow the error message...correct the "root=" boot option

root = /dev/hda1
replace hda1 with your root partition (the one where Linux is installed) :P

froedi 08-22-2004 10:22 AM

I guess it's not that easy because linux isn't installed on my hdd at all (at least not yet).
I'm talking about the kernel I compiled for my own slackware install cd -> when trying to boot it (from cd) the kernel panic occurs ;>

RestInPieces 08-22-2004 10:44 AM

hmm.... that is strange... but it should work the same...( the kernel just said: hey! where is your linux root partition?... cuz` lilo didn't tell me :D)

froedi 08-22-2004 11:13 AM

so what is my root partition then? :confused:


regarding the error message, I suppose it has got something to do with a ram disk that can't be mounted.
but 'knowing' that doesn't really help me :/

RestInPieces 08-22-2004 11:25 AM

hell no!... are you following me ?:D your root partition is the partition that has the linux distro installed on it ...and.. it has nothing to do with the ram disk ...because you don't have that sort of thing... just paste your lilo.conf and i'll point out exactly what to do...

froedi 08-22-2004 01:21 PM

alright, there seems to be a biiiiiiiiiig misunderstanding :rolleyes:

these are the facts:
- I don't have any linux distribution installed:
the official slackware install cd doesn't detect my sata drive correctly (because none of the default kernels supports sata)

- that's why I want to create a very own install iso, with a kernel that does support sata

- I managed to built such a kernel, which I used to replace the original bare.i kernel from the slackware cd

- so at the boot promt of the cd I select my custom kernel:
it starts booting (detects my hardware etc.) but then I get this kernel panic - before the actual setup is loaded

do you now know what I mean?! :D

RestInPieces 08-22-2004 02:47 PM

well.. now i now what you are talking about... sorry about the missunderstanding :D
now what you're just doing is a very complicated thing... you may have some problems with the install..i can't really tell you what the problem is ,but i can suggest something: don't install the kernel on the cd .. install linux with the bare.i and just use lilo to add your kernel... :)
(are you sure that your kernel worked... sometime..?)

All times are GMT -5. The time now is 11:50 AM.