LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Current64 : vte-0.64.0 - {xfce4,mate}-terminal : underscore (_) on bottom line not visible (https://www.linuxquestions.org/questions/slackware-14/current64-vte-0-64-0-%7Bxfce4-mate%7D-terminal-underscore-_-on-bottom-line-not-visible-4175693112/)

burdi01 04-04-2021 03:49 AM

Current64 : vte-0.64.0 - {xfce4,mate}-terminal : underscore (_) on bottom line not visible
 
Since the Mar 31 upgrade of vte to 0.64.0 an underscore (_) on the bottom line of xfce4-terminal 0.8.10 or mate-terminal 1.24.1 is no longer visible. It looks like 1 or 2 pixel lines are missing.
Downgrading vte to 0.62.3 resolves the problem.
:D

Edit Apr 8, 2021: Removed the quote from the GNOME issue tracker here.

burdi01 04-05-2021 05:38 AM

I was hoping for a confirmation or denial, but no one came forward.
Maybe my wording in the initial problem report was the cause *), or no one else sees the problem.
:D

*) Therefore I changed the wording of the report.

burdi01 04-06-2021 03:43 AM

In the one and only VTE 0.64 issue on https://gitlab.gnome.org/GNOME/vte/-/issues/ the maintainer states that "the line height is taken directly from the font's metrics".

So I reinstalled VTE 0.64.0 and tested whether the DejaVu Sans Mono Book font I use with size 9 is the culprit. And lo and behold: with the sizes 8 and 9 the problems occurs, but with size 10 it does not!
As for me the optimum size is 9 I also tested with Libration Mono Regular, Luxi Mono Regular and Monospace Regular. With none of these the problem occurs and for me the latter is the most acceptable replacement.
:D

burdi01 04-08-2021 07:22 AM

The Monospace Regular 9 workaround as mentioned above does not work in an LXDEish environment.
Keeping VTE pinned at 0.62.3 for the time being ...
:D

burdi01 05-02-2021 04:31 AM

The problem is not resolved by vte 0.64.1.
Still pinning VTE at 0.62.3 ...
:(


All times are GMT -5. The time now is 06:06 AM.