LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Current64: libfontconfig.so.1: undefined symbol: FT_Done_MM_Var (https://www.linuxquestions.org/questions/slackware-14/current64-libfontconfig-so-1-undefined-symbol-ft_done_mm_var-4175625249/)

burdi01 03-09-2018 03:42 AM

Current64: libfontconfig.so.1: undefined symbol: FT_Done_MM_Var
 
Current64 Thu Mar 8 updates: Thunderbird, leafpad and possibly others, as well as XFCE itself do not start any more:
Code:

thunderbird: symbol lookup error: /usr/lib64/../lib64/libfontconfig.so.1: undefined symbol: FT_Done_MM_Var
libfontconfig.so version is bumped from 1.10.1 to 1.11.1

hadack 03-09-2018 08:32 AM

Did you by chance miss the freetype upgrade on 14. Feb?

l/freetype-2.9-x86_64-1.txz: Upgraded.

burdi01 03-09-2018 11:05 AM

Quote:

Did you by chance miss the freetype upgrade on 14. Feb?
Actually I have freetype pinned at 2.7.1 -- see https://www.linuxquestions.org/quest...nt-4175606199/ for the why.
Upgrading freetype to 2.9 resolved my problem, rebuilding my 2.7.1 freetype version did not.
Considering my options ...
:D

burdi01 03-10-2018 04:08 AM

I decided to take the dive and unpinned/upgraded the freetype and fontconfig packages.
Hoping I will get used to the now somewhat awkward/clumsy dejavu/10 font ...
:D

mickski56 03-10-2018 04:30 AM

Are you aware of the file /etc/profile.d/freetype.sh ?
I tried to get used to the new look font rendering for a week or so, couldn't get used to it.
so set FREETYPE_PROPERTIES to "truetype:interpreter-version=35" for the old "incorrect" font rendering.
My eyes are happier as a result.
HTH

burdi01 03-10-2018 05:30 AM

Quote:

Are you aware of the file /etc/profile.d/freetype.sh ?
The last time I tested (some months ago) the results were not all-convincing.
As I am looking for the 2.7 behaviour "40" should be more appropriate. I retested and indeed "40" plus hinting "slight" makes dejavu more agreeable (though still not all-convincing) at size "9".
Thks. :D

Martinus2u 03-10-2018 06:06 AM

I went for Infinality mode (38) when i tried it some time ago, having used Infinality in the past. Not sure how big the difference is compared to 40.

aaditya 03-10-2018 11:54 PM

Was affected by this too, by having custom compiled freetype for reasons similar to the OP.

Thanks for the help!

jostber 07-24-2019 03:41 PM

I got this again with the Libreoffice upgrade in current to 6.2.5 and with freetype 2.10.1. I had to remove this file to make /usr/bin/libreoffice and /usr/bin/soffice work again:

/home/jostein/.config/libreoffice/4/user/config/javasettings_Linux_X86_64.xml

Ref. also to this:

https://github.com/flathub/org.libre...fice/issues/37


All times are GMT -5. The time now is 06:24 AM.