-   Slackware (
-   -   -current updates Mesa/Xorg + Legacy nVidia + X -configure = Problems (

linus72 11-22-2010 09:36 AM

-current updates Mesa/Xorg + Legacy nVidia + X -configure = Problems
Got the mesa/xorg updates this morning; using nvidia 96.43.19 from nvidia(not sbopkg) (mx4000)

I re-built/re-installed the nvidia driver 'cause Ponce the Wise noted it should be done here

all was successful

On same PC with almost identical system but running "nv" driver after updating mesa/xorg and doing X -configure I get black screen doing startx ( I had a pre-existing xorg.conf with "nv" driver)

Instead of putting "nv" for driver in xorg.conf, now X -configure results in putting "modesetting" where it says driver "" and X wont start

However, using no xorg.conf whatsoever and not doing X -configure X does start successfully!

So, with no xorg.conf and with the pre-existng /etc/modprobe.d/BLACKLIST-nouveau.conf it must be using the "nv" driver right??


1) since theres no xorg.conf and because the new Xorg doesnt need a xorg.conf (right?), how do I figure out what driver is being used?

2) why does doing X -configure make a erroneous xorg.conf that says "modesetting" instead of "nv" ?


oh, I noticed also in the changelog that it says "x/xorg-server-1.9.2-i486-3.txz: Rebuilt. Patched to try nouveau before nv."

but theres a pre-existing /etc/modprobe.d/BLACKLIST-nouveau.conf so thats a contradiction is it not?
it can't "try nouveau before nv." if the /etc/modprobe.d/BLACKLIST-nouveau.conf is in effect can it?

weird but it works without an existing xorg.conf...

I'm gonna remove or comment out the /etc/modprobe.d/BLACKLIST-nouveau.conf and see what happens...

After doing the above it loads the nouveau driver correctly and X starts with no xorg.conf
However, the screen "flashes" about every 10 seconds so I must use the /etc/modprobe.d/BLACKLIST-nouveau.conf...

allend 11-22-2010 10:03 AM

If you do 'upgradepkg' the xf86-video-nouveau-git package in /extra then the xf86-video-nouveau-blacklist package is removed which causes the /etc/modprobe.d/BLACKLIST-nouveau.conf to also be removed.
You need the xf86-video-nouveau-git package otherwise X has no nouveau drivers.

dolphin77 11-22-2010 10:03 AM

did noveau driver initialized with KMS enabled? I am on ATI board and it is not working correctly if I am not using KMS. Maybe you need a similar approach?

linus72 11-22-2010 10:08 AM

Thanks allend I'll try it...

dolphin77 I know nothing of KMS
you mean is KMS enabled in kernel?

OK, just tried the git nouveau and same result, intermittent flashing of the screen
so, I'll have to stick with nv or nvidia and blacklist nouveau

wonder what causes the flashing?

I was mistaken...after logging out and back in the git nouveau driver is now not flashing and seems to be working OK!

So, hopefully solved thanks to allend!

linus72 11-22-2010 10:40 AM


Big Question:

Using the new Xorg 1.9.2+ do I need to use the boot parameter "autoexec=xconf" in my live slackware versions using this xorg/mesa??

the xconf script is from Slax and essentially does "X -configure" so is that now obsolete and the slackware/arch nFluxOS builds will no longer need X to be configured as with ubuntu/debian livecd's??

dolphin77 11-23-2010 02:38 AM


Current Status

Quick overview :

KernelModeSetting (KMS) is mandatory
Suspend and resume is working for many chips

2D support is in fairly good shape with EXA acceleration, Xv and Randr12 (dual-head, rotations, etc.).

Any 3D functionality that might exist is still unsupported. Do not ask for instructions to try it. But you can read GalliumHowto in case you are brave enough.

I do not have a nvidia card so I cannot help more.

All times are GMT -5. The time now is 01:32 PM.