-   Slackware (
-   -   Current Update, now can't start desktop??? (

heavyonion 06-17-2013 10:00 AM

Current Update, now can't start desktop???
I have just recently installed Slackware 14 XFCE and last night I uncommitted a current repository source and updated my system. It took a bit of time and then when I restarted I could not get startx to start my desktop. Can I recover this by some commands or do I need to re install?? Slackware is cool!!! I am not new to linux distro's I am just new to Slackware different Beast.
Thank you for your time.

MultiSith 06-17-2013 04:35 PM

It depends what's wrong. I don't know of a way to "roll back" your installed packages though. And, even if you do--any custom configuration may be gone already (unless you made a back-up.)

It could be a simple fix, such as a quick config-file edit, or it could be a version compatibility issue somewhere. Personally, I say just re-install Slackware(since you just installed it anyway). A fresh install will take a few minutes but troubleshooting your issue might take a few hours.

Of course, that isn't what I would do...
If you would like to try to figure out what's wrong. We'll need the error message when you type startx and X's log file (/var/log/Xorg.0.log <-something like this). From there, we should be able to start tracking down what went wrong. Also, which repositories did you uncomment?

TroN-0074 06-17-2013 07:17 PM

Hi heavyonion. There is a subforum dedicated to slackware questions. I would suggest you to post your question there. You should add some more information such as the maker, model, and hardware in your computer. Does your computer has the nvidea video card? Have you tried to start your system in a different runlevel? Include there too what you have tried so far.
Good luck to you.

Tinkster 06-17-2013 07:52 PM

Moved: This thread is more suitable in <Slackware> and has been moved accordingly to help your thread/question get the exposure it deserves.

volkerdi 06-17-2013 07:58 PM


Originally Posted by heavyonion (Post 4973519)
I have just recently installed Slackware 14 XFCE and last night I uncommitted a current repository source

Hmmm.... Slackware 14... current repository source.

If you installed Slackware 14, the way to keep it updated without problems is to use a Slackware 14 repository. If you used a -current repo instead, you're probably missing packages that were added, several of which are now dependencies for getting GTK+ desktops to start properly.

If you're halfway to -current, I do think your best bet is to just make the full leap. Try this:


slackpkg update
slackpkg install-new (probably the missing step)
slackpkg upgrade-all
slackpkg clean-system (careful about this if you have third-party packages, but if you recently installed just do it)

Hope this gets you back on track.

heavyonion 06-18-2013 06:34 AM

Got it.
The advice worked.
Thank you so much for your time.

TroN-0074 06-18-2013 07:41 AM

Hey man, what else you want. Mr Slackware himself answered to your question here. You will never get that kind of customer support from any other software brand out there.

Good luck to you.

bsdunixdb 06-18-2013 06:19 PM

To be fair, There are a couple of distro's out there and at least one BSD where the lead dev's get involved in forum's.

It is just good to know that my favourite distro is included.

TroN-0074 06-18-2013 06:56 PM

By the way. Big THANK YOU, Pat for all your time and dedication put in to SlackWare we highly appreciate it.

san2ban 06-18-2013 11:51 PM

Pl. mark this thread as 'solved'

All times are GMT -5. The time now is 12:19 PM.