-   Slackware (
-   -   Current: udev problem with hplip-3.13.8/1 (

burdi01 08-22-2013 05:15 AM

Current: udev problem with hplip-3.13.8/1
The hplip-3.13.8/1 from the Wed Aug 21 21:26:58 UTC 2013 updates shows the same longish hiccup at start as hplip-3.13.5/1 did - see for details.
As it turns out /lib/udev/rules.d/56-hpmud.rules still needs the backgrounding *) as depicted in timkb4cq's May 31, 2013 post for that thread.

*) The 2> redirection is no longer needed.

Edit Aug 29, 2013: Amended the link (removed the leading "//"). :redface:

aus9 08-29-2013 12:36 AM


not sure if you were hoping this remain a zero reply post but your link did not work for me. But thankyou for the user name so for others the link appears to be

with OP giving info that the 2> section of the command, no longer needed

tronayne 08-29-2013 07:47 AM

I have the same problem, Slackware 14.0 stable (fully patched) and hplip-3.13.8-x86_64-1 (from H-P's download sit, built with the SlackBuild) -- long delay at boot.

Looking through all the discussions at the links provided above, everything points to a line in /lib/udev/rules.d/56-hpmud.rules

VNUM}'", RUN+="/bin/sh -c 'if [ -f /usr/bin/systemctl ]; then /usr/bin/systemctl --no-block start hp lip-printer@$env{BUSNUM}:$env{DEVNUM}.service; else /usr/bin/nohup /usr/bin/hp-config_usb_printer $env{BUSNUM}:$env{DEVNUM} ; fi'"
Slackware 14.0 stable doesn't have systemctl, so that isn't a problem.

The post immediately above indicates that the problem is associated with loading a plug-in, but none of my printers need plug-ins (the only one that's USB is a Photosmart C-4680).

I do build HPLIP from source with the SlackBuild from the ap directory; it compiles without error and runs just fine except for the boot delay.

If I remember correctly, hplip-3.13.6 worked correctly (no problems with printing, scanning or boot delay). So I went to SourceForge and got that back and I'm going to try it and see what happens (not a fix, tried those, no joy there).

Well, that was an exercise in futility -- hplip-3.13.6 exhibits the same boot delay on my desktop but not on my laptop; the laptop may be out-of-date with patches that will take some fiddling around to figure out.

OK, heck with it, go get the hplip source directory from -current (with, build it, upgradepkg and see what that's going to do.

Seems to work.

I still wonder what the actual problem is -- you go from 3.13.6 to 3.13.7 to 1.13.8 and what the heck happened somewhere in the process.


burdi01 08-30-2013 03:52 AM

See the Fri Aug 30 06:26:06 UTC 2013 entry at

All times are GMT -5. The time now is 01:38 AM.