-   Slackware (
-   -   current: qt-documentation tool assistant crashes (

hj1967 07-01-2012 10:59 AM

current: qt-documentation tool assistant crashes
running slackware current - 29-06-2012 64bit on core i5 2500.

Assistant crashes on startup

hjp1:~> /usr/bin/assistant
QGtkStyle was unable to detect the current GTK+ theme.
Segmentation fault

From the debugger:
Program received signal SIGSEGV, Segmentation fault.
0x00007ffff3b7392b in __memcpy_sse2 () from /lib64/
(gdb) bt
#0 0x00007ffff3b7392b in __memcpy_sse2 () from /lib64/
#1 0x000000000044edfd in ?? ()
#2 0x000000000044cc52 in ?? ()
#3 0x000000000044daf8 in ?? ()
#4 0x0000000000426918 in ?? ()
#5 0x00007ffff3b05a95 in __libc_start_main () from /lib64/
#6 0x00000000004276e9 in ?? ()
#7 0x00007fffffffdfa8 in ?? ()
#8 0x000000000000001c in ?? ()
#9 0x0000000000000001 in ?? ()
#10 0x00007fffffffe2df in ?? ()
#11 0x0000000000000000 in ?? ()

It seems the same bug as here.

The fix in the bugreport fixes in the problem in my local QT 4.8.2 version.

ponce 07-01-2012 11:59 AM

FYI, the qt-4.8.1 in 64-current doesn't seem affected.

volkerdi 07-01-2012 12:35 PM

It runs once, and then crashes the next time. Unfortunately, I tried the patch here and now I get this:

*** glibc detected *** assistant: corrupted double-linked list: 0x0000000000b63910 ***

And assistant hangs presenting a blank window.

hj1967 07-01-2012 01:04 PM

I applied the patch to the Digia Qt 4.8.2 version and there it fixed the problem. I have not tested it with the Slackware but
because both the assistant had the same crash I assumed it might fix the problem.

Anyway I guess you can leave this a known issue.

ponce 07-01-2012 01:25 PM


Originally Posted by volkerdi (Post 4716458)
It runs once, and then crashes the next time.

ops, I can confirm this :(
sorry for the too fast and wrong report.

Alien Bob 07-01-2012 03:02 PM

The segfault does not occur when you remove the sqlite database ${HOME}/.local/share/data/Trolltech/Assistant/qthelpcollection_4.8.1.qhc prior to starting assistant. That is why assistant will run the first time you start it - it has not created that database yet.

But this is of course not a real solution.


ponce 07-02-2012 08:27 AM

I've tried upgrading qt to 4.8.2 (as suggested by hj1967) using the slackbuild in -current (commented out two patches that got in in the meantime) and using the patch and assistant seems to work fine (kde and other qt apps I tested too -obviously I'm speaking about the stuff I tested), but really don't know if moving to the .2 qt is an option...

hj1967 07-02-2012 09:17 AM

I use Qt in projects at my work have mixed experiences with upgrade of Qt. In our case moving from 4.8.1 to 4.8.2 went without problems and
solved some memory leaks as well.
In Slackware the Qt 4.8.1 is a patched version for certain KDE apps if I am right. I have no idea if these fixes are
in the official Qt 4.8.2. Maybe the KDE developers know if it is save to upgrade to 4.8.2

ponce 07-02-2012 10:44 AM

in the meantime, I had a rapid look at the kde bugtracker looking for "qt-4.8.2": this here seems to apply.

ponce 07-02-2012 11:25 PM

seems like the akonadiconsole crash on start is solved with just rebuilding it over qt-4.8.2.


In Slackware the Qt 4.8.1 is a patched version for certain KDE apps if I am right.
If I don't got it wrong, it was like this in the past when the qt version used was the one in the kde repository, now the standard qt sources as released by upstream qt devs are used.

All times are GMT -5. The time now is 05:54 PM.