LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-14-2011, 10:27 AM   #1
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,519

Rep: Reputation: 62
--current, hibernate not working


Hello all,

On my netbook here, I did a fresh install of --current.

I cannot get hibernate to work, it seems to fall back to suspend.

In /var/log/pm-powersave.log I get this message:

/usr/lib/pm-utils/power.d/sched-powersave false: success.
Running hook /usr/lib/pm-utils/power.d/wireless false:
Turning powersave for wlan0 off...Error for wireless request "Set Power Management" (8B2C) :
SET failed on device wlan0 ; Operation not supported.
Failed

The netbook then seems to fallback to suspend at that point.

Thanks in advance.
 
Old 03-14-2011, 01:08 PM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 10,360

Rep: Reputation: 1147Reputation: 1147Reputation: 1147Reputation: 1147Reputation: 1147Reputation: 1147Reputation: 1147Reputation: 1147Reputation: 1147
Have you a resume partition (use swap) set? Is it big enough?

Post the o/p of
cat /sys/power/state
 
Old 03-14-2011, 11:43 PM   #3
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,519

Original Poster
Rep: Reputation: 62
Hello,

from the free command:

Mem: 1014400 646044 368356 0 43772 325752
-/+ buffers/cache: 276520 737880
Swap: 1076316 0 1076316

my fstab:
/dev/sda6 swap swap defaults 0 0

from lilo.conf:
image = /boot/vmlinuz-generic-smp-2.6.37.3-smp
root = /dev/sda5
label = Linux
read-only
initrd = /boot/initrd.gz-2.6.37.3-smp

from my mkinitrd.conf:
# mkinitrd.conf.sample
# See "man mkinitrd.conf" for details on the syntax of this file
#
SOURCE_TREE="/boot/initrd-tree"
#CLEAR_TREE="0"
OUTPUT_IMAGE="/boot/initrd.gz"
#KERNEL_VERSION="$(uname -r)"
#KEYMAP="us"
MODULE_LIST="ext4"
#LUKSDEV="/dev/sda2"
#LUKSKEY="LABEL=TRAVELSTICK:/keys/alienbob.luks"
ROOTDEV="/dev/sda5"
#OOTFS="ext4"
RESUMEDEV="/dev/sda6"
#RAID="0"
#LVM="0"
#UDEV="1"
#MODCONF="0"
#WAIT="1"

So unless I'm missing something, I think I have all my bases covered here.

I even went so far as to issue hibernate as root, and the pc simply goes into standby.
 
Old 03-15-2011, 03:45 AM   #4
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 10,360

Rep: Reputation: 1147Reputation: 1147Reputation: 1147Reputation: 1147Reputation: 1147Reputation: 1147Reputation: 1147Reputation: 1147Reputation: 1147
It's easier to go from scratch:

You need resume=/dev/sdax as a kernel boot parameter, that drive defined in fstab as swap, if you're compiling a kernel put resume device in there.

The o/p of cat /sys/power/state should include the work disk. Hibernate manually with

sync; echo -n disk > /sys/power/state

Does it work, or what error does it throw?
 
Old 03-15-2011, 12:40 PM   #5
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,519

Original Poster
Rep: Reputation: 62
Sorry my mistake, I did indeed have the resume= line in my lilo.conf up at the global append line.

I moved it down to the specific kernel as you suggested, reran lilo and still no luck.

What is interesting is:

when pm-hibernate is called, both /var/log/pm-powersave.log and /var/log/pm-suspend.log are updated to the time that I issued the hibernate command. Perhaps because hibernate is called, then fails, then it falls back to suspend; I'm not sure.

There is one line in the hibernate log that seems worth mentioning:

"/usr/lib/pm-utils/pm-functions: line 316: echo: write error: No such device"

And in the suspend log, there are these lines that are worth mentioning as well:

/usr/lib/pm-utils/power.d/sched-powersave false: success.
Running hook /usr/lib/pm-utils/power.d/wireless false:
Turning powersave for wlan0 off...Error for wireless request "Set Power Management" (8B2C) :
SET failed on device wlan0 ; Operation not supported.
Failed.

Seeing the wlan0 error there I just issued the hibernate again, and indeed the wifi is not turned off at all.

My netbook uses ath5k and I'm using wicd. I think I'm going to try blacklisting wifi as a test and see if anything changes. Will report back.
 
Old 03-15-2011, 12:59 PM   #6
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,519

Original Poster
Rep: Reputation: 62
business_kid thanks again for all your help. It turns out I had the wrong partition number for swap in my lilo.conf. I cannot believe I didn't catch that, but none the less it works now. Thank again.
 
Old 03-16-2011, 03:24 AM   #7
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 10,360

Rep: Reputation: 1147Reputation: 1147Reputation: 1147Reputation: 1147Reputation: 1147Reputation: 1147Reputation: 1147Reputation: 1147Reputation: 1147
You're Welcome - we old fogies have to stick together ;-). I'm doing engineering in College, and old enough to be father to most of the students. Not the lecturers, thankfully.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Resume after hibernate - slackware-current Chuck56 Slackware 15 03-29-2011 09:18 AM
tuxonice kernel, tuxoniceui_text. and hibernate on -current... linus72 Slackware 4 09-27-2010 12:00 PM
intel i810 pm-hibernate --current Old_Fogie Slackware 2 02-06-2010 08:28 PM
Wireless not working after Hibernate BogusTrumper Linux - Software 1 04-21-2007 05:18 PM
hibernate not working any more jnsenit Linux - Laptop and Netbook 0 11-24-2004 02:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration