-   Slackware (
-   -   current + fakeroot (

Speek 03-19-2007 06:38 AM

current + fakeroot
I always build my Slackware packages using Slackbuilds as normal user with fakeroot. With all the updates from current installed I can't get fakeroot working anymore. I've tried updating to the latest fakeroot (1.6.4), tried --with-ipc=tcp, tried making /usr/lib/ SUID, but nothing works.
Anybody else using fakeroot with up-to-date current?

jong357 03-19-2007 12:02 PM

Fakeroot has issues with newer versions of some packages. Bash maybe and possibly others. Read the DIY mailing list (G.S. uses fakeroot extensively) and Debian bug reports ( I think fakeroot is debian maintained) for more info. You don't say what problems your having so I can't really help you more than that.

Speek 03-19-2007 01:52 PM

Thanks for the pointer to DIY Linux. They have this message in the guide: "Current Fakeroot has problems with Coreutils 6.x and above when the Coreutils are compiled against Glibc 2.4 and above. Please refer to Section 4.18, “Coreutils-6.7” to see how we've worked around it for now. We expect upstream will release a fixed Fakeroot version soon." So I guess I'll have to build packages as root for a while. If I find out something useful I'll report it here.

jong357 03-20-2007 01:36 PM

Wow, I just checked the current changelog and Pat has gone all bleeding edge... ;) What's up with these posts about "current not up to date"? "Stable" most certainly is... Glibc-2.5, gcc-4.1.2, binutils-2.17.x, coreutils-6.7, Xorg-7.2... That's more bleeding edge than I like to do myself... :scratch: Holy crap. Never thought I'd see the day when Slackware would do that.

So, yea... That's probably your issue. Current coreutils-6.7 was built against glibc-2.5 but fakeroot probably isn't being maintained all that well (It's a debian thing, what do you expect?)

Why don't you download the current source directory of coreutils from slackware current and pass


./configure ac_cv_func_openat=no
to the build script? That should fix your problem... Assuming your hitting a perms problem as the DIY mailing list suggests. Just make sure you build the package with the build number ONE HIGHER than what is installed and do an "upgradepkg"... I'm sure I don't need to tell you not to do a "removepkg" on coreutils... ;)

h4kteur 03-21-2007 06:39 PM

after looking around for a while, I found this bug report from debian. There is a patch for fakeroot 1.5.10 who worked for me. I hope it'll do the job for you.

Speek 03-22-2007 04:31 AM


Originally Posted by h4kteur
after looking around for a while, I found thie bug report from debian. There is a patch for fakeroot 1.5.10 who worked for me. I hope it'll do the job for you.

Hey that's great! It seems to work well. I've made a Slackware package:

h4kteur 04-15-2007 09:49 AM

with fakeroot 1.7, the patch isn't needed anymore.

All times are GMT -5. The time now is 04:25 AM.